Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Очистить таблицу

Ø
Я
   cherv
17.11.04 - 15:59
Как очистить таблицу в режиме ввода данных
 
 
   Gloom
1 - 17.11.04 - 16:04
Вот примерчик:
//****************************************************
Процедура ОчиститьТаблицу()
  Для НомСтр=13 По СтрокВТаблице Цикл
    Для НомСтолб=1 По 12 Цикл
      Обл=Таблица.Область(НомСтр,НомСтолб);
      Обл.Текст="";
      Обл.Рамка(0,0,0,0);
      Обл.РазмерШрифта(НормРазмерШрифта);
      Обл.Полужирный(0);
    КонецЦикла;
  КонецЦикла;	
  СтрокВТаблице=12;
  Таблица.ОбластьПечати(,,СтрокВТаблице);
КонецПроцедуры//ОчиститьТаблицу()
   Cerrg
2 - 17.11.04 - 16:10
ТвояТаблица.Очистить();
   cherv
3 - 17.11.04 - 16:16
(1) Ну в общем понятно, спасибо. Просто я думал, что можно очистить каким-то методом...
(2) Так не работает (именно для таблицы для ввода данных)
   Cerrg
4 - 17.11.04 - 16:29
Хошь пример? дай мыло
   cherv
5 - 17.11.04 - 16:47
(4) vchernyshev@park.ru
   Cerrg
6 - 17.11.04 - 17:07
Отослал



Список тем форума

Форум Территория 1С

Рекламное место пустует  
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует