Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Как в константу добавить группу справочника?

Ø
Я
   Sergilov
12.11.04 - 16:50
Процедура ПриВыбореРодителя(Род)
  Если НазваниеНабораПрав()="Основной" Тогда
    Если Род=Константа.ЗакрытаяГруппа Тогда
      Сообщить("Вам запрещен доступ к эитой группе ТМЦ");
      СтатусВозврата(0);
    КонецЕсли;
  КонецЕсли;
КонецПроцедуры
Все вроде зашибись, но только группу не могу впихнуть в константу ЗакрытаяГруппа. Требует выбора элемента. Помогите. Посоветуйте. Научите.
 
 
   YF
1 - 12.11.04 - 16:51
А если через обработку попробовать, сделать там реквизит, выбрат группу, потом по кнопке записать в константу.
Правда сам не пробовал ...
   sergfor1c
2 - 12.11.04 - 16:56
Для полной секретности сохрани в константе код группы.
И делай проверку СокрЛП(Элемент.Родитель.Код) = СокрЛП(ТвояКонстанта)
   Bot
3 - 12.11.04 - 16:57
+(1) должно заработать! Сам не пробовал, но уверен на все 117%.:))
   FlyS
4 - 12.11.04 - 16:58
В контанту поставить елемент с Закрыот группы, а потом по этому элементы выйти на родителя, правда ПриВыбореРодителя уже не прокатит.
   Kote
5 - 12.11.04 - 16:59
(1) Я пробовал, работает
   Sergilov
6 - 12.11.04 - 17:09
(1) И впрямь работает! ;-)



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует