Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Есть ли возможность спозиционироваться программно в форме списка?

Ø
Я
   Игорек
11.11.04 - 11:22
Есть ли возможность спозиционироваться программно в форме списка справочника?
Везде у методов есть замечание "Метод можно использовать только для объектов, созданных функцией СоздатьОбъект."
А мне нужно программно :(
т.е. при открытии формы справочника сделать текущим элемент, который известен заранее...
Может кто знает как?
 
 
   A78
1 - 11.11.04 - 11:34
АктивизироватьОбъект()
   Игорек
2 - 11.11.04 - 11:36
помощь все ещё нужна... вроде вопрос простой...
   Муму после всплытия
3 - 11.11.04 - 11:36
............... только ПриОткрытии не получится..............
   Кортес
4 - 11.11.04 - 11:37
(3) почему?
   Игорек
5 - 11.11.04 - 11:39
1 Можно пример кода?
т.е. эл. спр. в переменной ВыбЭл.
   Муму после всплытия
6 - 11.11.04 - 11:41
(4)
Формы еще нету....................
   Кортес
7 - 11.11.04 - 11:43
(6) Недоперепонял.
   A78
8 - 11.11.04 - 11:44
Форма списка, Процедура ПриОткрытии():
Спр=СоздатьОбъект("Справочник.Сотрудники");
Спр.НайтиПоКоду("0000000001");
АктивизироватьОбъект(Спр.ТекущийЭлемент());
   Игорек
9 - 11.11.04 - 11:47
Ё моё, даже уже в открытой форме не пашет :(
АктивизироватьОбъект(Спр.ТекущийЭлемент());
{Справочник.МестаХранения.ФормаСписка.ДляПодбора.Модуль(15)}: В данной формуле не может быть вызвана эта процедура(функция)
   Кортес
10 - 11.11.04 - 11:49
(9) Игорек, чувствуешь разницу между "при открытии" и "уже в открытой форме"?
 
  Рекламное место пустует
   A78
11 - 11.11.04 - 11:49
Проверял на "Сотрудниках". Форма списка. работает
   Игорек
12 - 11.11.04 - 11:53
(10) Хмм... ну а в уже открытой форме реально спозиционировать или нет?
   A78
13 - 11.11.04 - 11:55
Добавь кнопку, повесь на нее процедуру и дави...
   bsg
14 - 11.11.04 - 11:55
(12) Из кнопки позиционируйся, а не из реквизита.
   Игорек
15 - 11.11.04 - 12:03
Так по кнопке он, при натыкании на метод пишет: В данной формуле не может быть вызвана эта процедура(функция)
:-(
   A78
16 - 11.11.04 - 12:11
Правильно. Этот метод может исп-ся только в модуле формы, но у тебя в вопросе, цитирую "...т.е. при открытии формы справочника...".
   A78
17 - 11.11.04 - 12:13
+16. И какая вообще стоит задача?
   A78
18 - 11.11.04 - 12:19
В форме списка справочника есть кнопка. По ней вызываем процедуру:
Процедура Кнопка()
  
  Спр=СоздатьОбъект("Справочник.Сотрудники");
  Спр.НайтиПоКоду("0000000001");
  АктивизироватьОбъект(Спр.ТекущийЭлемент());
  
КонецПроцедуры
   Муму после всплытия
19 - 11.11.04 - 12:23
(15)
по моему вам есть смысл использовать ОткрытьПодбор()
   Игорек
20 - 11.11.04 - 12:25
18 - именно так и не работает
19 - именно в форме подбора пытаюсь это сделать :)
   Муму после всплытия
21 - 11.11.04 - 12:28
(20)
я не про форму.................... я про метод................ там есть 5-й параметр
   anna187
22 - 11.11.04 - 12:30
(20) Я не волшебник, а пока только учусь. Но подобная процедура точно работает в ФормеСписка->ФормаСписка, а у тебя ФормеСписка->ФормаПодбора. Думаю в этом все дело
   bsg
23 - 11.11.04 - 12:31
Гонишь ты что-то.
Посмотри в ТиС справочник "Номенклатура". Там прозиционируются и из кнопки и из ТЗ.
   A78
24 - 11.11.04 - 12:33
В бухе в форме для подбора номенклатуры тоже все чудесно работает и по кнопке и при открытии
   Игорек
25 - 11.11.04 - 13:07
(21) АктивизироватьОбъект(Спр.ТекущийЭлемент());
один параметр - элемент справочника
   Кортес
26 - 11.11.04 - 13:11
Бесполезно...
   Игорек
27 - 11.11.04 - 13:13
26 не будет работать?
   Kvantic
28 - 11.11.04 - 13:31
Вот здесь есть одно решение
http://www.sinor.ru/~my1c/knowhow/getskod.html
   Игорек
29 - 11.11.04 - 13:43
(28) Ха! РАБОТАЕТ, но позиционируется на ТАБЛИЧНУЮ ЧАСТЬ,
а не на КОНКРЕТНЫЙ ЭЛЕМЕНТ в СПРАВОЧНИКЕ :(((
   Игорек
30 - 11.11.04 - 13:59
up
   Kvantic
31 - 11.11.04 - 14:31
А может быть это проблема "кривые ручки"
Вот только что попробовал тестик написал
Это обработка в ней выбираю в реквизите диалога П - нужный мне элемент справочника и вызываю форму. В ней позиционируюсь. Работает железно.
//*******************************************
Процедура Выполнить()
  Пар=П.ТекущийЭлемент();
  ОткрытьФорму("Справочник.Номенклатура",Пар);
КонецПроцедуры// Форма списка справочника
Процедура ПриОткрытии()
  Т=Форма.Параметр;
  Если ПустоеЗначение(Т)=0 Тогда
    АктивизироватьОбъект(Т);
  КонецЕсли;
КонецПроцедуры
   Игорек
32 - 11.11.04 - 15:27
ПриЗакрытии()
не работает :(




Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует