Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

v7.7: Бухгалтерия 460 релиз Как победить таблицу значений

Ø
Я
   Сигизмунд
11.11.04 - 15:16
Народ! Когда вставляю в процедуру оператор: ТаблицаДанных.Свернуть("2","4"); и запускаю на выполнение выскакивает ошибка:
"Поле агрегатного объекта не обнаружено (Статья)
Поле агрегатного объекта не обнаружено (ДеловаяАктивность)
ТаблицаДанных.Статья = Ит.Субконто(2);
{C:\1C\ОБРАБОТКИ\СВОДКА РАСХОДОВ СЕБЕСТОИМОСТИ2.ERT(64)}: Поле агрегатного объекта не обнаружено (Статья)"
убираю оператор "Свернуть" и прога работает как часы. В чем баг? Или у меня глаз замылился и косяк свой не вижу. Помогите люди добрые, код процедуры прилагаю
Процедура Сформировать()
  Перем ТекущийСубСчет;
  
  
  Таб           = СоздатьОбъект("Таблица");
  ТаблицаДанных = СоздатьОбъект("ТаблицаЗначений");
  ТаблицаДанных.НоваяКолонка("Статья");
  ТаблицаДанных.НоваяКолонка("Подразделение");
  ТаблицаДанных.НоваяКолонка("ДеловаяАктивность");
  ТаблицаДанных.НоваяКолонка("Сумма");
  Таб.ИсходнаяТаблица("Сформировать");
  Ит = СоздатьОбъект("БухгалтерскиеИтоги");
  
  Ит.ИспользоватьСубконто("ВидыНоменклатуры");
  Ит.ИспользоватьСубконто("СтатьиЗатратНаПроизводство");
  Ит.ИспользоватьСубконто("Подразделения");
  Ит.ВключатьСубсчета(1);
  Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "20;25;26",,, 1,, "С");
  
  
    Ит.ВыбратьСчета(1);
  Пока Ит.ПолучитьСчет() = 1
  Цикл ТекущийСубСчет = Ит.Счет;
  
    Таб.ВывестиСекцию("счета");
      Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) =1
    Цикл Если Ит.Субконто(1).Родитель <> НужныйРодитель Тогда Продолжить КонецЕсли;
      
       Таб.ВывестиСекцию("ВидыНоменклатуры");
       Ит.ВыбратьСубконто(2);
      
       ТаблицаДанных.УдалитьСтроки();
      
       Пока Ит.ПолучитьСубконто(2) =1
       Цикл
       	       Ит.ВыбратьСубконто(3);
          	   Пока Ит.ПолучитьСубконто(3) = 1
             Цикл
             	
             	    ТаблицаДанных.НоваяСтрока();
             		ТаблицаДанных.Статья            = Ит.Субконто(2);
             		ТаблицаДанных.Подразделение     = Ит.Субконто(3);
             		ТаблицаДанных.ДеловаяАктивность = Ит.Субконто(2).ДеловаяАктивность;
             	    ТаблицаДанных.Сумма             = Ит.ДО();
             КонецЦикла;
         КонецЦикла;
     		    ТаблицаДанных.Свернуть("2","4");
        ТаблицаДанных.Сортировать("Подразделение+");
          ТаблицаДанных.ВыбратьСтроки();
     		    Пока ТаблицаДанных.ПолучитьСтроку() = 1
      		Цикл Таб.ВывестиСекцию("строкатаблицы");
     		    КонецЦикла;
    КонецЦикла;
  КонецЦикла;	
  Таб.ТолькоПросмотр(1);
  Таб.Показать("Сформировать","");
КонецПроцедуры
 
 
 
   Сигизмунд
1 - 11.11.04 - 15:18
up
   Джинн
2 - 11.11.04 - 15:18
После ТаблицаДанных.Свернуть("2","4") в ТаблицаДанных остаются только две колонки - 2,4. И никакой деловой активности :)
   Сигизмунд
3 - 11.11.04 - 15:22
вот блин!
2 Джинн спасибо за подсказку



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует