Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Регистры

Ø
Я
   coma
10.11.04 - 15:13
Может кто подскажет в чем проблема?
Для Инд = 1 По Метаданные.Регистр() Цикл
Рег = СоздатьОбъект("Регистр."+Метаданные.Регистр(Инд).Идентификатор);
Рег.ВыбратьДвижения();
Пока Рег.ПолучитьДвижение()=1 Цикл
Для Инд1 = 1 По Метаданные.Регистр(Инд).Измерение() Цикл
ИдРекв = Метаданные.Регистр(Инд).Измерение(Инд1).Идентификатор;
Если Рег.ПолучитьАтрибут(ИдРекв)= Э1 Тогда
 Рег.УстановитьАтрибут(ИдРекв,ЭлЗамена)// Выдавет сообщение об ошибке "Действие недоступно!"
 
КонецЕсли;
КонецЦикла;
Для Инд1 = 1 По Метаданные.Регистр(Инд).Ресурс() Цикл
ИдРекв = Метаданные.Регистр(Инд).Ресурс(Инд1).Идентификатор;
Если Рег.ПолучитьАтрибут(ИдРекв) = Э1 Тогда
 Рег.УстановитьАтрибут(ИдРекв,ЭлЗамена);
КонецЕсли;
КонецЦикла;
Для Инд1 = 1 По Метаданные.Регистр(Инд).Реквизит() Цикл
ИдРекв = Метаданные.Регистр(Инд).Реквизит(Инд1).Идентификатор;
Если Рег.ПолучитьАтрибут(ИдРекв)= Э1 Тогда
 Рег.УстановитьАтрибут(ИдРекв,ЭлЗамена);
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;
 
  Рекламное место пустует
   YF
2 - 10.11.04 - 15:15
Тему неправильно назвал.
   Пшзукшщт
3 - 10.11.04 - 15:16
тоись етой абработкай ты пытаеся с аднаво измерения перенести на друое все движения?
   coma
4 - 10.11.04 - 15:17
(3)изменить одно измерени на другое.
   coma
6 - 10.11.04 - 15:22
(5) э1= элемент заменяемый, ЭлЗамена - элемент замена
   YF
8 - 10.11.04 - 15:23
Я всегда был уверен, что все изменения регистров 1С позволяет делать либо документами, либо внешними компонентами, либо прямой записью в таблицы ...
   Ghost
9 - 10.11.04 - 15:24
Вообще-то изменять движения регистров можно только документами в предопределенной процедуре модуля документа "ОбработкаПроведения".
   coma
11 - 10.11.04 - 15:26
т.е. это метод УстановитьАтрибут()для регистра, работает только в ОбработкеПроведния()?
   Пшзукшщт
12 - 10.11.04 - 15:30
мдя. во первых изменения в регистре производятся тока методами ДвижениеВыполнить()
ДвижениеПриход\РасходВыполнить()
ДвижениеПриход\Расход
ДвижениеВыполнить()
Движение()
все. УстановитьАтрибут используется в модуле проведения документа для того чтобы установить значение измерений пере тем как сделать ДвижениеВыполнить() или ДвижениеПриход\РасходВыполнить()
вот и все. значения измерений заменить так низя...
   coma
13 - 10.11.04 - 15:42
up



Список тем форума

Форум Территория 1С

  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует