Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Выбор группы подчинённого справочника. Помогите !

Ø
Я
   Aleks73
10.11.04 - 14:16
Установил Форма.Реквизит.ВыборГруппы(1) , а при открытии - Реквизит.использоватьВладельца(Владелец).
всё равно при попытке выбрать сначала открывается справочник-владелец, и группа не выбирается.
Помогите !
 
 
   Пшзукшщт
1 - 10.11.04 - 14:22
клева. а в Форма.Реквизит праписана с чем связан етот реквизит?
   Aleks73
2 - 10.11.04 - 14:23
(1) Не понял. Реквизит типа справочник.
   ValeraVV
3 - 10.11.04 - 14:24
у тя владелец откуда берется?
   Туxлый
4 - 10.11.04 - 14:26
В свойчтвах реквизита формы в закладке "дополнительно" надо прописать ид реквизита-владельца в поле "связан с".
   Aleks73
5 - 10.11.04 - 14:26
Владелец - реквизит другого справочника. Заполняется в той же форме
   Пшзукшщт
6 - 10.11.04 - 14:29
ета седня тока клиника?
ЗЫ давно я проста тут не был...
   Aleks73
7 - 10.11.04 - 14:30
Тухлый, спасибо, вопрос с владельцем снят. Как бы ещё снять вопрос с выбором группы...
   Aleks73
8 - 10.11.04 - 14:32
Пшзукшщт, спасибо за поднятие ветки. Продолжайте дальше так же.
   Aleks73
9 - 10.11.04 - 14:34
Тухлый, спасибо, и группа стала выбираться. Что бы я без тебя делал ! Теперь есть надежда, что нам вовремя дадут зарплату !!!
   ValeraVV
10 - 10.11.04 - 14:36
Хех. Думал Тухлый, а зарплту Aleks73 получит.............
 
  Рекламное место пустует
   Aleks73
11 - 10.11.04 - 14:40
(10) К сожалению, Тухлый не оставил мыла...
   YF
12 - 10.11.04 - 14:43
(11) А что, зарплату теперь на мыло перечисляют? Сам ПО написал для этого?
   Пшзукшщт
13 - 10.11.04 - 14:46
(8) па мойму атвет ужэ в 1 был дан. или я не Пшзукшщт. :)
   Aleks73
14 - 10.11.04 - 14:47
(12) Не писал, но ничего сложного в этом нет. Правда, из-за ошибки в 1С её при этом нельзя обналичить.
   ValeraVV
15 - 10.11.04 - 14:48
Так как Тухлый не отвечает предлахаю поделить ЗП Aleks73 между (1) и (3)....
   Aleks73
16 - 10.11.04 - 14:50
(13)
Найдите 10 различий (для сведения - я никогда раньше не пользовался свойством "Связан с") :
1 вариант. "клева. а в Форма.Реквизит праписана с чем связан етот реквизит?"
2 вариант. "В свойчтвах реквизита формы в закладке "дополнительно" надо прописать ид реквизита-владельца в поле "связан с"."
   Aleks73
17 - 10.11.04 - 14:53
(15) Могу написать обработку для перечисления на мыло (без возможности обналичивания, см (14)). Стоимость написания обработки предлагаю поделить между... см (15)
   ValeraVV
18 - 10.11.04 - 14:57
Хоть пивом бы угостили. Эх, жадный вы человек Aleks73.
Тыхлый, я и gipekiot ведь совершенно безвоздмездно по вашему поводу голову напрягали, а вы.......
   Пшзукшщт
19 - 10.11.04 - 14:59
(18) эк ка ты миня езвратил...ета в атмеску за мой русский?:)))
   Aleks73
20 - 10.11.04 - 15:00
(18) Я правда сам не употребляю пиво. Но если ты из моего города - столица нашей Родины - то оставь мыло. (Пиво после зарплаты). А Тухлый, значит, без пива останется ?!! ValeraVV, это не справедливо !
   Пшзукшщт
22 - 10.11.04 - 15:05
(16)но впринцыпе можа и так:
Процедура ОбработкаПодбора(пЭлемент)
   Реквизит = пЭлемент;
КонецПроцедуры
Процедура ПриНачалеВыбораЗначения(пИдентЭлемДиалога, пФлагСтандОбр)
   Перем лКонтекстФормы;
   Если пИдентЭлемДиалога = "Реквизит" Тогда
      ОткрытьПодбор("Справочник." + Реквизит.Вид(), лКонтекстФормы);
      лКонтекстФормы.ИспользоватьВладельца(РеквизитВладелец);
      пФлагСтандОбр = 0
   КонецЕсли
КонецПроцедуры
:)
      
   Mandela
23 - 10.11.04 - 15:08
(21) А зачем? В смысле раскладку переключал?...
   ValeraVV
24 - 10.11.04 - 15:09
(23) а вот не умею я так по русски писать..........
   Пшзукшщт
25 - 10.11.04 - 15:09
(23) имхо у нево язык не павернулся на русском ето праизнести:))
   Aleks73
26 - 10.11.04 - 15:13
ИМХО, в функции ОткрытьПодбор одну запятую забыл.
Но вообще пробовать некогда сейчас, срочно сдать работу надо....
   Mandela
27 - 10.11.04 - 15:14
(24) Я тож безрукий и слипой б/п, но Copy+Paste спасает :)
(25) Тринероваццо надо... :)
   YF
28 - 10.11.04 - 15:21
Небольшое замечание по поводу "Связан с"
Реквизит1, реквизит2 из подчиненного к Реквизит1 справочника
На форме в Реквизит2 Связан с="Реквизит1"
Если для Реквизит2 не указать форму для выбора, тогда при попытке выбрать Реквизит2, при не выбранном Реквизит1 открывается форма выбора Владельца. После выбора 1С замирает и ... падает.
   Aleks73
29 - 10.11.04 - 15:25
(28) У меня не наблюдается. 1С с ключом.
   YF
30 - 10.11.04 - 15:28
(29) У меня наблюдается. 1С с ключом. 21 релиз для СКЛ, база ДБФ.
   Aleks73
31 - 10.11.04 - 15:38
(30) 23 релиз. Остальное то же. МД большой, но модуль формы могу прислать. Поймёшь...




Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует