Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Запись констант в цикле

Ø
Я
   Agente Secreto
10.11.04 - 09:24
Нужно установить значения констант в цикле, используя одноименные реквизиты справочника...
Применяю Метаданные, с обычными константами ясно, но как быть с периодическими?
Вот код:
  Для к=1 По Метаданные.Константа() Цикл
    
    ТекИдентификатор=Метаданные.Константа(к).Идентификатор;
    
    Для н=1 По Метаданные.Справочник("Фирмы").Реквизит() Цикл
      Если ТекИдентификатор<>Метаданные.Справочник("Фирмы").Реквизит(н).Идентификатор Тогда
        Продолжить;
      КонецЕсли;
      Если Метаданные.Справочник("Фирмы").Реквизит(н).Периодический=1 Тогда
        ФирмаСпр.ИспользоватьДату(ТекущаяДата());
        Константа.УстановитьАтрибут(ТекИдентификатор,ФирмаСпр.ПолучитьАтрибут(ТекИдентификатор));
      Иначе
        Константа.УстановитьАтрибут(ТекИдентификатор,ФирмаСпр.ПолучитьАтрибут(ТекИдентификатор));
      КонецЕсли;			
      Прервать;
    КонецЦикла;
    
    
    
  КонецЦикла;
Как в данном случае записывать период. константы?
Заранее спасибо
 
 
   Жюль
1 - 10.11.04 - 09:30
Ты имеешь в виду константа.БлаБлаБла.Установить() ?
   Agente Secreto
2 - 10.11.04 - 09:36
У меня БлаБлаБла - неизвестна.....
я могу получать константу только по атрибуту....
я ведь не могу написать Константа.ТекИдентификатор.Установить(,)....
   Agente Secreto
3 - 10.11.04 - 09:38
просто, применительно к справочнику можно применить ИспользоватьДату(), что-нить подобное есть для констант?
   Diter
4 - 10.11.04 - 09:41
Вот как это деалется с реквизитами справочника
ЗначениеПоля=ПодчиненныйЭлемент.УстановитьАтрибут(Значение).Установить(ТекущаяДата());
   Diter
5 - 10.11.04 - 09:43
(4)Не так блин. Не из того кода кусок выдернул. Щас найду
   Agente Secreto
6 - 10.11.04 - 09:58
Dieter, так как это будет, применительно к константам?
   Diter
7 - 10.11.04 - 10:08
(6) Слушай А это настолько обязательно? Я имею в виду - у тебя что так много периодических констант? Прямым установлением их значений чего нельзя воспользоваться?
   ValeraVV
8 - 10.11.04 - 10:13
Есть такая штука - РабочаяДата()......
   Agente Secreto
9 - 10.11.04 - 10:14
(8) - и как ее в данном случае использовать?
(7) нужна универсальность обработки
   Gloom
10 - 10.11.04 - 10:21
Шаблон()
 
  Рекламное место пустует
   Agente Secreto
11 - 10.11.04 - 10:26
(10) так и думал...
спасибо!
   mszsuz
12 - 10.11.04 - 14:39
Константа.ПолучитьАтрибут("новый1").Установить(РабочаяДата(),"111");



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует