Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Перебор реквизитов формы документа в цикле (не обязательно реквизиты документов)

Ø
Я
   Данила хМастер
10.11.04 - 12:36
Пришлось делать так...
Процедура Форма_ТолькоПросмотр(реж)
  // Установить (реж=1) / Снять (реж=0) только просмотр с формы
  Для ё=1 по Метаданные.Документ(Вид()).РеквизитШапки() Цикл
    рекв=Метаданные.Документ(Вид()).РеквизитШапки(ё);
    Попытка Форма.ПолучитьАтрибут(рекв).Доступность(реж); Исключение КонецПопытки;
    Попытка	Форма.ПолучитьАтрибут(рекв).Редактирование(реж); Исключение	КонецПопытки;
  КонецЦикла;
  Для ё=1 по Метаданные.Документ(Вид()).РеквизитТабличнойЧасти() Цикл
    рекв=Метаданные.Документ(Вид()).РеквизитТабличнойЧасти(ё);
    Попытка Форма.ПолучитьАтрибут(рекв).Доступность(реж); Исключение КонецПопытки;
    Попытка Форма.ПолучитьАтрибут(рекв).Редактирование(реж); Исключение КонецПопытки;
  КонецЦикла;
КонецПроцедуры
 
 
   Меланхоличный ворон
1 - 10.11.04 - 12:37
А как же условие >> (не обязательно реквизиты документов)
   MetaEditor
2 - 10.11.04 - 12:40
Формех есть для реквизитов...
   Муму после всплытия
3 - 10.11.04 - 12:41
(0)
прям глаза открыли.......................
   Данила хМастер
4 - 10.11.04 - 13:35
(1)Ничего не поделаешь: кидаю такие поля в списокЗн и над ними делаю ДостРед(0).
(2)Расскажите плз, что такое ФормЕх.
!!! Но теперь еще проблемка: есть 2 реквизита у дока: ДатаДок и ДатаРеестра(у них есть системные(!) кнопки выбора) .
Когда делаешь над ними:
Форма.ДатаДок.Доступность(0);
Форма.ДатаДок.Редактирование(0);
Форма.ДатаРеестра.Доступность(0);
Форма.ДатаРеестра.Редактирование(0);
получается так, что редактировать нельзя оба поля, в датеДок недоступна кнопка выбора, а вот у даты реестра почему-то кнопкой выбора можно дату забывать ( :(! ). Эти кнопки даже имеют разные пиктограмки: у ДатыДок "...", а у ДатыРеестра "<календарик>".
   ValeraVV
5 - 10.11.04 - 13:40
Точно Хмастер
а ты посмотри что у тебя вызывает пихтаграмма у ДатыРеестра
   Данила хМастер
6 - 10.11.04 - 13:48
(5)Я ж написал: она СИСТЕМНАЯ.
Т.е. не кнопка, а у поля ввода типа дата стоит птица "Имеет кнопку выбора".
Может кто знает как программно эту птицу снять?
   Пшзукшщт
7 - 10.11.04 - 13:49
(0) ва первых забыл есть ищо такая фенька как ОбщийРеквизитДокумента()
(4) ва втарых разные пиктаграмки патамушта разные типы значений. с календариком дата, с ... - строка. очевидна перепутал с календариком у ДатаДок должэн быть.
   Данила хМастер
8 - 10.11.04 - 14:00
(7)Не перепутал! У ДАТАДОК - "..." (когда он недоступен и неред.). Релиз 23скуль.
Общие - уже увидел и у себя прописал.
   АЛьФ
9 - 10.11.04 - 14:03



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует