Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

И снова XML - беда...

Ø
Я
   beginner
10.11.04 - 10:17
Проблема возникла при стыковке 8-ки и 7-ки. Файл XML формируется из 8.0, а в 7.7 видит структуру (в смысле количество подчиненных), но не видит в этой структуре тэги. Так вот подскажите что сделать, чтобы 7-ка эти тэги видела.
Вот часть кода:
Процедура ПриОткрытии()
  
  Если ЗагрузитьВнешнююКомпоненту(гПутьОбъекта_КомпонентаV7plus) <> 1	Тогда
    Предупреждение("Компонента v7plus.dll не найдена!");
    СтатусВозврата(0);	Возврат;
  КонецЕсли;
  
Анализатор = СоздатьОбъект("AddIn.XMLParser");
  
  Если Число(Анализатор.ВерсияАнализатора) < 2 Тогда
    Предупреждение("Для работы с программой необходимо обновить внешнюю компоненту v7plus.dll !");
    СтатусВозврата(0);	Возврат;
  КонецЕсли;
                                                                                        	
КонецПроцедуры
Процедура ЗагрузитьДанные()	
  Файл = СоздатьОбъект("ФС");
  Выбфайл=ФормИмяФайлаДанных;
  Файл.ВыбратьФайл(0,Выбфайл);
  
  ФайлДанных=Анализатор.СоздатьДокумент();
  ФайлДанных.Загрузить(Выбфайл);
  ВсеУзлы=ФайлДанных.ВыбратьУзлы("Выгрузка");
  
  ТЗП = СоздатьОбъект("ТаблицаЗначений");
  ТЗП.НоваяКолонка("Место");
  ТЗП.НоваяКолонка("Контрагент");
  
  Данные = ВсеУзлы.ПолучитьУзел(0);
  Прих = Данные.ВыбратьУзел("ПриходныеНакладные");
  Внутреннее = Данные.ВыбратьУзел("ВнутреннееДвижение");
  Расходные = Данные.ВыбратьУзел("РасходныеНакладные");
  Зачистка = Данные.ВыбратьУзел("Зачистка");
  
  Для х=1 по Прих.КоличествоПодчиненных()  Цикл
    ТЗП.НоваяСтрока();
    Приходная = Прих.ПолучитьПодчиненныйПоНомеру(х);
    ТЗП.Место = Приходная.Значение;
  
  КонецЦикла;
 
  Рекламное место пустует
   beginner
1 - 10.11.04 - 10:22
только не молчите, пожалуйста, кто чего-нибудь знает, подскажите
   echo
2 - 10.11.04 - 10:31
У меня такое ощущение, что ты используешь 3 парсер. Попробуй 4 релиз.
   GrayT
3 - 10.11.04 - 10:36
Покажи кусок ХМЛ, где приходные записаны.
   beginner
4 - 10.11.04 - 10:41
да легко, собственно вот и он:
<?xml version="1.0"?>
<Выгрузка>
  <ПриходныеНакладные>
    <НоваяНакладная>
      <МестоХранения>Пересыпная дальняя</МестоХранения>
      <Контрагент>Юг-Зерно</Контрагент>
      <НомерДокВходящий>ПР125 </НомерДокВходящий>
      <Номер>1</Номер>
      <Наименование>Пшеница Класс №5</Наименование>
      <Количество>10000</Количество>
      <Цена>25</Цена>
      <Сумма>250000</Сумма>
      <НДС>50000</НДС>
      <Всего>250000</Всего>
    </НоваяНакладная>
    <НоваяНакладная>
      <МестоХранения>Банка 4</МестоХранения>
      <Контрагент>ООО "Альфа Крона"</Контрагент>
      <НомерДокВходящий>15а12</НомерДокВходящий>
      <Номер>1</Номер>
      <Наименование>Пшеница Класс №4</Наименование>
      <Количество>6000</Количество>
      <Цена>14</Цена>
      <Сумма>84000</Сумма>
      <НДС>16800</НДС>
      <Всего>84000</Всего>
    </НоваяНакладная>
   beginner
5 - 10.11.04 - 10:51
up
   GrayT
6 - 10.11.04 - 10:56
Ну и где у тебя Приходная.Значение? Значения ведь нет.
Попробуй Приходная.ПолучитьАтрибут("МестоХранения")
   beginner
7 - 10.11.04 - 11:04
И так работать не хочет, возвращает пустую строку и все на этом
   Gloom
8 - 10.11.04 - 11:05
(6)МестоХранения - это не атрибут...
(0)ТЗП.Место = Приходная.ВыбратьУзел("МестоХранения").Текст;
   beginner
9 - 10.11.04 - 11:09
Ааа! Работает! Все работает! Родина тебя не забудет!!!



Список тем форума

Форум Территория 1С

  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует