Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Выборка бухитогов от определенного документа???

Ø
Я
   Соратник
10.11.04 - 10:10
Вот такая конструкция:
БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ИспользоватьСубконто(ВидыСубконто.МестаХранения,Склад);
  
Док=СоздатьОбъект("Документ");
Если Док.НайтиПоНомеру("15",РабочаяДата(),"ПоступлениеТоваров")=1 Тогда
  Сообщить(""+Док);
КонецЕсли;
ДатаНач=Док.ТекущийДокумент();
  
Если БухИт.ВыполнитьЗапрос(ДатаНач, ДатаКон, "41.1",,,, "Операция")=0 Тогда
  Предупреждение("Итогов нет");
  Возврат;
КонецЕсли;
Возвращает ошибку "Неправильно задан период!" если дата документа и дата конца периода одинаковая, если дата конца периода больше, то работает.
Я озадачен, как получить итоги от документа до конца дня???
 
  Рекламное место пустует
   Соратник
1 - 10.11.04 - 10:38
Ну где спецы?
Вырождается территория?
   Мымра
2 - 10.11.04 - 10:44
документ поставить в начало дня
   Соратник
3 - 10.11.04 - 10:47
2) Он в середине дня должен быть
   Мымра
4 - 10.11.04 - 10:48
Тогда датакон поставь в конец дня
   Соратник
5 - 10.11.04 - 10:50
4) Дату в конец дня? Это как?
   Тигра полосатая
6 - 10.11.04 - 10:55
Если Док.ДатаДок=ДатаКон Тогда
Если БухИт.ВыполнитьЗапрос(,Док.ТекущийДокумент(), "41.1",,,, "Операция")=0 Тогда
  Предупреждение("Итогов нет");
  Возврат;
КонецЕсли;
иначе
Если БухИт.ВыполнитьЗапрос(ДатаНач, ДатаКон, "41.1",,,, "Операция")=0 Тогда
  Предупреждение("Итогов нет");
  Возврат;
КонецЕсли;
конецЕсли
   Соратник
7 - 10.11.04 - 10:55
4) дата она и есть дата
   Соратник
9 - 10.11.04 - 11:02
В соседнем форуме подсказали одну идею, причем все заработало
ДатаКон=СформироватьПозициюДокумента(ДатаКон,23,59,59,1);
   Тигра полосатая
10 - 10.11.04 - 11:02
Пардон, в 6 - На Документ
От документа надо формировать еще позицию Документа :
СформироватьПозициюДокумента(Док.ДатаДок,23,59,59,1);
 
  Рекламное место пустует
   Соратник
11 - 10.11.04 - 11:06
8)В описании метода Выполнить запрос не указывается, что оба эти параметра должны быть совпадающих типов (или позиция документа, или дата)
Объясню зачем надо.
Приведенный текст это пример. Идет выписка документов, потом водят документ Акт ревизии, потом опять выписывают накладные. Отчет надо сформировать отдельно, до акта ревизии и после акта ревизии



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует