Вход | Регистрация


Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

ЗиК 4.0 DOS Проф -> ЗиК 7.7

Ø
Я
   Lucky
16.11.04 - 10:48
Собственно, есть у кого наработочки по переносу данных, ну хотя бы справочников из ЗиК 4.0 DOS Проф в ЗиК 7.7 ? Неужели нету стандартных фишек по переходу?
 
 
   Lucky
1 - 16.11.04 - 11:10
"Есть один путь - наверх..." (с) не моё
   Lucky
2 - 16.11.04 - 11:31
up
   Lucky
3 - 16.11.04 - 12:13
up :(
   saasa
4 - 16.11.04 - 12:15
(0) В чем проблема ? Работать неохота ?
   Lucky
5 - 16.11.04 - 12:20
Ха! знали бы вы, скока там полей в dbf файлах!
Тем более вдруг есть стандартный переход, а я не знаю :)
   NS
6 - 16.11.04 - 12:24
(5) Три? Четыре?
   saasa
7 - 16.11.04 - 12:26
В конце года, когда скоро сдавать ЕСН и НДФЛ затеять переход - ню-ню ;)
   Lucky
8 - 16.11.04 - 12:26
Шутники... по несколько десятков в каждом :(
   saasa
9 - 16.11.04 - 12:30
Может в природе и есть обработки по переносу, но думаю придется вам самим делать. Потихоньку, аккуратненько переносите справочники, документы, расчеты, потом рассчитываете налоги и будет вам счастье.
   Lucky
10 - 16.11.04 - 12:33
(9) Вот этого-то я и боюсь. Во-первых, не хотелось бы велосипед изобретать, а во-вторых клиента придётся предупредить что это будет стоить чуть дороже :)
 
  Рекламное место пустует
   saasa
11 - 16.11.04 - 12:36
(10) в 3 раза ;) Удачи !
Главное не обещайте сдать годовую отчетность в новой программе :)
   NS
12 - 16.11.04 - 12:38
(11) Пжалуйста, объясните мне проблемы со сдачей годовой отчетности в новой программе.
   saasa
13 - 16.11.04 - 12:41
(12)Проблем со сдачей - никаких, если есть данные !
Просто может так сложится, что данных в новой программе вовремя и не окажется. Мало ли что может случится.
   NS
14 - 16.11.04 - 12:42
И что может случиться?
Данные до конца года можно вести паралельно.
Для запуска 7.7 не так уж и много нужно перенести.
   saasa
15 - 16.11.04 - 12:46
(14) Немного - это сколько ?
1. Кадровые данные
2. Кадровые приказы
3. Данные по расчету среднего заработка для отпусков,больничных и т.п.
4. Ну и так по мелочи
В принципе немного ;)
   NS
16 - 16.11.04 - 12:51
(15)Очень немного.
Более того - просто переход не учитывая организационных вопросов, если есть опыт перевода с других программ на ЗиК - 2 дня работы.
   NS
17 - 16.11.04 - 12:53
(15) Какие такие "Данные по расчету среднего заработка для отпусков,больничных и т.п."????
Очень тяжело перенести кадровые приказы....
ДБФ.Первая();
  Пока дбф.вконце()=0 цикл
    если пустоезначение(ДБФ.FIO)=1 тогда
      ДБФ.Следующая();
      продолжить;
    конецесли;	
    если спр.найтипокоду(прав("0000000000"+сокрлп(ДБФ.TN),10))>0 Тогда
      Если ДБФ.DU<>"ггггммдд" Тогда
        Сообщить(ДБФ.DU);
        док.новый();
        Док.Датадок=Дата(Число(лев(ДБФ.DU,4)),Число(сред(ДБФ.DU,5,2)),Число(прав(ДБФ.DU,2)));
          Док.УстановитьновыйНомер("N-");
        Док.ДатаУвольнения=док.датадок;
        док.сотрудник=спр.текущийэлемент();
        Док.Записать();
        Док.Провести();
      КонецЕсли;
    конецесли;
    ДБФ.Следующая();
  Конеццикла;	
   saasa
18 - 16.11.04 - 12:54
(16) Согласен, если есть возможность получить каким либо способом весь необходимый набор данных, то можно справится за 2-3 дня(*2 = неделя) :).
Но, как обычно бывает писец подкрадывается незаметно.
   saasa
19 - 16.11.04 - 12:56
(17) "Какие такие "Данные по расчету среднего заработка для отпусков,больничных и т.п."????"
Больничные, отпуска, командировки вы в новом году
вручную считать будете ?
   NS
20 - 16.11.04 - 13:03
(19) Просто полностью заполняешь ЖР.
Процедура Сформировать()
  ЖурналРасч=создатьобъект("ЖурналРасчетов.Зарплата");
  Док=создатьобъект("Документ.Ввестирасчеты");
  Док.выбратьдокументы();
  пока док.получитьдокумент()=1 цикл
    Док.Удалитьстроки();
    спр=создатьобъект("Справочник.Сотрудники");
    ДБФ1=создатьобъект("XBase");
    ДБФ1.ОткрытьФайл("C:\08_10_04\TN_0904");
    ДБФ1.ПоказыватьУдаленные(0);
    ДБФ1.Первая();
    Пока дбф1.вконце()=0 цикл
      Если спр.найтипокоду(прав("0000000000"+сокрлп(ДБФ1.TN),10))=0 Тогда
        сообщить(ДБФ1.TN);
        ДБФ1.Следующая();
        продолжить;
      КонецЕсли;
      ДД=сокрлп(ДБФ1.DRP);
      Дат=Дата(число(Лев(ДД,4)),число(сред(ДД,5)),1);
      ДатН=НачМесяца(Дат);
      ДатК=КонМесяца(Дат);
      сум=окр(ДБФ1.SN,2);
      Если (док.ДатаДок>=датН)и(док.ДатаДок<=датК) Тогда
        док.новаястрока();
        Док.сотр=спр.ТекущийЭлемент();
        Док.Рез=сум;
        Док.КодДохода=число(ДБФ1.WN);
        Док.Дней=ДБФ1.DNN;
        Док.Часов=ДБФ1.HN;
        Док.ДатаНач=Дата(число(Лев(ДБФ1.DN,4)),число(сред(ДБФ1.DN,5)),1);
        Док.ДатаКон=Дата(число(Лев(ДБФ1.DK,4)),число(сред(ДБФ1.DK,5)),1);
      КонецЕсли;
      ДБФ1.Следующая();
    КонецЦикла;
    Док.Записать();
    ЖурналРасч.УстановитьтекущийПериод(ЖурналРасч.периодподате(Док.Датадок),0);
    Док.Провести();
  конеццикла;
КонецПроцедуры
   МимохожийОднако
21 - 16.11.04 - 13:08
Не так страшен черт, как его малютка (с)"Русское радио"
NS прав. Особых проблем для опытных нет. Но никто не мешает попытаться перенести данные и посмотреть. Тогда и выводы можно сделать. Но как и при любом переходе работы хватит и программисту и бухгалтеру, который будет проверять результаты
   saasa
22 - 16.11.04 - 13:37
(20),(21) Так никто и не говорит что сложно, главное ничего не потерять!




Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует