Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Время документа

Ø
Я
   Flik
16.11.04 - 12:17
Как сравнить порядок документов.
Т.е. есть Док1 и Док2 нужно узнать что раньше создано.
Метод должен быть максимально быстрым, т.к. используется очень часто.
 
 
   Муму после всплытия
1 - 16.11.04 - 12:19
хм................. ПолучитьПозицию() к примеру
   NS
2 - 16.11.04 - 12:22
ПолучитьПозицию()
   Flik
3 - 16.11.04 - 12:24
Если Док1.ПолучитьПозицию()<Док2.ПолучитьПозицию() Тогда
{Глобальный модуль(132)}: Поле агрегатного объекта не обнаружено (ПолучитьПозицию)
   Flik
4 - 16.11.04 - 12:45
Может кто знает еще какие-либо способы или как заставить сравнивать это.
   Lvk
5 - 16.11.04 - 12:47
                  Если СформироватьПозициюДокумента(ДатВремДокРасх)>СформироватьПозициюДокумента(Запрос.ДокДвиж) Тогда
                    ДатВремДокРасх=Запрос.ДокДвиж
                  КонецЕсли;
   bsg
6 - 16.11.04 - 12:48
ПолучитьПозицию() работает. Накосячил где-то. Или не то делаешь.
Что там у тебя Док1, Док2?
   NS
7 - 16.11.04 - 12:49
Процедура Сформировать()
    Док=создатьобъект("Документ");
  Док.ВыбратьДокументы();
  пока Док.ПолучитьДокумент()=1 цикл
    сообщить(Док.ПолучитьПозицию());
  КонецЦикла;	
КонецПроцедуры
У тебя просто док - не выбран, либо имеет тип отличный от документ.
   Flik
8 - 16.11.04 - 12:51
Сделал. У меня была ошибка. =) Всем спасибо за помощь.



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует