Вход | Регистрация

О жизни... ::

Метки:

OFF: Как средствами 1С поздравить с праздниками?

Я
   Denis Nsk
 
16.02.04 - 07:11
Привет Всем.
Грядут праздники. Поэтому хотелось бы поздравить своих колег бухов средсвами 1С.

У кого какие идеи?
Знаю только про возможность замены заставки на картинку. Хотелось бы разместить картинку в рабочем окне программы или еще че-нить. Да еще различать пользователя ))) Не сильно круто?
 
  Рекламное место пустует
   OctoberHammer
 
1 - 16.02.04 - 07:23
// ===============================
Процедура ПриНачалеРаботыСистемы()
   рез = ЗагрузитьВнешнююКомпоненту("bcs_wnd.dll");
   Если рез = 0 Тогда
       //Сообщить("Ошибка загрузки компоненты ");
       Возврат;
   КонецЕсли;
   Попытка
       Окно = СоздатьОбъект("AddIn.Wnd");
   Исключение
       //Сообщить("Ошибка загрузки компоненты ");
       Возврат;
   КонецПопытки;                              
   Если ПустоеЗначение(Пользователь.ФайлОбоев)=0 Тогда
       Если ФС.СуществуетФайл(Пользователь.ФайлОбоев)=1 Тогда
           Окно.ЗагрузитьОбои(Пользователь.ФайлОбоев,0);  
       КонецЕсли;
   КонецЕсли;
   SnarkHunter
 
2 - 16.02.04 - 07:25
(+1)Я еще в дополнение к этому делал случайный выбор из 16 картинок и проверку на пол пользователя...
   Denis Nsk
 
3 - 16.02.04 - 07:44
Спасибо. А что за компонента bcs_wnd.dll и объект AddIn.Wnd?

SnarkHunter, а как?
Другие предложения еще принимаются.
   Denis Nsk
 
4 - 16.02.04 - 11:39
Up
   IAm
5 - 16.02.04 - 11:44
1 Попробовал так сделать на прошлое 8 марта. 1С через 5 минут вылетел без сообщений. Вот праздник-то был.
   Кое-кто@где-то.там
6 - 16.02.04 - 12:39
Здесь готовая обработка
http://obmen.daphouse2.com/obmen/8marta.zip
Надеюсь, как её подключать объяснять не стоит?
   Рупор абсурда
 
7 - 16.02.04 - 12:43
(6) А чего там?
   Denis Nsk
 
8 - 16.02.04 - 13:05
Спасибо.
OctoberHammer и SnarkHunter ВК bcs_wnd.dll не стандартная от 1С? Где взять?
   Львенок
 
9 - 16.02.04 - 13:42
(8) STFW, блин.
___
Искренне Ваш, Львенок.


Список тем форума
Рекламное место пустует  
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует