Вход | Регистрация

1С:Предприятие ::

Метки:

Как отменить проведение документа ??

Я
   Serega
 
22.11.04 - 14:12
господа туплю уже часа два :
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() > 0 Цикл
    ТекДок = Док.ТекущийДокумент();
    Если СокрЛП(ТекДок.НомерДокВходящий) = НомДок Тогда
   // имеется документ с таким номером 

    НомДокТек = ТекДок.НомерДок;
    НаличиеДокумента = 1;
    РедДок = Док.ТекущийДокумент();
    Сообщить("Документ с номером " + СокрЛП(ТекДок.НомерДок) + " с    вход. ном. " + СокрЛП(ТекДок.НомерДокВходящий) + " уже имеется, его содержимое замещается документом из файла. (Номер из Воронежа)","!");
КонецЕсли;
КонецЦикла;

Если НаличиеДокумента = 1 Тогда
    Док = РедДок;
    Док.СделатьНеПроведенным(); 
    Док.УдалитьСтроки();
Иначе
    Док.Новый();
КонецЕсли;

На Док.СделатьНеПроведенным() выдает ошибку "Не выбран документ!"
Подскажите пожалуйства что не так ???
 
 
   Мулька
 
1 - 22.11.04 - 14:15
Как на счет Записать ?
   Бивень
 
2 - 22.11.04 - 14:15
Целых 2 часа?
   mic
3 - 22.11.04 - 14:17
Вместо "Док=РедДок"
Док.НайтиДокумент(РедДок);
   Бивень
 
3 - 22.11.04 - 14:17
(1) Каким боком тут запись?
   База Знаний
5 - 22.11.04 - 14:19
Как, насчет, делать это в цикле, а не после него?
   Serega
 
6 - 22.11.04 - 14:20
2 часа с обедом :-)
тока учуся я 1су
большое спасибо заработало
   321
 
7 - 22.11.04 - 14:22
(6) Было бы полезнее, если бы ты еще 2 часа просидел, но сам нашел выход, но это мое мнение
   Rovan
 
8 - 22.11.04 - 14:26
(0) СделатьНеПроведенным() метод объекта созданного с помощью СоздатьОбъект() !
   Serega
 
9 - 22.11.04 - 14:30
это понятно, но опыта маловато просто
   Serega
 
10 - 22.11.04 - 14:32
по идее в "реддок" то ссылка запомнилась...
вот почему не передалася ... в "док"
 
  Рекламное место пустует


Список тем форума
 
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует