Вход | Регистрация

1С:Предприятие ::

Метки:

Подскажите

Я
   ally
 
15.02.04 - 20:05
Есть ли в Зик процедура в ГМ (или где-нить) разбивающая реквизит "Наименование" Справочника "Сотрудники" отдельно на "Фамилию", "Имя", "Отчество". Чтоб можно было глянуть или передать ей наименование. Или ручками писать?
 
  Рекламное место пустует
   Кое-кто@где-то.там
1 - 15.02.04 - 20:08
//******************************************************************************

//    глФамилияИмяОтчество(Объект,Фамилия,Имя,Отчество)
//

//    Параметры:
//        Объект     - элемент справочника Сотрудники или Строка

//        Фамилия     - в этот параметр будет записана фамилия сотрудника
//        Имя         - в этот параметр будет записано имя сотрудника

//        Отчество - в этот параметр будет записано отчество сотрудника
//

//    Возвращаемое значение:
//        фамилия и инициалы сотрудника

//
//    Описание:

//        разбирает "наименование" сотрудника по Фамилия, Имя, Отчество
//        и возвращает фамилию и инициалы сотрудника

//
Функция глФамилияИмяОтчество(Объект,Фамилия="",Имя="",Отчество="") Экспорт
    
    Если ТипЗначения(Объект)=2 Тогда
        ФИО = глРазделить(СокрЛП(Объект)," ");
    Иначе
        ФИО = глРазделить(СокрЛП(Объект.Наименование)," ");
    КонецЕсли;
    Фамилия = СтрПолучитьСтроку(ФИО,1);
    Имя        = СтрПолучитьСтроку(ФИО,2);
    Отчество= СтрПолучитьСтроку(ФИО,3);
    Возврат Фамилия+?(ПустоеЗначение(Имя)=0," "+Лев(Имя,1)+"."+?(ПустоеЗначение(Отчество)=0,Лев(Отчество,1)+".",""),"")

КонецФункции   // глФамилияИмяОтчество
   Кое-кто@где-то.там
2 - 15.02.04 - 20:10
и ещё
//******************************************************************************

//    глРазделить(Стр,Разделитель)
//

//    Параметры:
//        Стр            - строка, которую необходимо разложить на подстроки

//        Разделитель - строка-разделитель, по умолчанию - запятая
//

//    Возвращаемое значение:
//        Многострочная строка, составленная из подстрок

//
//    Описание:

//        Разбивает строку на многострочную строку по разделителю
//

Функция глРазделить(Знач Стр,Разделитель=",") Экспорт
    Если Разделитель=" " Тогда
        Пока Найти(Стр,"  ")>0 Цикл
            Стр = СтрЗаменить(Стр,"  "," ")
        КонецЦикла
    КонецЕсли;
    Возврат СтрЗаменить(Стр,Разделитель,РазделительСтрок)
КонецФункции   // глРазделить


Список тем форума
Рекламное место пустует  
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует