Вход | Регистрация

1С:Предприятие ::

Метки:внешние компоненты

VTools: как отследить изменение пометки в дереве?

Я
   Asmody
 
21.11.04 - 17:36
subj.
Делаю через ПриНажатииЛевойКнопки(), но в этом случае отлавливаются все события (открытие-закрытие, редактирование), а мне нужно только изменение чекбокса.
 
 
   big
 
1 - 22.11.04 - 10:12
Привет Asmody! Я делал вот так:

Процедура НажатиеЛевойКнопкаМыши()
    Если МояТаблица.ПолучитьКоличествоСтрок()<=1 Тогда
        Возврат;
    КонецЕсли;
    ТекКолонка=МояТаблица.Колонка(); ТекСтрока=МояТаблица.Строка();
    Если ТекКолонка=1 Тогда
        ТекКартинка=МояТаблица.ПолучитьКартинку(ТекСтрока, ТекКолонка);
        Если ТекКартинка=18 Тогда
            МояТаблица.ЗадатьКартинку(ТекСтрока, ТекКолонка, ТекКартинка+1);
        ИначеЕсли ТекКартинка=19 Тогда
            МояТаблица.ЗадатьКартинку(ТекСтрока, ТекКолонка, ТекКартинка-1);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   Asmody
 
2 - 22.11.04 - 11:22
привет! как сам? >;))
клево, но это для GRID'а кажется? а у меня - дерево с пометками. Хотел красивый отбор забацать, застрял на этих пометках...
   big
 
3 - 22.11.04 - 13:10
(2) Вашими молитвами.
Млин... Дерево не юзал - стОит попробовать.
   big
 
4 - 22.11.04 - 13:19
(0) Там оказывается все проще:
МоеДерево.ИспользоватьФлаги(1)// 0 - не используем чекбоксы, 1 - используем
Глянь в примере Tree.ert
   Asmody
 
5 - 22.11.04 - 14:08
(4) это я в курсе. говорю же, дерево с чекбоксами.
нужно перехватить факт изменения чекбокса. кроме как ПриНажатииЛевойКнопки() это сделать негде. Но ПриНажатииЛевойКнопки() срабатывает всегда, т.е. при разкрытии-закрытии ветки, попытке редактирования и т.д. Причем на момент срабатывания метода чекбокс еще не изменил свое значение. что интересно, при изменении чекбокса событие ПриОтпусканииЛевойКнопки() не генерится.
Идея была очевидна: при отметке род. элемента отмечать все дочерние. пока пришлось отказаться.
Но суперский отбор уже соорудил :)
   big
 
6 - 22.11.04 - 14:13
(5) Во-во. До этого я позже додумался - невнимательно вопрос прочитал. Сам сейчас пробовал - те же траблы.
   Витаэль
 
7 - 22.11.04 - 14:13
Я уже давал ответ на этом форуме.
   Asmody
 
8 - 22.11.04 - 14:18
(7) ссылку в студию, plz, а то с твоими 10 никами поиск не разгребешь...
   Витаэль
 
9 - 22.11.04 - 14:24
8. Под ником Матрейя вроде.
   big
 
10 - 22.11.04 - 14:46
(9) Жаль, что в ВК нет "стандартного" события. Спасибо за помощь.
 
 
   Витаэль
 
11 - 22.11.04 - 14:48
10. Пожалуйста, только когдя это я тебе помог? +Все неудобства можно обойти програмно.
   big
 
12 - 22.11.04 - 14:54
(11) Помощь была. Нашел твой ответ (7) на такой же вопрос. Даже не думал, что программно можно "отказать" в установке Флага и "подменить" его собственными действиями.
   Asmody
 
13 - 22.11.04 - 15:47
(7) попробовал твой способ. теперь галка ставится при любом щелчке на элементе дерева. мне так не надо...
   Asmody
 
14 - 22.11.04 - 15:49
(13+) делал как написано тут Введение в vtools.
   Витаэль
 
15 - 22.11.04 - 16:12
14. Ну так немного измени приведенный в ссылке код.


Список тем форума
Рекламное место пустует  
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует