Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

8-ка: Как вывести в форме связанный реквизит?

Ø
Я
   wms
09.11.04 - 12:34
Например в форме документа в табл. части есть
реквизит товар тип Справочник.Номенклатура,
а необходимо вывести реквизит Артикул, связанный с товаром ?
Киньте пример, а то давно делал и забыл...
 
 
   wms
1 - 09.11.04 - 20:56
up
   Полубенский Алексей
2 - 10.11.04 - 08:59
Создаешь новую колонку и выводишь в обработчике табл. части ПриВыводеСтроки()
   wms
3 - 11.11.04 - 01:34
ПриВыводеСтроки ?! Это уже что то,
 а то я в ОбновлениеОтображения формы пытался, ничего не получилось...
А сам текст можно в студию? (там цикл какой-то должен быть... )
Без примеров тяжеловато по букварям учиться.
И еще вопрос:
Установлена платформа 1С8
Создаю новую базу
Есть обновление Упровление Торговлей
Что то не получилось ее загрузить в эту базу, так как это было раньше в 7-ке (загружали мд-шник)
Что технология обновления изменилась???
   barlog
4 - 11.11.04 - 03:43
Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
  Если  ДанныеСтроки.Номер>0 Тогда
    ОформлениеСтроки.Ячейки.Номер.УстановитьТекст(спцНомерДоговора(ДанныеСтроки.Ссылка));
    ОформлениеСтроки.Ячейки.РегБух.ОтображатьФлажок=Истина;
    Если ДанныеСтроки.Ссылка.Сдано>'00010101' Тогда
      ОформлениеСтроки.Ячейки.РегБух.Флажок=Истина;
    Иначе
      ОформлениеСтроки.Ячейки.РегБух.Флажок=Ложь;
    КонецЕсли;
  КонецЕсли;
КонецПроцедуры
   девушка
5 - 11.11.04 - 03:48
(3) да, технология олбновления изменилась, тперь если есть только обновления, а установочного пакета нет - фиг ты установишь базу
   wms
6 - 11.11.04 - 11:07
(4) что то непонятно, там вроде цикл нужен какой-то
(5) Да, я так и подумал, спасибо за подтверждение
Киньте примерчик по (0)
   Нечего делать
7 - 11.11.04 - 11:12
2(6) Событие вызывается при выводе КАЖДОЙ строки. Цикл не нужен
   wms
8 - 11.11.04 - 11:16
Процедура КомплектПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
  артикул=ДанныеСтроки.товар.артикул;
КонецПроцедуры
Тогда где что не так ?
   wms
9 - 11.11.04 - 11:20
Даже так не катит:
ОформлениеСтроки.Ячейки.Артикул.Текст=ДанныеСтроки.товар.артикул;
   wms
10 - 11.11.04 - 11:24
Заработало:
ОформлениеСтроки.Ячейки.Артикул.УстановитьТекст(ДанныеСтроки.товар.артикул);
Раньше, правда делали не так, точно, или возможности платформы улучшили...
 
  Рекламное место пустует



Список тем форума

Форум Территория 1С

  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует