Вход | Регистрация

1С:Предприятие ::

Метки:

Таблица в режиме ввода данных

Я
   Макс
14.02.04 - 14:06
Как задать чтобы у всех ячеек был тип "неопределенный"?
 
  Рекламное место пустует
   GrayT
 
1 - 14.02.04 - 14:10
А он какой?
   Макс
2 - 14.02.04 - 14:13
А он "строка" с неогр. длиной.
   GrayT
 
3 - 14.02.04 - 14:19
Да? А у меня по клику 0 возращает
Процедура ПриВыбореЯчейкиТаблицы(Адрес, значен)
    Предупреждение(ТипЗначения(Значен));
КонецПроцедуры//риВыбореЯчейкиТаблицы(<Адрес>,<Значение>)
   Макс
4 - 14.02.04 - 14:29
или я дурак или где.
да сделал отчет - все так и есть. но если начать потом проверять тип ячейки уже в конфигураторе - то показывает "строка". сохраняю ее, запускаю - проверяю - тип 0, проверяю в конфигураторе - в закладке "данные" нет ни одного поля. нажал "отмена". опять открыл свойства ячейки - уже закладка "данные" активна и тип "строка". запускаю - возвращает 0... офигеть. я не понимаю закономерности - но суть уже ясна как сделать правильно
   Макс
5 - 14.02.04 - 14:36
И вообще суть в том что мне надо назначить тип ячейки самому - например "справочник.товары".

Таблица.Область(Ном,3).НазначитьТип("Справочник.Товары",,);
Таблица.Область(Ном,3).Значение=Запрос.ТМЦ;

или я не так назначаю тип?
   GrayT
 
6 - 14.02.04 - 14:42
Хм, действительно, ни когда не обращал внимания
   Таня
 
7 - 14.02.04 - 14:47
А у меня так никогда не получалось назначить тип
я всегда прямо в свойствах ячейки, на закладке Данные ставила в поле Тип  - конкретный выбирала и все
Неопределенный если ставишь, он его тут же преобразует в строку.
   Макс
8 - 14.02.04 - 14:55
Тогда пример простенький.
Надо вывести в таблице в режиме ввода данных справочник контрагентов.
Процедура Сформировать()
    Спр=СоздатьОбъект("Справочник.Контрагенты");
    Спр.ВыбратьЭлементы();
    i=1;
    Пока Спр.ПолучитьЭлемент()=1 Цикл
        Таблица.Область(i,1).НазначитьТип("Справочник.Контрагенты",,);
        Таблица.Область(i,1).Значение=Спр.ТекущийЭлемент();
        i=i+1;
    КонецЦикла;
КонецПроцедуры

Процедура ПриВыбореЯчейкиТаблицы(Адрес,Значение) 
   Предупреждение(ТипЗначения(Значение)); 
КонецПроцедуры

Попробуй пощелкать до формирования по первому столбцу и после - тот же нуль... такое подозрение что неправильно ставлю назначение типа
   Макс
9 - 14.02.04 - 14:57
2Таня: дело в том что мне нужно чтобы после нажатия END прыгал курсор в конец таблицы. если я задам тип сам - я не знаю сколько товара может быть и 1000 или 10000 - не определиться где конец ставить таблицы... вот такие вот пироги - над оптимально сделать. у меня было так - но не устраивает - не хочу потом переделывать эту обработку для кого-то еще раз. сделал и забыл :)
   Макс
10 - 14.02.04 - 15:23
Мне тут намекнули что таблицу в режиме ввода данных лучше не использовать в моем случае, когда не известно сколько строк будет :) мне эт предложение понравилось - но альтернативы для себя я не могу найти :)
 
  Рекламное место пустует
   GrayT
 
11 - 14.02.04 - 15:29
Да, такие таблицы хороши для фиксированных бланков, я щас то-же пытаюсь твою задачку реализовать, пока 0
   Макс
12 - 14.02.04 - 16:37
Вообщем пока оставил я эту проблему на будущее - над будет не забывать об этом - обошелся выделением 10000 строк с присваиванием им типа "неопределенный" насильно. Фиг с ним :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует