Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

Алгоритм проверки правильности ИНН

Ø
Я
   Вежливый
09.11.04 - 09:55
Кто-нибудь реализовывал, поделитесь пожалуйста.
 
 
   Бит
1 - 09.11.04 - 09:56
Длина и содержимое
   Вежливый
2 - 09.11.04 - 09:57
(1) Ширина и форма... К чему это я?
   warenic
3 - 09.11.04 - 09:57
http://warenic.narod.ru/utils/CheckINN.zip
   AlexBugs
4 - 09.11.04 - 09:59
Функция глПроверитьИНН(ИНН,Пар)// возврат - 1 - правильный, 0 - нет
 Перем Вес[11],Ном,Сумма,Ключ;//  Пар -1 (организация-10 знаков)  0 (ИП-12 знаков)
 Если Пар=1 Тогда
  Ключ=10;// Организация
  Вес[1]=31; Вес[2]=29; Вес[3]=23; Вес[4]=19; Вес[5]=17;
  Вес[6]=13; Вес[7]=7 ; Вес[8]=5 ; Вес[9]=3;
  Сумма=0;
  Для Ном=1 По 9 Цикл
   Сумма=Сумма+Число(Сред(ИНН,Ном,1))*Вес[Ном];
  КонецЦикла;
  Ключ=11-(Сумма-Цел(Сумма/11)*11);
  Ключ=?(Ключ>9,0,Ключ);
  Возврат ?(Ключ=Число(Сред(ИНН,10,1)),1,0);
 Иначе
  Ключ=12;// ИП
  Вес[1]=41; Вес[2]=37;
  Вес[3]=31; Вес[4]=29;
  Вес[5]=23; Вес[6]=19; Вес[7]=17;
  Вес[8]=13; Вес[9]=7 ; Вес[10]=5 ; Вес[11]=3;
  Сумма=0;
  Для Ном=1 По 10 Цикл
   Сумма=Сумма+Число(Сред(ИНН,Ном,1))*Вес[Ном+1];
  КонецЦикла;
  Ключ=11-(Сумма-Цел(Сумма/11)*11);
  Стр=Лев(ИНН,10)+Строка(?(ключ<10,ключ,0));
  Сумма=0;
  Для Ном=1 По 11 Цикл
   Сумма=Сумма+Число(Сред(Стр,Ном,1))*Вес[Ном];
  КонецЦикла;
  Ключ=11-(Сумма-Цел(Сумма/11)*11);
  Стр=Стр+Строка(?(ключ<10,ключ,0));
  Возврат ?(Стр=ИНН,1,0);
 КонецЕсли;
КонецФункции
   klom
5 - 09.11.04 - 10:00
http://www.yandex.ru/yandsearch?stype=www&nl=0&text=%C0%EB%E3%EE%F0%E8%F2%EC+%EF%F0%EE%E2%E5%F0%EA%E8+%EF%F0%E0%E2%E8%EB%FC%ED%EE%F1%F2%E8+%C8%CD%CD
яндекс рулить
   Вежливый
6 - 09.11.04 - 10:00
О, оно!
   AlexBugs
7 - 09.11.04 - 10:19
Кстати, налоговая этот алгоритм официально не публиковала :)
Наверно поэтому 1С его и не встраивает в типовую...



Список тем форума

Форум Территория 1С

Рекламное место пустует   Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует