Вход | Регистрация


1С:Предприятие ::

Метки:

Как открыть форму уже существующего документа?

Я
   Костя
 
19.11.04 - 12:26
У меня есть вот такие наброски:
Процедура Первый()
    Док=СоздатьОбъект("Документ.Счёт"); 
    Док1=СоздатьОбъект("Документ");
    Если Первый=0 Тогда
       //Док.Новый();

    Иначе 
        Док1.ВыбратьПоЗначению(ТекущаяДата(),ТекущаяДата(),"НомСтола",Первый);
        Пока Док1.ПолучитьДокумент()=1 Цикл
        Если Док1.Проведен()=0 Тогда
             ОткрытьФорму(Док1,й,0);
        КонецЕсли;    
        КонецЦикла;    
    КонецЕсли;
КонецПроцедуры

Может кто обьяснит почему?
 
 
   SnarkHunter
 
1 - 19.11.04 - 12:27
Потому что...
   SKrin
 
2 - 19.11.04 - 12:27
что "почему"?
   Костя
 
3 - 19.11.04 - 12:36
Я нешел в выборке документ  каторый мне нужен, и мне его надо открыть для редоктирования, но он у меня не открывается "ОткрытьФорму(Док1,й,0);"
   Костя
 
4 - 19.11.04 - 12:37
"редАктирования" извиняюсь
   vS
 
5 - 19.11.04 - 12:38
первый, это что такое? Позывной?
Перечисление? Справочник?
или это СТРОКА???
   Костя
 
6 - 19.11.04 - 12:38
Число
   vS
 
7 - 19.11.04 - 12:39
а если ТекДок() ?
   Костя
 
8 - 19.11.04 - 12:39
"НомСтола"-Общий реквизит, тоже число.
   Костя
 
9 - 19.11.04 - 12:40
(7) Т.е. ""ОткрытьФорму(ТекущийДокумент(),й,0);" "
   SKrin
 
10 - 19.11.04 - 12:40
а че такое "й"
 
  Рекламное место пустует
   SKrin
 
11 - 19.11.04 - 12:41
(9) не, ты че...
ОткрытьФорму(Док1.ТекущийДокумент(),й,0);
   й
12 - 19.11.04 - 12:43
это абривеатура от йОПРСТ.
   Костя
 
13 - 19.11.04 - 12:43
(11) Я это и имел в виду..
   Костя
 
14 - 19.11.04 - 12:46
10) Честно говоря , даже не знаю!
   Костя
 
15 - 19.11.04 - 12:46
11) Всё получилось, Спасибо!
   Костя
 
16 - 19.11.04 - 12:54
У меня ещё вопрос, короче: Есть отчёт, его форма всё время открыта, на форме несколько кнопок, под номерами от 1 до 5 (например), по нажатию кнопки, у меня открывается Форма документа (нового), я его заполняю, записую, закрываю, но не провожу. Мне нужно, что бы про закрытии один из реквизитов этого документа передавался в реквизит формы отчёта (Например:

Номер=Док.НомСтола), как бы мне это реализовать?
   miki
 
17 - 19.11.04 - 12:57
(16) А как ты ее (форму нового документа) оnкрываешь? Покажи код, плз.
   Таня
 
18 - 19.11.04 - 13:00
через контекст, он у тебя "й" обозван
   Костя
 
19 - 19.11.04 - 13:01
Процедура Первый()
    Док=СоздатьОбъект("Документ.Счёт"); 
    Док1=СоздатьОбъект("Документ");
    Если Первый=0 Тогда
        ОткрытьФорму("Документ.Счёт");
    Иначе 
        Док1.ВыбратьПоЗначению(ТекущаяДата(),ТекущаяДата(),"НомСтола",Первый);
        Пока Док1.ПолучитьДокумент()=1 Цикл
            Если Док1.Проведен()=0 Тогда
                    ОткрытьФорму(Док1.ТекущийДокумент(),й,0);
            КонецЕсли;    
        КонецЦикла;    
    КонецЕсли;
КонецПроцедуры
   Костя
 
20 - 19.11.04 - 13:02
(18) По подробнее PLZZ...
   miki
 
21 - 19.11.04 - 13:05
(19) Уверен, что новый документ открываешь?
   Костя
 
22 - 19.11.04 - 13:07
(21) "ОткрытьФорму("Документ.Счёт");", - А разве нет?
   miki
 
23 - 19.11.04 - 13:14
(22) Да. Я на "ОткрытьФорму(Док1.ТекущийДокумент(),й,0);" смотрел. Читать мне надо учиться.
Тебе с какого дока надо реквизит?
   Костя
 
24 - 19.11.04 - 13:22
"ОткрытьФорму("Документ.Счёт")-Я открыл, всё заполнил, записую этот док. и вот с него мне надо взять реквизит. А потом, когда я его опять открываю и провожу, реквезит отчёта мне надо будет обнулить.
   miki
 
25 - 19.11.04 - 13:28
(24) Ну так добавь и в 'ОткрытьФорму("Документ.Счёт")' свою "й", а потом к (18).
И: "Что такое Первый"? (с)vS.
"потом, когда я его опять открываю" - это когда?
   Костя
 
26 - 19.11.04 - 13:34
(25) На счёт "й" я так и не понял что это. "Первый"-это тот самый реквизит формы отчёта, про каторый я и говорю. А открываю я его опять затем, чтоб если он не проведён, в него по мере надобности добавить или изменить данные (так может бать несколько раз), а в конце уже провести. Т.е. при очередном нажатии кнопки (если этот документ проведён), он уже не откроется, а откроется новый документ!!! О как...
   Костя
 
27 - 19.11.04 - 13:35
"А открываю я его опять затем, чтоб ..."-в смысле документ.!!!
   Костя
 
28 - 19.11.04 - 13:39
Ну так что?
   Таня
 
29 - 19.11.04 - 13:44
я точно щас сказать не смогу, попробуй: Й.НомерСтола;
   Таня
 
30 - 19.11.04 - 13:45
Номер=Й.НомСтола
   miki
 
31 - 19.11.04 - 13:51
(26) А нах тебе тогда реквизит документа?
   Костя
 
32 - 19.11.04 - 13:53
(31) Ну например, мне нужно в "первый" передать "НомерДок", каторый мы ещё не провели...
   miki
 
33 - 19.11.04 - 13:57
(32) В таком случае траблы могут быть с "Если Первый=0 Тогда".
Используй лучше Первый как ссылку на док и юзай "Если Первый.Выбран()=0 Тогда"
 
  Рекламное место пустует
   Костя
 
34 - 19.11.04 - 14:26
(33) Каким образом "как ссылку на док"?
   miki
 
35 - 19.11.04 - 14:59
(34) Извини, отлучиться пришлось. Бухи(ов) поздравляли...
Попробуй так: ОткрытьФорму("Документ.Счёт",Первый).
   Костя
 
36 - 19.11.04 - 15:52
(35) Я уже по другому сделал, я в первый, при открытии дока, передаю его номер, а потом делаю с ним что захочу!!!
   miki
 
37 - 19.11.04 - 16:09
(37) А если какой-нить чел номер поменяет?
Потом начальники будут с тобой делать что захотят...
   miki
 
38 - 19.11.04 - 16:10
(37) т.е. (36). Опять тремор...
   Костя
 
39 - 19.11.04 - 16:11
Не поменяют!!!
У него периодичность в пределах дня, и запрет на редактирование.
   miki
 
40 - 19.11.04 - 16:19
(39) Можно еще Access denied юзерам на базу. И спать спокойно.
   Костя
 
41 - 19.11.04 - 16:52
(40) Щё це таке?



Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует