Вход | Регистрация


1С:Предприятие ::

Метки:

Родитель элемента справочника

Я
   Serg_Y
19.11.04 - 01:22
Народ выручайте
Все облазил не могу ничего найти и понять
Как мне для созданого програмно эл. справочника сначала получить родителя а потом присвоить его эл.

Если можно примерчик.
Заранее огромное спасибо
Если мож че не так назвал (извените до профи мне еще далеко), задайте вопрос я отвечу
еще раз заранее огромное спасибо
 
 
   Asmody
 
1 - 19.11.04 - 01:24
чевоа нада сделать?
   Asmody
 
2 - 19.11.04 - 01:25
   Serg_Y
3 - 19.11.04 - 01:30
Asmody
2 - 19.11.04 - 01:25
Если честно то там ничего толково так и не родили

Мне тяжело сказать что нада
давай я лучше на примере


СпрКли.Новый();
СпрКли.Наименование = КлиентНайм; 
СпрКли.ПолнНаименование = КлиентПолнНайм; 
СпрКли.Адрес = КлиентАдрес; 
СпрКли.НомерСвидетельства = КлиентНомерСвидетельства; 
СпрКли.ИНН = КлиентИНН;
СпрКли.Телефоны = КлиентТелефон;
СпрКли.Примечание = КлиентПримечание;
СпрКли.ОКПО = КлиентОКПО;
СпрКли.ДокНомер = КлиентСерияПасп;
СпрКли.ДокСерия = КлиентНомерПасп;
СпрКли.ИспользоватьДату(ДатаДокФайла); 
СпрКли.Записать();

Мне нада что бы у этого элемента был родитель, тоесть что бы он находился в греппе. Это все работает
   Serg_Y
4 - 19.11.04 - 01:32
Я конечно понимаю, что это може элементарно делается, но если не трудно то расскажите как???
   Asmody
 
5 - 19.11.04 - 01:38
откуда ты узнаЁшь, какой у клиента должен быть родитель?

(смешно сказал, но спросил серьезно, в меру возможного >;))
   Serg_Y
6 - 19.11.04 - 01:41
Я знаю какой он должен быть, тоесть я знаю его текстовое название, он во всех елементов один
мне хотя бы так сделать
   Asmody
 
7 - 19.11.04 - 01:52
СпрГ=СоздатьОбъект("Справочник.Контрагенты");
Если СпрГ.НайтиПоНаименованию(<наименованиегруппы>)=1 Тогда
    СпрКли.ИспользоватьРодителя(СпрГ.ТекущийЭлемент());
КонецЕсли;

дальше как у тебя...
   Serg_Y
8 - 19.11.04 - 02:07
Всеравно создает в корне справочника єлементы
   big
 
9 - 19.11.04 - 02:12
Попробуй
СпрКли.Новый(); 
СпрКли.ИспользоватьРодителя(СпрГ.ТекущийЭлемент());
СпрКли.Записать();
СпрКли.ИспользоватьДату(ДатаДокФайла);
и т.д.

Если честно, то уже похоже на танец с бубном, но все-таки. А вообще, добрый тебе совет, отложи до утра - помогает на 95%.
   bsg
10 - 19.11.04 - 02:12
(8) Значит нет у тебя группы с таким наименованием.
 
 
   bsg
11 - 19.11.04 - 02:25
+(10)
Попробуй вот так.
Замени наименованиегруппы на то, что тебе нужно.

Если СпрКли.НайтиПоНаименованию("наименованиегруппы")=0 Тогда
    СпрКли.НоваяГруппа();
    СпрКли.Наименование="наименованиегруппы";
    СпрКли.Записать(); 
КонецЕсли; 
СпрКли.ИспользоватьРодителя(СпрКли.ТекущийЭлемент()); 

СпрКли.Новый(); 
СпрКли.Наименование = КлиентНайм; 
СпрКли.ПолнНаименование = КлиентПолнНайм; 
СпрКли.Адрес = КлиентАдрес; 
СпрКли.НомерСвидетельства = КлиентНомерСвидетельства; 
СпрКли.ИНН = КлиентИНН; 
СпрКли.Телефоны = КлиентТелефон; 
СпрКли.Примечание = КлиентПримечание; 
СпрКли.ОКПО = КлиентОКПО; 
СпрКли.ДокНомер = КлиентСерияПасп; 
СпрКли.ДокСерия = КлиентНомерПасп; 
СпрКли.ИспользоватьДату(ДатаДокФайла); 
СпрКли.Записать();
   Serg_Y
12 - 19.11.04 - 02:27
А у тебя это работало???
   Serg_Y
13 - 19.11.04 - 02:29
Оки завтра еще гляну
всем спасибо
   bsg
14 - 19.11.04 - 02:31
(12) Я не знаю в какой конфигурации и какой справочник ты заполняешь.
Поэтому не могу проверить твой код у себя.
   alvandael
 
15 - 19.11.04 - 11:08
(11) ИМХО проблема в том, что ищется Наименование не дополненное пробелами до длины реквизита справочника Наименование. т.е.
Длина Наименования 25, а ищется строка  "Группа".
   SnarkHunter
 
16 - 19.11.04 - 11:14
Тупняк продолжается...
   321
 
17 - 19.11.04 - 11:17
Можно искать по первым символам, можно по коду.Куча вариантов...плюс нужна проверка на признак группы
   SKrin
 
18 - 19.11.04 - 11:26
сто пудово рабочий вариант:
    спр=СоздатьОбъект("Справочник.ФизЛица");
    спрГ=СоздатьОбъект("Справочник.ФизЛица");
    СпрГ.НайтиПоНаименованию("Водители",0,1);
    Спр.ИспользоватьРодителя(СпрГ.ТекущийЭлемент());
    спр.Новый();
    спр.Наименование="ааааа";
    спр.Записать();


это только пример на своей конфе
   321
 
19 - 19.11.04 - 11:31
(18)Ну не стопудовый...
   SKrin
 
20 - 19.11.04 - 11:36
(19) если есть группа "Водители", то 100 пудовый
   bsg
21 - 19.11.04 - 11:39
(20) А, если есть элемент "Водители"?
   Таня
 
22 - 19.11.04 - 11:41
вчерашняя битва за 100 баксов никого ничему не научила видимо... :-/
   SKrin
 
23 - 19.11.04 - 11:47
(21) ну да, согласен, нехватает нескольких проверочных условий
НО элемент то создается в группе "Водители"... это факт
   321
 
24 - 19.11.04 - 11:51
(23) Если есть элемент и группа с одноименным названием попробуй-ка спозиционироваться поиском по наименованию на одном, а потом на другом.Получишь фигу...
   427
 
25 - 19.11.04 - 12:01
И ЭтИ люди запрещают мне ковыряться в носе?
   SKrin
 
26 - 19.11.04 - 12:04
(24) он сначала находит группу
   Эт
27 - 19.11.04 - 12:11
патамушта ты сначала создал папку, а потом элемент. Теперь попробуй наоборот.
   SnarkHunter
 
28 - 19.11.04 - 12:15
Я в шоке...
   Asmody
 
29 - 19.11.04 - 12:19
(24) так можно:
ТекстСКЛ="
|SELECT Контрагенты.ID as [Группа $Справочник.Контрагенты]
|FROM $Справочник.Контрагенты as Контрагенты
|WHERE (Контрагенты.isfolder=1) AND (Контрагенты.ismark="""")
|  AND (Контрагенты.Desc="""+СокрЛП(наименованиегруппы)+")";
РС=СоздатьОбъект("ODBCRecordset");
РС.УстБД1С();
РС.Открыть(ТекстСКЛ);
Если РС.СтрокОбработано()>0 Тогда
    РС.ВНачало();
    Группа=РС.ПолучитьЗначение("Группа");
КонецЕсли;

ну или принерно так... не проверял.
   GrayT
 
30 - 19.11.04 - 12:21
Во тягомотину развели
   Guk
 
31 - 19.11.04 - 12:23
"Над дурман-травой стоит туман..." (с) Ноль
   Таня
 
32 - 19.11.04 - 12:27
и это при том, что автор уже давно слинял... :))
   miki
 
33 - 19.11.04 - 12:28
(32)+ Ему яйца оторвать надо. Было. Еще вчера. Если есть.
 
  Рекламное место пустует
   Asmody
 
34 - 19.11.04 - 12:32
да уж! субЧудила переЁматый! два дня всем мОзги ипЁтЪ!!! >;))
   Нервные
35 - 19.11.04 - 12:34
какие все.
Не дождетесь никак?
~~~~~~~~~~~
Наконец! После тусклой недели работы на адинэсэ. Солнце ударило из зенита (дальше по тексту МЖ)
   France
 
36 - 19.11.04 - 15:22
тему Элемент справочника - принадлежность группе  прибили..
бум теперь тут кролиководу СергЙ-у помогать:)))))
   SKrin
 
37 - 19.11.04 - 15:23
да он бы хоть сказал получилось у него или нет...
8)))))))
   321
 
38 - 19.11.04 - 15:24
Сэр гей, эт кто?
   miki
 
39 - 19.11.04 - 15:24
(37) Он сказал... Пару раз как min...
   Cheater
 
40 - 19.11.04 - 15:24
(37) Он не говорит, если не спросишь :(
   France
 
41 - 19.11.04 - 15:26
(39) но я ему, почему то, не поверил.. врал он..
кроликод но.. или же (38)? :)
   miki
 
42 - 19.11.04 - 15:40
(41) Что (кто) такое "кроликод"?
   France
 
43 - 19.11.04 - 15:42
(42) кроликовод...
а кроликами оказываются те, кто на него обратил внимания..
ЗЫ чур нея..
ЗыЗы и как там котенок твой?
   miki
 
44 - 19.11.04 - 16:07
(43)Живет, играется, пьет, жрет, срет. Все как у людей.
Как назвали забыл спросить.
   miki
 
45 - 19.11.04 - 16:47
   Serg_Y
46 - 19.11.04 - 18:33
добрый вечер всем обитателям форума
короче я уже все перепробовал все равно не пашет

Если СпрКли.НайтиПоНаименованию(КлиентНайм,0,1) = 0 Тогда
                               
СпрКли.Новый(); 
СпрКли.Наименование = КлиентНайм; 
СпрКли.ПолнНаименование = КлиентПолнНайм; 
СпрКли.Адрес = КлиентАдрес; 
СпрКли.НомерСвидетельства = КлиентНомерСвидетельства; 
СпрКли.ИНН = КлиентИНН;
СпрКли.Телефоны = КлиентТелефон;
СпрКли.Примечание = КлиентПримечание;
СпрКли.ОКПО = КлиентОКПО;
СпрКли.ДокНомер = КлиентСерияПасп;
СпрКли.ДокСерия = КлиентНомерПасп;
СпрКли.ИспользоватьДату(ДатаДокФайла); 
СпрКли.Записать();
СпрГ=СоздатьОбъект("Справочник.Клиенты"); 
Если СпрГ.НайтиПоНаименованию("Покупатели",0,0)=1 Тогда
//у меня в отладчике равно 0 тоесть не находит и соответственно

//не присваивает родителя, хотя группа сто пудов есть
//в чем глюк или может какой то другой способ поиска подскажете

//так что бы нашло группу
СпрКли.ИспользоватьРодителя(СпрГ.ТекущийЭлемент()); 
КонецЕсли; 

я вот думаю, а не может быть такой фишки я хочу найти "Покупатели"
а в справочник есть "Покупатели           " (пробелы до тех пор пока не выедет длину наименования)????
   Serg_Y
47 - 19.11.04 - 18:34
Второй день не могу ничего с этим сделать???
   miki
 
48 - 19.11.04 - 18:39
Вот еще баян по теме.
Вывалился мужик с пятого этажа, пьяный.
Ну вокруг толпа собралась. Что-то спорят, обсуждают.
Мужик очнулся через некоторое время, поднимается, видит - все вокруг на не него круглыми глазами смотрят. Он:
- А шо я? Я сам только подошел...
   427
 
49 - 19.11.04 - 18:57
пля... Это какая серия?
 
  Рекламное место пустует
   Таня
 
50 - 19.11.04 - 19:06
Serg_Y, ты мог бы ограничиться " добрый вечер всем обитателям форума", об остальном все и так бы догадались...
   Таня в пальто
51 - 19.11.04 - 19:13

   Таня
 
52 - 19.11.04 - 19:15
а еще наверно я в шапке, в валенках, в варежках...
Блин, какая я извращенка, дома в зимней одежде ходить...
   Таня
 
53 - 19.11.04 - 19:15
ты кто, Таня в пальто?
   LOSS
 
54 - 19.11.04 - 19:24
А впостели
   Vol71
 
55 - 19.11.04 - 19:24
Дежа вю



Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует