Вход | Регистрация


1С:Предприятие ::

Метки:

Как вытащить через OLE реквизит документа типа "Перечисление"?

Я
   Андрей66
18.11.04 - 19:10
открываю базу челез ОЛЕ. во внешней базе беру документ, одно из полей которого типа "справочник "услуги" а справочник имеет реквизит типа "Тип услуг" - перечисление. надо устроить проверку по этому реквизиту .

делаю все как в http://mista.ru/articles1c/ole.htm однако фиг :(

БазаОле.Initialize(БазаОле.RMTrade,"/d"+КаталогБазыОле+" /n"+ПользовательОле+" /p" +ПарольОле+МонопольныйРежимOLE,?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));

СчетаОМС=БазаОле.CreateObject("Документ.СчетОМС");
СчетаОМС.ВыбратьДокументы(ДатаС,ДатаПо);
Пока СчетаОМС.ПолучитьДокумент()=1 Цикл
    СчетаОМС.ВыбратьСтроки();
    Пока СчетаОМС.ПолучитьСтроку()=1 Цикл
        Пациент=СчетаОМС.Случай;
        Пациент.ВыбратьСтроки();
        Пока Пациент.ПолучитьСтроку()=1 Цикл
            БазаОлеПЦР=БазаОле.Перечисление.ТипУслуг.ПЦР;
            Если Пациент.Услуга.Тип=БазаОлеПЦР Тогда
                Сообщить("ПЦР");  //  <  ----   ВОТ ТУТ НЕ КАТИТ!

            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
КонецЦикла;

то есть строки документа выбирает, а до указанного места не доходит даже если там реально стоит нужный тип услуги.

что делать? как лечить?
 
 
   Бивень
 
1 - 18.11.04 - 19:29
Когда ты наконец почитаешь книжку, то поймёшь, что по ОЛЕ можно тягать только простые типы, каковыми перечисления не являются ...
   IAm
 
2 - 18.11.04 - 19:32
(1) Когда ты наконец подумаешь мозгом - то поймешь, что данное ограничение в случае с перечислениями легко обойти
   Недалекий
3 - 18.11.04 - 19:35
(2) А чё мозгом думать можно? Во как...
   Бивень
 
4 - 18.11.04 - 19:43
(2) Обход твой - это переретаскивание перечислений в виде номеров или идентификаторов. Это можно понять, даже думая задницей ...
   France
 
5 - 18.11.04 - 19:43
(0) получить порядковый номер значения перечисления из базы ОLE и проверять по нему..
   Недалекий
6 - 18.11.04 - 19:44
(4) Это по нашенски!!
   IAm
 
7 - 18.11.04 - 19:45
(4) Если задницей не думать - вариант с номером исчезает.
   France
 
8 - 18.11.04 - 19:46
(4) если у человека нету задницы, то он надумать ничего не сможет.. так что, надо было подсказать...

а как насчет кода то?.. а?
   Бивень
 
9 - 18.11.04 - 19:48
(8) А как насчет 100$ ?
   Недалекий
10 - 18.11.04 - 19:50
Люди гибнут за бабло.
 
  Рекламное место пустует
   Лошадка в пальто
 
11 - 18.11.04 - 19:51
10. А я за него кушаю и выпиваю...
   Недалекий
12 - 18.11.04 - 19:52
Первый раз вижу Лошадку, которая с такой скоростью с  ветки на ветку прыгает.
Ну, чисто, обезъяна (с гранатой).
   Лошадка в пальто
 
13 - 18.11.04 - 19:53
Я здесь приставлена скакать с ветки на ветку и пресекать флейм...
   IAm
 
14 - 18.11.04 - 19:55
Близкий видимо щитает лошадку и обезьяну одной и той же человекой
   Андрей66
15 - 18.11.04 - 19:55
(1)-(10) тогда почему в  http://mista.ru/articles1c/ole.htm
вот это работает :  

       Если ДокОле.ПризнакНакладной <> БазаОле.Перечисление.ПризнРасхНакл.ВозвратПоставщику Тогда
               Продолжить;
          КонецЕсли;

а?

а у меня по сути то же самое, но не пашет?
   Недалекий
16 - 18.11.04 - 19:56
Ой, боюсь, боюсь
   Андрей66
17 - 18.11.04 - 20:49

   Бивень
 
18 - 18.11.04 - 20:51
(17) Молчать будем?
   Андрей66
19 - 18.11.04 - 20:56
(17) да вот и я то же самое хотел спросить...

по (0), (15) идеи есть? а мож я тебе в аську стукну? объяснишь? :)
   Бивень
 
20 - 18.11.04 - 21:03
(19) Сравнить два перечисления можно, если оба они из одной базы ...
   Бивень
 
21 - 18.11.04 - 21:05
(19) В аську стукни, если знаешь её ...
   Андрей66
22 - 18.11.04 - 21:20
(20) кто ж ее не знает.. :)
   IAm
 
23 - 18.11.04 - 22:16
Вот так вот человек задал вопрос и в течение 22 постов не может получить ответ.
Стыдно должно быть Вам, г-н митичкин, что на вашем сайте такое. Впроче6м как говорится какой поп, такой и приход.
   Guk
 
24 - 18.11.04 - 22:28
ДокОле.СпособОплаты=База.Перечисление.СпособыОплаты.ЗначениеПоИдентификатору("ПоФакту");
   GrayT
 
25 - 18.11.04 - 22:43
Достали уже наезжать
   Guk
 
26 - 18.11.04 - 22:48
(25) Я не знал, что строчкой в (24) я на кого-то наехал. Простите...
   GrayT
 
27 - 18.11.04 - 22:53
(26)Я указывал строчку? я про 23 (вот прицепилось число)
Кстати, тебя банили что ли? что за тень тут от тебя пробегала?
   Guk
 
28 - 18.11.04 - 22:54
(27) Регистрироваться на курсах, посчитал моветоном...
   GrayT
 
29 - 18.11.04 - 22:57
Вот чем на курсах надо заниматься :)
   Guk
 
30 - 18.11.04 - 23:00
(29) На курсах не звери. Там тоже перерывы бывают...
   IAm
 
31 - 18.11.04 - 23:26
Достал тупить
   GrayT
 
32 - 18.11.04 - 23:28
(31)Пальцы разогни. С вас помощи порой, как с козла молока. Только тень на плетень.
   IAm
 
33 - 18.11.04 - 23:30
(32)
В чем причина хамства?
Кому, где и когда я должен был помочь?
 
  Рекламное место пустует
   GrayT
 
34 - 18.11.04 - 23:35
Ты про пальцы? Это образно. Имел ввиду не тебя конкретно (Если бы про тебя написал бы "Вас" с большой буквы), а супер спецов, постоянно наезжающих на форум и его обитателей.
   IAm
 
35 - 18.11.04 - 23:39
Запомните все. Когда граут пишет "(31)Пальцы разогни. " это во-первых образно, во-вторых про всех спецов, постоянно наезжающих на форум и его обитателей.
Мне нравится манера общения, сейчас тоже попробую.
   IAm
 
36 - 18.11.04 - 23:39
(34)
СРА
НЫЙ
МУДИ
ЛО
   IAm
 
37 - 18.11.04 - 23:40
В 36 это я конечно про полчища саранчи, мешающих самолетам в небе над каиром.
   IAm
 
38 - 18.11.04 - 23:41
+37 Конечно же образно, очень образно.
   GrayT
 
39 - 18.11.04 - 23:42
Мне вот твоя манера абсолютно не нравиться. Экран не забрызгал?
   GrayT
 
40 - 18.11.04 - 23:44
"Из двух сорящихся виноват тот кто умнее" - Извини - был не прав
   IAm
 
41 - 18.11.04 - 23:46
Умный GrayT видимо всерьез считает, что я с ним ссорюсь, но поскольку у него явно прослеживается комплекс быть умнее меня, то так и быть сделаю вид что я с ним ссорился и что я прав :)
   GrayT
 
42 - 18.11.04 - 23:48
Я не считаю себя умнее тебя по ряду причин. И такие комплексы за собой не замечаю вообще.
Ладно - проехали
   IAm
 
43 - 18.11.04 - 23:50
42 Я тоже не считаю, что ты так считаешь, мне просто забавно наблюдать как ты оправдываешься. :)
   GrayT
 
44 - 18.11.04 - 23:54
И почему я такой правильный?
   IAm
 
45 - 18.11.04 - 23:55
Слишком много правил.
   IAm
 
46 - 18.11.04 - 23:56
Правил - существительное.
   IAm
 
47 - 18.11.04 - 23:56
Спокойной ночи.
   GrayT
 
48 - 18.11.04 - 23:58
Возможно.
   GrayT
 
49 - 19.11.04 - 00:00
И тебе удачно провести время ;)
 
 
   Андрей66
50 - 19.11.04 - 00:55
GrayT, IAm !  Вы знаете, есть такая программка, ICQ называется...



Список тем форума
Рекламное место пустует  
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует