Вход | Регистрация


1С:Предприятие ::

Метки:

!!! Помогите разобраться с циклом

Я
   Novichek
 
18.11.04 - 10:37
Спр=СоздатьОбъект("Справочник.Товары");
    РегТовары = СоздатьОбъект("Регистр.ОстаткиТоваров");  
    Спр.ИспользоватьРодителя(группаОткуда);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
        Если (Спр.ТекущийЭлемент().ЭтоГруппа()=0) Тогда
            Если РегТовары.СводныйОстаток(Спр.ТекущийЭлемент(),,"ОстатокТовара")=0 Тогда
                Спр.Родитель=ГруппаКуда;
            КонецЕсли;
        КонецЕсли;
        Спр.Записать();
   КонецЦикла;
Нужный элемент находит и  выходит из цикла.
А надо чтобы всю группу до конца пробежала.
 
  Рекламное место пустует
   miki
 
1 - 18.11.04 - 10:43
(0) У тебя после
    Спр.Родитель=ГруппаКуда;
...
      Спр.Записать();
текущий элемент в выборке выходит из этой выборки.
Короче, сам же пишешь "Использовать родителя". А потом меняешь этого родителя.
   Novichek
 
2 - 18.11.04 - 10:43
Почему на Спр.Записать(); процедура завершает свою работу?????????
   GrayT
 
3 - 18.11.04 - 10:44
Логично - сбил выборку изменив родителя.
Загоняй в тз, и вторым проходом по ТЗ переприсваивай
   vS
 
4 - 18.11.04 - 10:45
потому, что при записи спр. перепозиционируется
и ваще...
занеси Записать в условие, где присваиваешь...
и лучще находи этот элемент в другом справочнике, и его записывай
   miki
 
5 - 18.11.04 - 10:46
(2) На или после?
   miki
 
6 - 18.11.04 - 10:48
(3,4)+ Лучше в список, а потом цикл по списку.
Или попробуй вместо "Использовать родителя" проверять на вхождение в группаОткуда в цикле по элементам справочника.
   Славко
 
7 - 18.11.04 - 10:48
:)))))
вместо...
   Tarlich
 
8 - 18.11.04 - 10:50
Правильнее сделать запрос и указать товар в группа откуда
   GrayT
 
9 - 18.11.04 - 10:50
(6)Чем лучше?
   vS
 
10 - 18.11.04 - 11:22
правильнее, не факт быстрее...
 
  Рекламное место пустует
   miki
 
11 - 18.11.04 - 11:25
(9) Зачем таблицу для одной колонки?
   GrayT
 
12 - 18.11.04 - 11:28
(12)Незачем, самое смешное что сз быстрее ;)
Переклинил, думал группа куда разная
   NS
 
13 - 18.11.04 - 11:28
(11) А зачем список, для одной колонки?
В списке их две!
   GrayT
 
14 - 18.11.04 - 11:29
(13)Три
   miki
 
15 - 18.11.04 - 11:30
(13) Тогда уж три.
   NS
 
16 - 18.11.04 - 11:31
(14,15) Торможу... Третья какая? Флаг?
   NS
 
17 - 18.11.04 - 11:31
То есть пометка?
   miki
 
18 - 18.11.04 - 11:33
(16) Смотря какая у тебя вторая.
   NS
 
19 - 18.11.04 - 11:33
(18) Это смотря какая первая ;-)
   miki
 
20 - 18.11.04 - 11:34
(19) ОК :)
   Novichek
 
21 - 18.11.04 - 11:35
Неужели все так сложно,
Разве нельзя просто зациклить??????????????????????
   NS
 
22 - 18.11.04 - 11:53
Нельзя!
Ты будешь заново перебирать все элементы с самого начала.
Что будет быстрее?



Список тем форума
Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует