Вход | Регистрация

1С:Предприятие ::

Метки:Встроенный язык

Вопрос по ПлануОбмена

Я
   flood
 
17.11.04 - 08:19
Необходимо что бы в перефирийную базу справочник "Контрагенты" выгружался без поставщиков. Как лучше всего реализовать, подскажите.
 
  Рекламное место пустует
   flood
 
1 - 17.11.04 - 08:52
Я так думаю надо програмно фильтровать по галочке "Поставщик" из реквизитов контрагента,и устанавливать АвтоЗаполнение = ложь. Больше ничего в голову пока не приходит.
   Волшебник
 
2 - 17.11.04 - 09:14
(1) Можно и так, но ненадежно.
Лучше использовать событие ПриОтправкеДанныхПодчиненному
   flood
 
3 - 17.11.04 - 09:28
Вообще задача такая что в филиал должны передаваться только "Номенклатура", "Контрагенты" без поставщиков, и "Перемещение товаров" которое приходует товар на склад в филиале. А в центральную базу должно попадать все из филиала. Поэтому в план обмена должны включатся все объекты метаданных, а при обмене програмно исключатся ненужные. Так я понимаю? А как насчет УдалитьРегистрациюИзменений()?
   Волшебник
 
4 - 17.11.04 - 09:34
(3) Так.
Регистрацию изменений лучше не трогай.
   Волшебник
 
5 - 17.11.04 - 09:35
(4)+ Не то чтобы это нельзя категорически, просто это ненадежно.
В одном месте предусмотришь явное заполнение получателей, а объект изменится в другом месте и пойдет в филиал.
   flood
 
6 - 17.11.04 - 09:39
ПриОтправкеДанных вызывается для каждого измененного объекта?
   flood
 
7 - 17.11.04 - 09:39
ПриОтправкеДанныхПодчиненному()
   Волшебник
 
8 - 17.11.04 - 09:45
(6) Да. Для каждого объекта и набора записей.
   flood
 
9 - 17.11.04 - 09:54
А как отменить обмен для подчиненных справочников "Контрагента", тоже вручную?
Насколько верно вот такое решение?
Если ТипЗнч(НовыыйЭлемент) = Тип("СправочникОбъект.Контрагенты") Тогда
   Если НовыйЭлемент.Поставщик Тогда
                  ...........................
    КонецЕсли;
ИначеЕсли ТипЗнч(НовыйЭлемент) = Тип("СправочникОбъект.ЮридическиеЛица") Тогда
     Если НовыйЭлемент.Контрагент.Поставщик Тогда
                   .............................
     КонецЕсли;
ИначеЕсли ТипЗнч(НовыйЭлемент) = Тип("СправочникОбъект.ДоговорыВзаиморасчетов") Тогда
    Если НовыйЭлемент.Владелец.Поставщик Тогда
          ..........................
    КонецЕсли;
КонецЕсли;
   Волшебник
 
10 - 17.11.04 - 10:00
Нормально
 
 


Список тем форума
Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует