Вход | Регистрация


1С:Предприятие ::

Метки:Запросы и построители

Запрос скинуть не в таблицу значений, а в Excel

Я
   jetcom
 
16.11.04 - 17:48
Всем привет! Имеем запрос, но как его скинуть не в таблицу значений, а в Excel? (собственно в теме)
А запросик то на тему про "сертификаты" как раз в помощь человеку, - жаль опаздал:))
//*******************************************

// Процедура генерации запроса Сформировать.
//

Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
   //Проверка выбора группы

Если ВыбТекущийЭлемент.ЭтоГруппа()=0 Тогда
    Предупреждение("Надо выбрать группу справочника!");
    Возврат;
КонецЕсли;   
   //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса ="
   //{{ЗАПРОС(Сформировать)

    |ТМЦ = Справочник.Номенклатура.ТекущийЭлемент;
    |Код = Справочник.Номенклатура.Код;
//    |Наименование= Справочник.Номенклатура.Наименование;

    |Сертификаты = Справочник.Номенклатура.Сертификаты;
    |СертификатДействителенДо = Справочник.Номенклатура.СертификатДействителенДо;
    |НомерГТД = Справочник.Номенклатура.НомерГТД;
    |СтранаПроисхождения = Справочник.Номенклатура.СтранаПроисхождения;
    |Группировка ТМЦ упорядочить по ТМЦ.Наименование; 
    |Условие(ТМЦ в ВыбТекущийЭлемент);";
   //}}ЗАПРОС

   // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
   // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать"); 
   // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
        Пока Запрос.Группировка(1) = 1 Цикл
       // Заполнение полей ТекущийЭлемент

        Таб.ВывестиСекцию("ТекущийЭлемент");
    КонецЦикла;
   // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
 
 
   Лошадка в пальто
 
1 - 16.11.04 - 17:54
Можешь вместо строк лить в эксель через ОЛЕ...долго и нудно...
А можешь прочитать ЖКК и увидеть что сформированную таблицу легко можно сохранить как МХЛ,ХЛС,ТХТ или ХТМЛ файл.
   jetcom
 
2 - 16.11.04 - 17:59
(1)Если можно, одну строчечку про метод "Сохранить как"...
Какой его синтаксис в 1С?
   Лошадка в пальто
 
3 - 16.11.04 - 18:01
В синтаксис помощник
   jetcom
 
4 - 16.11.04 - 18:05
Сохранить(<ИмяФайла>)
Это???
   Лошадка в пальто
 
5 - 16.11.04 - 18:05
Гд-то в разделе про работу с таблицами.
   jetcom
 
6 - 16.11.04 - 18:12
Не нашел...
   Лошадка в пальто
 
7 - 16.11.04 - 18:13
не помню я навскидку.Открой книжку
   jetcom
 
8 - 16.11.04 - 18:17
Про тиски помнишь?!?!?
А про таблицы нет...
;)
   Лошадка в пальто
 
9 - 16.11.04 - 18:18
Про таблицы не помню. Я их чо, каждый день сохраняю как ХЛС? Понадобится, книжку открою
   Бивень
 
11 - 16.11.04 - 18:29
Лошадка, а тебя сильно затруднит, посмотреть книжку, найти там нужный метод и ответить джеткому?
   Лошадка в пальто
 
12 - 16.11.04 - 18:31
нету у меня книжки с собой... и одинэски нету...
Тем более мне что в такую погоду промозглую отвлекаться от беседы с милыми мне людьми и вкусной рюмки коньячку?
   jetcom
 
13 - 16.11.04 - 18:35
Рукописи не горят, а спасибки не сносятся, Лошадка! :)
   427
 
20 - 16.11.04 - 21:47
200 баксов - и 1С вместо полутора часов будет писать в Ексель 1.5 минуты...
   Asmody
 
21 - 17.11.04 - 00:12
(20) с сохранением форматированя и без ВК? >;))
   jetcom
 
22 - 05.12.04 - 09:48
Что нужно добавить в этот код, чтобы при нажатии на ячейку ТЗ открывался соответствующий элемент номенклатуры, как "по ссылке" ?
Это оч. сложно делается?
   jetcom
 
23 - 05.12.04 - 09:51
Естесственно, не ТЗ (очепятка), а таблицы...
   Ёжик в тумане
 
24 - 05.12.04 - 09:52
(22) Нет, не сложно.
   jetcom
 
25 - 05.12.04 - 23:23
(24)Сложней, чем написать "(22) Нет, не сложно." ? ;)
   Ёжик в тумане
 
26 - 05.12.04 - 23:28
(25) Самую малость.
   jetcom
 
27 - 05.12.04 - 23:32
(24+25+26)=Тогда.Конечно.Сложно.
И как жешь я тебя понимаю...
   Ёжик в тумане
 
28 - 05.12.04 - 23:36
А вот я тебя не очень...
   jetcom
 
29 - 05.12.04 - 23:39
Для этого нужно всего-то выйти из тумана ;)
Где-ж тут понять то, когда руки своей не видно...
   Ёжик в тумане
 
30 - 05.12.04 - 23:46
(29) Ну руку-то я, допустим, вижу.. :)
   jetcom
 
31 - 05.12.04 - 23:48
Дружище! Ты бы название метода подсказал, если сам знаешь, а я уж поиском сам накопаю чего-нить...
А туману тут на форуме и без тебя хватает ;)
   Ёжик в тумане
 
32 - 05.12.04 - 23:50
(31) Слышал такое слово "расшифровка"?
А вообще - взял бы ты какой-нибудь типовой отчёт, где так сделано, да и посмотрел, как оно там.
   jetcom
 
33 - 05.12.04 - 23:58
Вот с этого можно было бы и начать, спасибо!
Слышал, конечно. Но в  ТИС 9.2 7.70.935 есть такой отчет: "Карточка количественно-суммового учета", так вот там словом "Расшифровка" (через поиск) и не пахнет. Наверное, ссылается на глобальник, а там уже идет доработка в этом плане? Ведь других методов, кроме "Расшифровки", я думаю нет...
 
  Рекламное место пустует
   Ёжик в тумане
 
34 - 06.12.04 - 00:00
(33) Интересно, ты в свойства ячейки таблицы хоть когда-нибудь заглядывал?
   jetcom
 
35 - 06.12.04 - 00:01
В типовых много наверчено постороннего, чтобы толком разобраться с этим.
Поэтому хотел, чтобы кто-нить на моем же простейшем примере показал, как это реализуется, - вот тогда можно "въехать" с пол-оборота... Если это не оч. сложно, как ты говоришь.
Ну а если проблематично, - буду разбираться сам.
   1С Дурочка
35 - 06.12.04 - 00:01
Для начала, напиши то, что у тебя в ячейке в поле "Расшифровка"
   jetcom
 
37 - 06.12.04 - 00:03
(34)Заглядывал, и ... что? ;)
   jetcom
 
38 - 06.12.04 - 00:06
(35)Вввввау! Вот оно! Это и все? Так просто? Расшифровка: Запрос.ТекДок
   jetcom
 
39 - 06.12.04 - 00:07
(38) Это из этого типового отчета.
   jetcom
 
40 - 06.12.04 - 00:08
Оказывается все дело в свойстве ячейки!?!
Я думаю, что возможно его также программно менять...
   Guk
 
41 - 06.12.04 - 00:09
Люблю людей под шафе...
   1С Дурочка
42 - 06.12.04 - 00:09
Если это ссылка на объект метаданных, то этого достаточно, чтобы ячейка "расшифровалась" этим объектом.
   jetcom
 
43 - 06.12.04 - 00:14
(41) Если это про меня, то ты проницателен, :)) да, только что разбрелись гости, - моей доче сегодня ровно годик исполнился! Но я всегда эмоционален, так что ты там не очень! ;)
   Синхронизатор
 
44 - 06.12.04 - 03:56
Джетком, ещё ОЧЕНЬ рекомендую внимательно покурить текст Экспорт-процедуры "ОбработкаЯчейкиТаблицы(..)" Глобального модуля.
А ещё - стараться поменьше хамить, даже если тебя провоцируют. Гордые самураи из соседнего аула, к примеру, очень стыдятся и называют "потерять лицо", если их удается на такое спровоцировать - иногда стыдятся так сильно, что делают харакири мечом вакидзаси...
   427
 
45 - 06.12.04 - 07:08
+44 - и заодно обнаружить в данной процедуре маленькую свинюшку... Аккуратно выращенную там...


(21) Да, без ВК.
   vS
 
46 - 06.12.04 - 07:14
(44) каким мячом?
   jetcom
 
47 - 07.12.04 - 03:02
(44)внимательно покурил, но
(45)свинку не обнаружил, а интересно очень, как она может выглядеть?



Список тем форума
 
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует