Вход | Регистрация

1С:Предприятие ::

Метки:

Двойной отбор в общем журнале

Я
   AndreYar
16.11.04 - 15:10
У меня в доке есть такой реквизит многострочной части как "Документ" он заполняется из общего журнала с установленным отбором по текущему поставщику, но вот беда в выборку попадают и другие виды документов.Как сделать так чтобы был установлен еще и отбор по виду документа
 
 
   GrayT
 
1 - 16.11.04 - 15:17
Ни кто не хочет отвечать, просто всем надоело.
Либо составное поле, либо обработка с ТЗ на форме.
Короче в поиск - уже много говорили
   Tarlich
 
2 - 16.11.04 - 15:36
обработка с ТЗ - я так делал
   Andreyar
3 - 16.11.04 - 15:56
а где ее нарыть
   Tarlich
 
4 - 16.11.04 - 15:58
че рыть делай сам
   AndreYar
5 - 16.11.04 - 16:00
у меня время в обрез
   GrayT
 
6 - 16.11.04 - 16:01
На прослабе вроде были настраиваемые журналы. Но проще самому
   Tarlich
 
7 - 16.11.04 - 16:03
делов 5 минут
   Витаэль
 
8 - 16.11.04 - 16:05
7. Смотря как делать.
   Tarlich
 
9 - 16.11.04 - 16:12
в документе делаеш
ПриНачалеВыбораЗначения()
Если нужный тебе элемент тогда открываеш сделанную обработку
которая при открытии заполнится как тебе надо
   AndreYar
10 - 16.11.04 - 16:18
а поподробней
 
  Рекламное место пустует
   GrayT
 
11 - 16.11.04 - 16:26
Вот пример:
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Без итогов;
    |Док = Документ.ПартияВПроизводстве.ТекущийДокумент;
    |ВидПартии = Документ.ПартияВПроизводстве.ВидПартии;
    |Группировка Док;
    |//}}ЗАПРОС

    ;           
    Если ВидПартии.ТекущаяСтрока()>1 Тогда
        ВыбВидПартии = ВидПартии.ПолучитьЗначение(ВидПартии.ТекущаяСтрока());
        ТекстЗапроса = ТекстЗапроса + "Условие (ВидПартии=ВыбВидПартии);"
    КонецЕсли;
    
   // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли; 
    Состояние("Поиск документов");
    Док = СоздатьОбъект("Документ");
    ТабДокументов.УдалитьСтроки();
    Пока Запрос.Группировка() = 1 Цикл  
        ТабДокументов.НоваяСтрока();
        ТабДокументов.ДатаДок    = Формат(Запрос.Док.ДатаДок, "ДДММГГГГ");
        ТабДокументов.ВремяДок    = Запрос.Док.ПолучитьВремя();
        ТабДокументов.НомерДок    = Запрос.Док.НомерДок;
        ТабДокументов.Док        = Запрос.Док;
        ТабДокументов.ВсегоОп    = Запрос.Док.КоличествоСтрок();
        ТабДокументов.Выполнено    = Запрос.Док.ПоследняяОперация.НомерОперации;
        ТабДокументов.ВидПартии = Запрос.Док.ВидПартии;
    КонецЦикла;
КонецПроцедуры

ТабДокументов - таблица на форме
   AndreYar
12 - 16.11.04 - 16:29
пасибо


Список тем форума
Рекламное место пустует   Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует