Вход | Регистрация

1С:Предприятие ::

Метки:внешние компоненты

Объект V7TextFile - как подключить и где взять

Я
   MobilSoyuz
 
16.11.04 - 09:59
Объект V7TextFile - как подключить и где взять.
и как можно обойтись без нее!
Заранее благодарен за ответы.
 
 
   wolk
 
1 - 16.11.04 - 10:07
В Конфигураторе нажми Ctrl+F1, далее ищи про работу с текстом. Активно пробуй применить полученные знания на практике. Если останутся какие-то вопросы - пиши здесь.
   Волшебник
 
2 - 16.11.04 - 10:11
   Волшебник
 
3 - 16.11.04 - 10:13
v7plus вообще содержит:

Шлюз к MS Internet Explorer
Работа с почтовым клиентом через MAPI
Отсылка запросов по HTTP и обработка результатов
Обработка XML-документов через MSXML
Получение системной информации
Прямое чтение и запись текстовых файлов

http://www.erp-volga.com/hare/add-in/addin.v7plus.html
   MobilSoyuz
 
4 - 16.11.04 - 10:33
Как загрузить текстовый файл для дальнейшего его исользования без помощи v7plus ?
   Волшебник
 
5 - 16.11.04 - 10:37
(4) Используй объект Текст.
   MobilSoyuz
 
6 - 16.11.04 - 11:53
Процедура Выполнить()
    перем флаг, имяФайла;
    флаг=ФС.ВыбратьФайл(0,имяФайла,,"Находим нужный файл.txt","Текстовые файлы|*.txt");
    Если флаг=1 Тогда
         текст=СоздатьОбъект("Текст");
        Текст.Очистить();
        Текст.Открыть("D:\"+имяФайла);
        ыы= Текст.КоличествоСтрок();
        Если ыы = 0 Тогда
          Предупреждение("Текст Пустой!");
          Возврат;
        КонецЕсли;
        Ном = 1;
        Пока Ном <= ыы Цикл
        Текст = Текст.ПолучитьСтроку(Ном);
        ТекстСписок.ДобавитьЗначение(Текст);
        Ном = Ном+1;
        КонецЦикла;
        Форма.Обновить();
    
    КонецЕсли;
КонецПроцедуры

Считывается только первая строка, потом пишет ошибку:
Текст = Текст.ПолучитьСтроку(Ном);
: Значение не представляет агрегатный объект (ПолучитьСтроку)
Подскажите, что не так (может конечно и в ДНК...,но и это допускаю, но все же!! :-))
   Волшебник
 
7 - 16.11.04 - 11:54
Текст = Текст.ПолучитьСтроку(Ном); 

Называй переменные по-разному, ладно?
   MobilSoyuz
 
8 - 16.11.04 - 11:59
(7) Волшебник - Огромное СЕНЬКС, за помощь!!!
Уразумею!!!
   MobilSoyuz
 
9 - 16.11.04 - 12:15
Тему можно закрыть!!!
Всем спасибо!
   Волшебник
 
10 - 16.11.04 - 12:16
(9) После создания темы автор не имеет на нее никаких прав.
Читай тут http://forum.mista.ru/rules.htm и тут http://forum.mista.ru/about.htm
 
 


Список тем форума
Рекламное место пустует   Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует