Вход | Регистрация

1С:Предприятие ::

Метки:

Вопрос по ОбработкаОжидания()

Я
   Diter
 
15.11.04 - 10:05
Можно ли через ОбработкаОжидания передавать в вызываемую процедуру параметр? Заранее спасибо.
 
 
   GrayT
 
1 - 15.11.04 - 10:14
Нет наверное - юзай глобальные переменные
   Diter
 
2 - 15.11.04 - 10:22
(1) Обидно :(((
Эй зубры!!! Это правда? (нисколько не умаляю знаний Сергея (1))
   NiGMa
 
3 - 15.11.04 - 10:23
(0) Точно нельзя.
Если глобальная ОбработкаОжидания() - то через глобальную переменную, если Форма.ОбработкаОжидания() - можно через переменную модуля формы.

Кстати - Форма.ОбработкаОжидания() в модальном режиме не работает.
   Diter
 
4 - 15.11.04 - 10:30
(3) Интересно, а я просто использовал в контексте формы ОбработкаОжидания() (без "Форма.").
Да, кстати - а можно через эту процедуру в контексте формы вызвать не глобальную а "местную" процедуру из модуля формы?
   GrayT
 
5 - 15.11.04 - 10:34
(4) Можно, если использовать Форма. :))))
   Diter
 
6 - 15.11.04 - 10:41
(5) А вот и не получается

Процедура ОтменаПроведения() Экспорт
    Сообщить("Получилось в форме");
КонецПроцедуры

Форма.ОбработкаОжидания("ОтменаПроведения",1);
ОбработкаОжидания("глОтменаПроведения",1);

В глобальнике точно такая же процедура только глОтменаПроведения. Так вот при работе происходит запуска только процедуры в глобальнике :(
   GrayT
 
7 - 15.11.04 - 10:46
Модуль формы
Процедура ПоказатьВремя()
 Форма.ТекстНаФорме.Заголовок(ТекущееВремя());
КонецПроцедуры

Процедура ПриОткрытии()
 Форма.ОбработкаОжидания("ПоказатьВремя", 1);
КонецПроцедуры

А так?
   Diter
 
8 - 15.11.04 - 10:49
(7) Спасибо!!!!!!!!!
:)))))))))
   GrayT
 
9 - 15.11.04 - 10:50
Как ребенок, честн слово ;)
Пжлста :)
   Diter
 
10 - 15.11.04 - 10:53
(9) ???????????
 
  Рекламное место пустует
   GrayT
 
11 - 15.11.04 - 10:58
(10)Не напрягайся. Просто прикололся над твоей искреней радостью (по доброму).
Ок.
   Diter
 
12 - 15.11.04 - 11:05
(11) Будешь тут рад. Мне нужно организовать отмену проведения документа из его формы. Использовать глобальную процедуру несколько неудобно. Т.к. работа с этим документом происходит максимум один раз в день, а обращение к процедуре - всё время работы 1С. Сделать через обработку ожидания в форме не получилось. Вот и радуюсь, что подсказали нужное направление. :)
   GrayT
 
13 - 15.11.04 - 11:24
Так погоди - вроде совсем недавно эту тему поднимали. Ее что так и не решили?
   32I
 
14 - 15.11.04 - 11:28
тест
http:\\1c.ru\news
<a href='http:\\1c.ru\news'>test</a>
   GrayT
 
15 - 15.11.04 - 11:29
(14) Гы. Еще один
   32I
 
16 - 15.11.04 - 11:30
(15) понимаю, что не в тему. но! как делать гиперссылки?
   Diter
 
17 - 15.11.04 - 11:32
(13) Да почему ж не решили. Решение давно известно. Вопрос в другом - форма документа не успевает закрыться до того как у этого документа созданого найденого через СоздатьОбъект() отменяется проведение. Вот и надо паeзу сделать в работе обработки. Вjпрос у меня был не в этом. Мне нужно было запустить через обработку ожидания процедуру модуля формы.


Список тем форума
  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует