Вход | Регистрация

1С:Предприятие ::

Метки:

Вызов процедуры из своего тела по условию.

Я
   THawk
 
12.11.04 - 14:36
Работоспособна ли данная конструкция. По идее должна работать но, зависла.
Процедура OSIZ_FillTable(Tbl, ДатКон) Экспорт  
    ДатаКонца = КонМесяца(ДатКон);
    КВ = СоздатьОбъект("Справочник.КоэффициентыВозмещения");
    КВ.ВыбратьЭлементы();
    Если КВ.ВыбратьЭлементыПоРеквизиту("ДатаОстатка", ДатаКонца, 0, 0) = 1 Тогда
         Пока КВ.ПолучитьЭлемент() = 1 Цикл  
           //Передача данных при наличии (выполнение неких действий)         

         КонецЦикла;    
    Иначе
         УстановкаСТекущейДатой(ДатаКонца);//заполним таблицу 

         OSIZ_FillTable(Tbl, ДатКон);// снова вызываем процедуру 

    КонецЕсли;
КонецПроцедуры
 
 
   Guk
 
1 - 12.11.04 - 14:38
(0) "Вызов процедуры из своего тела", называется проще - рекурсия. В 1С она работает...
   321
 
2 - 12.11.04 - 14:39
(0)Первое,что бросается в глаза-это двойная выборка элементов справочника
   THawk
 
3 - 12.11.04 - 14:55
Да простите ощибка,
ответ  что рекурсия 1с работает,  меня  очень радует...
   Guk
 
4 - 12.11.04 - 14:56
(3) Приходите к нам еще, задавайте вопросы (с)...


Список тем форума
 
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует