Вход | Регистрация

1С:Предприятие ::

Метки:справочники

Раскрытие дерева папок

Я
   arno131
 
12.11.04 - 14:15
Можно ли сделать так, что при открытии справочника, к примеру "Номенклатура", дерево папок программно раскрывалось?
 
 
   arno131
 
1 - 12.11.04 - 14:18
Забыл сказать, платформа 1Cv77
   321
 
2 - 12.11.04 - 14:22
Что за бред...зачем это делать программно?
   arno131
 
3 - 12.11.04 - 14:29
Экономия в несколько кликов при выборе номенклатурной позиции.
   321
 
4 - 12.11.04 - 14:33
(3)Если ты имеешь ввиду иерархический режим,как его установил, так он и будет дальше...
   arno131
 
5 - 12.11.04 - 14:40
Я имел ввиду, что при открытии дерево групп раскрывалось:

                          -=Справочник Номенклатура=-

  Дерево групп             #               Многострочная часть
============================================================================
[-] Уровень 1
  [-] Уровень 2
    [-] Уровень 3
       ....
   321
 
6 - 12.11.04 - 14:51
Есть один метод называется АктивизироватьОбъект(), но он работает в случае подбора из формы списка этого справочника
   Бивень
 
7 - 12.11.04 - 15:08
Штатными средствами нельзя! ...
   321
 
8 - 12.11.04 - 15:58
(0)Для открытия нужной папки всего лишь нужно программно
установить курсор на любом элементе из этой папки.Это делается при помощи метода
АктивизироватьОбъект(), см. выше...
   NiGMa
 
9 - 12.11.04 - 17:53
(8) Речь-то немного о другом - нужен программный аналог пункта меню "Найти в дереве"... а его нет :(
Можно попробовать через WinScript... нелегко, однако...

Придется переходить на v8 ;) там есть, кажется.
   427
 
10 - 12.11.04 - 18:31
(9) кто выкладывал способ... по моему WinScript....

зы не интересовало никогда.
 
 
   427
 
11 - 12.11.04 - 18:31
Пардон
(9) кто то выкладывал способ... по моему WinScript....

зы не интересовало никогда.
   GrayT
 
12 - 12.11.04 - 18:39
Не знаю кто и как выкладывал, это я нарисовал:

Перем Сз, ТекСтрСЗ, МожноЗакрыть;
    
//_____________________________________________________________________________

Функция  ПоказатьУровень()
            Если ТекСтрСЗ = сз.РазмерСписка() Тогда
                Возврат ""; 
            КонецЕсли;
            МожноЗакрыть=0;
            Форма.Закрыть();
КонецФункции//ПоказатьУровень()

//_____________________________________________________________________________
Процедура ПоКнопке() 
    ПредУровень=1;
    ПредЭлемент="";
    сч=0;
    сз = СоздатьОбъект("СписокЗначений"); 
    спр = СоздатьОбъект("Справочник.ОбъектыУчета");
    спр.ВыбратьЭлементы(1);
    Пока спр.ПолучитьЭлемент()=1 Цикл
        Если ПредУровень = спр.Уровень() Тогда
            Продолжить;
        ИначеЕсли спр.Уровень()>ПредУровень Тогда
            ПредЭлемент = спр.ТекущийЭлемент();
            ПредУровень = спр.Уровень();
            Продолжить;
        КонецЕсли;
        
        сз.ДобавитьЗначение(ПредЭлемент);
        ПредУровень = спр.Уровень();
        ПредЭлемент = спр.ТекущийЭлемент();
    КонецЦикла;
    
    ТекСтрСЗ = 1; 
    ФОрма.Обновить();
КонецПроцедуры//ПоКнопке


////_____________________________________________________________________________

Процедура ПриЗакрытии()
    Если МожноЗакрыть=0 Тогда
        АктивизироватьОбъект(сз.ПолучитьЗначение(ТекСтрСЗ));
        WshShell = CreateObject("WScript.Shell");
        WshShell.SendKeys("%"); 
        WshShell.SendKeys("Д");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{DOWN}");
        WshShell.SendKeys("{ENTER}"); 
       //Форма.Обновить();

        ТекСтрСЗ = ТекСтрСЗ + 1;
        МожноЗакрыть = 1;
        СтатусВозврата(0); 
    КонецЕсли;
КонецПроцедуры//ПриЗакрытии


ТекСтрСЗ = 0;
сз = СоздатьОбъект("СписокЗначений"); 
МожноЗакрыть = 1;

ЗЫ: Может и криво - главное идея - можно подшлифовать.
гы- на большом справочнике моргает красиво :))

Да на форме кнопка и текст с "ПоказатьУровень()"


Список тем форума
  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует