Вход | Регистрация

1С:Предприятие ::

Метки:

Есть возможность удалить программно периодический реквизит?

Я
   Kopyl
 
12.11.04 - 13:17
Для периодических реквизитов:
-Получить()-есть
-Установить() -есть
А как убрать его вооще? (если дата извесна)
И как определить программно дату установки этого периодического реквизита?
 
  Рекламное место пустует
   Бивень
 
1 - 12.11.04 - 13:22
Читай про объект "Периодический".
   skunk
 
2 - 12.11.04 - 13:31
Удалить()
Delete()
Синтаксис:
Удалить()
Назначение:
Удалить периодическое значение на заданную дату.
Возвращает: 1 - если вызов метода закончился успешно, 0 - иначе.
Замечание:
До вызова данного метода периодическое значение следует выбрать при помощи методов ПолучитьЗначение или НайтиЗначение.
   321
 
3 - 12.11.04 - 13:34
Вот люди блин пошли...он же не про значение спрашивает
   Бивень
 
4 - 12.11.04 - 13:37
(3) Забьёмся?
   321
 
5 - 12.11.04 - 13:38
(4)Уточни пж-та
   skunk
 
6 - 12.11.04 - 13:39
неа он именно это и имел ввиду... значение реквизита... ибо сам реквизит ;)
   Kopyl
 
7 - 12.11.04 - 13:42
(1)
Получилось Спасибо.
   Kopyl
 
8 - 12.11.04 - 13:43
Тупо и просто
Процедура Убрать()
    СпрФ = СоздатьОбъект("Справочник.Фирмы");
    СпрФ.ПорядокКодов();
    СпрФ.ВыбратьЭлементы();
    Дата1=Дата(2004,11,05);
    Дата2=Дата(2004,10,25);
    Дата3=Дата(2004,10,29);
    Пока СпрФ.ПолучитьЭлемент() = 1 Цикл
        ПерЕлем = СоздатьОбъект("Периодический");
        Попытка 
            ПерЕлем.ИспользоватьОбъект("СуммаКредита",СпрФ);
            Сообщить(СпрФ);
            ПерЕлем.ВыбратьЗначения();
                   Пока ПерЕлем.ПолучитьЗначение() = 1 Цикл
                    ДатаЗначения = ПерЕлем.ДатаЗнач;
                    Если (ДатаЗначения=Дата1) или (ДатаЗначения=Дата2) или (ДатаЗначения=Дата3)  Тогда
                           ПерЕлем.Удалить();
                    КонецЕсли;
                КонецЦикла;
        Исключение
        КонецПопытки;
    КонецЦикла;          
    Вопрос("Все");
КонецПроцедуры


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует