Вход | Регистрация


1С:Предприятие ::

Метки:

Отчет по военнообязанным в ЗиК

Я
   админ
 
11.11.04 - 09:57
проблема-нужно сделать отчет по военнобязанным в 1с:ЗиК, ну звание там, служил/не служил и т.д., начальница отдела кадров орет на меня-типа почему там такого нет...покопался, действительно-в справочнике сотрудники, в сведениях о сотруднике ничего такого не забивается (полей нет просто).что делать?как добавить эти поля и потом сделать по ним отчет?можт документ измененный у кого нить есть?
 
 
   GrayT
 
1 - 11.11.04 - 10:02
Да простят меня модераторы - но он сам адреса не оставил :(
//_____________________________________________________________________________

Процедура СписокВоеннообязанных()
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;

    |Сотрудник = Справочник.Сотрудники.ТекущийЭлемент;
    |Группировка Сотрудник Упорядочить по Сотрудник.Наименование без групп;
    
    |Условие(Сотрудник.ПометкаУдаления()=0);
    |//}}ЗАПРОС

    ; 
    
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
        Возврат;
    КонецЕсли; 
    ТабСотрудников =СоздатьОбъект("ТаблицаЗначений");
    Запрос.Выгрузить(ТабСотрудников,,0);

   //Возврат ТаблицаСотрудников

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");

    СЗ = СоздатьОбъект("СписокЗначений");
    СЗ.Установить("ВОИН_1_2","");   // звание

    СЗ.Установить("ВОИН_1_4","");   // ВУС

    СЗ.Установить("ВОИН_1_8","");   // Номер

    СЗ.Установить("ВОИН_1_5","");   // годность


    Таб.ВывестиСекцию("Заголовок");
    Таб.ВывестиСекцию("Шапка");
   //Таб.ПрисоединитьСекцию("Шапка|ФИО");

   //Таб.ПрисоединитьСекцию("Шапка|ДатаРождения");

   //Таб.ПрисоединитьСекцию("Шапка|Адрес");

    
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0); 
    Ном=0;
    
    ТабСотрудников.ВыбратьСтроки();
    Пока ТабСотрудников.получитьСтроку()>0 Цикл
        Сотрудник = ТабСотрудников.Сотрудник;  
        Если ПустоеЗначение(Сотрудник.СостояниеФизЛица.Получить(ВыбКонПериода))=1 Тогда
            Продолжить;
        КонецЕсли;
        СЗ.Установить("ВОИН_1_2","");   // звание

        СЗ.Установить("ВОИН_1_4","");   // ВУС

         СЗ.Установить("ВОИН_1_8","");   // Номер

        СЗ.Установить("ВОИН_1_5","");
        глЗначенияИзСтроки(Сотрудник.ВоинскийУчет,        СЗ,"ВОИН");   // 6. Образование

        Адрес="";
        Ад="";
        Звание    = Сз.Получить("ВОИН_1_2"); 
        ВУС        = Сз.Получить("ВОИН_1_4"); 
        Номер    = Сз.Получить("ВОИН_1_8"); 
        Годность= Сз.Получить("ВОИН_1_5");
        Если (ПустаяСтрока(ВУС)     =1 ) и
             (ПустаяСтрока(Номер)   =1 ) и
             (ПустаяСтрока(Годность)=1 ) Тогда
            Продолжить;
        КонецЕсли;    
        
        ДатаРож=ДатаГод(Сотрудник.ДатаРождения);
        Адрес1=глПредставлениеАдреса(Сотрудник.АдресПрописка);
        ДлинаАдрес=СтрДлина(Адрес1);
        Н1=Найти(Адрес1,",");
        Если н1=0 тогда
               Адрес=Адрес1;
        Иначе
             ДлинаВ=СтрДлина(Лев(Адрес1,н1));
             А=Прав(Адрес1,ДлинаАдрес-ДлинаВ);
             ДлинаА=СтрДлина(А);
             Н2=Найти(А,",");   
             в=Прав(Адрес1,(ДлинаАдрес-Н2-н1));
             Дв=Найти(В,",");
             
             Адрес=Лев(Адрес1,Н2+н1+ДВ);
             Ад=Прав(Адрес1,(ДлинаАдрес-Н2-н1-ДВ));
        КонецЕсли;     
        ном=ном+1;
        Таб.ВывестиСекцию("Сотрудник");
       //Таб.ПрисоединитьСекцию("Сотрудник|ФИО");

       //Таб.ПрисоединитьСекцию("Сотрудник|ДатаРождения");

       //Таб.ПрисоединитьСекцию("Сотрудник|Адрес");

    КонецЦикла;                        
    Таб.ВывестиСекцию("Подвал");
   // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры//СписокВоеннообязанных
   Marinka
 
2 - 11.11.04 - 10:04
(1) Оперативно... надеюсь, что модераторы это оценят :)
   админ
 
3 - 11.11.04 - 10:06
адрес вот
в программировании-ноль((
листинг какого документа это?
отчета уже, судя по всему?
но по каким полям будет идити выборка, если полей таких в данных о сотруднике нет?
   Ninon
 
4 - 11.11.04 - 10:06
(2)Ну, что ты Мариш - главное форумчане оценят :))
   GrayT
 
5 - 11.11.04 - 10:08
3 - Все сведения зашиты в Сотридник.ВоинскийУчет
   админ
 
6 - 11.11.04 - 10:15
запустил конфигуратор, выбрал новый отчет, скопировал листинг, при синт котроле ошибка
Если ПустоеЗначение(Сотрудник.СостояниеФизЛица.Получить(ВыбКонПериода))=1 Тогда
переменная не определена ВыбКонПериода
   PHelen
 
7 - 11.11.04 - 10:17
Интересно, а ваш ОК карточку Т-2 ведет по сотрам в 1С, или они её на бумажке карандашиком заполняют ? Там все есть, нехватает только выборки. Кстати,(1) большое спасибо за обработочку.
   админ
 
8 - 11.11.04 - 10:18
гм...еще-покопался в конфигураторе, да, действительно, в агрегатном справочнике сотрудник есть справочник воинский учет...а как в него данные вбивать??
   GrayT
 
9 - 11.11.04 - 10:23
(8)Гы. Ты еще в почтовом ящике покопайся, еще много чего найдешь :)))
   PHelen
 
10 - 11.11.04 - 10:24
Ещё раз. На каждого сотра д.б. заполнена (кстати отделом кадров) карточка Т-2, а если он научный сотр, то и Т-4. Смотри ВВод данных. Там всё заполняешь и оттуда все берёшь.
 
  Рекламное место пустует
   админ
 
11 - 11.11.04 - 10:24
хе)
   админ
 
12 - 11.11.04 - 10:28
оно там пишет-переменная не определена выб нач пер
   админ
 
13 - 11.11.04 - 10:30
2PHelen
ЗиК стандартная, но что то карточки Т2 не найду
в меню документы такого нет
   GrayT
 
14 - 11.11.04 - 10:37
(12)ВыбНачПер - реквизит формы. Ты письмо получил. А про Т2 - релиз ЗиКа какой?
   админ
 
15 - 11.11.04 - 10:44
релиз 7.70.247
ВыбНачПер - реквизит формы-не понял?)это протокол такой?)
просто тупо не вижу в карточке сотрудника поля, в который можно было бы вбивать данные о советской армии))
   GrayT
 
16 - 11.11.04 - 10:50
Мама, роди меня обратно.
Открываешь справочник сотрудников, открываешь сотрудника, жмешь на капу "ВводДанных" первым в списке Т2, вкуриваешь
Детский сад.
   Черт
 
17 - 11.11.04 - 10:56
Спокойнее GrayT, спокойнее, чел может первый раз конфигуратор открыл,
   Ninon
 
18 - 11.11.04 - 10:57
(6)Тебе ж дали листинг модуля - в доке ты сам уж теперь пропиши выбор периода.
Кстати, спасибо Грею..
   Ninon
 
19 - 11.11.04 - 10:59
(18)+ пока твои кадровички вбивают ланные в Т2 - тут и "твой" отчетик подоспеет, начинай шагать .. ;))
   админ
 
20 - 11.11.04 - 11:06
?*%?;:%*?:*?(:*(?:*(
уроооодыыыыы....
в Т2 пустые все эти графы, соответсвенно и отчеты у меня пустые вылезали((((((
ткнул носом (как меня только что), начальницу ОК, были сначала страшные потерянные глаза, так что я даже прижался к дверце сейфа (это смешно, кстать. было-100 двухметровых кг, грусна прячущихся))))-фигли, ей теперь 1100 человек перелопачивать!, а потом....потом начались вопли-мля, да почему я раньше етого не видела...короче, весело)))
народ, простите за тупость-простоя ж админ, ну ам tcp/ip, active directory, dhcp  и прочие клевые и хорошие вещи...1с-зло, которому мне нужно овладеть...жостка и напористо...читаю самоучитель)))))пожелайте удачи админу
   GrayT
 
21 - 11.11.04 - 11:10
"Ну ты это, заходи если что" (с) (Жил-был пес) А мы у тебя про TCP будем спрашивать
-У тебя TCP/IP сотит?
-Стоит, но как ты его назвал!
Удачи ;)

ЗЫ:Может лучше было ее к сейфу прижать?
   Ninon
 
22 - 11.11.04 - 11:15
(20)Когда ко мне подходит ЗамДира по кадрам и возмущается: "Почему этого нет!?, надо купить другую программу!", я говорю ему: из компа можно вытащить только из того, что туда ручками ввели - Ваши кадровики это сделали? :))
   админ
 
23 - 11.11.04 - 12:07
2GrayT
заходить буду



Список тем форума
  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует