Вход | Регистрация


Информационные технологии ::

Метки:

Как помогите написать обработку

Я
   Валентина
 
11.02.04 - 18:59
Уважаемые Гуру помогите. Мне нужно из таблицы ДБФ перенести справочник Контрагенты и Расчетные счета в 1С торговлю. Я новичек и у меня ничего не получается.(((
 
 
   skunk
 
1 - 11.02.04 - 19:01
а точнее если не трудно
   Рупор абсурда
 
2 - 11.02.04 - 19:06
Слово "новичок" пишется с буквой "о" ...
   Валентина
 
3 - 11.02.04 - 19:06
Есть старая программа, в ней справочник в виде ДБФ, по яцейкам как положено разбиты все данные, а мне нужно перенести его в 1С и все сохранить.
   Валентина
 
4 - 11.02.04 - 19:07
Рупор абсурда, спасибо за подсказку. Буду относиться внимательней.
   ally
 
5 - 11.02.04 - 19:07
ща он про яцейки завернет.....
   Рупор абсурда
 
6 - 11.02.04 - 19:08
Слово "ячейка" с буквой "ц" выглядит неприлично ...
   Рупор абсурда
 
7 - 11.02.04 - 19:09
(5) Телепатка?
   Рупор абсурда
 
8 - 11.02.04 - 19:10
Валентина, ты что-нибудь делала уже?
   Валентина
 
9 - 11.02.04 - 19:10
Может кто поможет?
   Валентина
 
10 - 11.02.04 - 19:12
Так по мелочам.
 
  Рекламное место пустует
   Рупор абсурда
 
11 - 11.02.04 - 19:15
(10) Т.е. тебе с самого начала объяснять надо?
   Валентина
 
12 - 11.02.04 - 19:19
Ну, ни совсем. У меня самое сложное, это понять как загрузить расчетные счета и банк
   Рупор абсурда
 
13 - 11.02.04 - 19:27
(12) А _не_из_ДБФ_ ты это делать умеешь?
   Валентина
 
14 - 11.02.04 - 19:30
нет. не умею. Я только что попробоваля из дбф загрузить справочник, нименование загрузилось, а дальше нет.
   skunk
 
15 - 11.02.04 - 19:33
точно также как и все остальное
или там какая кака есть
   Рупор абсурда
 
16 - 11.02.04 - 19:33
(14) Код ты нам не покажешь, конечно ...
   Валентина
 
17 - 11.02.04 - 19:36
Утром, только я сечас дома, все на работе.
   Рупор абсурда
 
18 - 11.02.04 - 19:36
(17) На печи лежишь?
   Валентина
 
19 - 11.02.04 - 19:40
Нет только что домой пришла, решила  спросить совет у народа, т.к. на рабте интернета нет. Сейчас буду книжки умные листать, как найти владельца

Ну обижать-то зачем? Я 1С-ом этим только месяц занимаюсь
   skunk
 
20 - 11.02.04 - 19:41
(18)вай вай опять хулиганишь
   Валентина
 
22 - 11.02.04 - 19:45
Да нет, просто сложно это все с самого начала методом научного тыка
   Шершень
 
23 - 11.02.04 - 19:45
(21) Рупор, да возьми девушку на буксир.
   Рупор абсурда
 
24 - 11.02.04 - 19:46
(20) Что ты, что ты? ... Я теперь исправляться начну ...
Мне сёдня ночью даже кошмарики снились ..., kos c Волшебником за мной всю ночь с челаутами наперевес гонялись ...
Не выспался нифига из-за них ... :((
   Валентина
 
25 - 11.02.04 - 19:47
Это из того что есть дома

//*******************************************
Процедура ОткрФайл()
   пФ="";
   пКат="";
   Если ФС.ВыбратьФайл(0,пФ,пКат,"Выберите dbf-файл с накладной:","dbf-файлы (*.dbf) |*.dbf","dbf")=1 Тогда
       //сообщить(""+пКат+пФ);
       пПуть=""+пКат+пФ;
   КонецЕсли;
КонецПроцедуры
//*******************************************
Процедура Сформировать()
   Если СокрЛП(пПуть)="" Тогда
       сообщить("Не выбран путь с именем файла!");
       статусвозврата(0);возврат;
   КонецЕсли;                    
   
   ДБФ=СоздатьОбъект("XBase");

   ДБФ.ДобавитьПоле("Name",2,30,0);

   ДБФ.ОткрытьФайл(""+СокрЛП(пПуть));
   
   СпрКонтр=СоздатьОбъект("Справочник.Контрагенты");
   
   сообщить("Начало згрузки справочника . . . ");
   Рупор абсурда
 
26 - 11.02.04 - 19:48
(23) А сам чего? Не знаешь "как загрузить расчетные счета и банк"?
   Шершень
 
27 - 11.02.04 - 19:49
(26) Лень.
   Таня
 
28 - 11.02.04 - 19:54
А вот бы и меня бы кто на буксир взял :)
   Рупор абсурда
 
29 - 11.02.04 - 19:55
(28) Так ты замужем, небось?
   Валентина
 
30 - 11.02.04 - 19:58
ЛЮЮЮЮДДДИИИ, мы здесь все не замужем, может все-таки к проклятым контрагентам вернемся
   Рупор абсурда
 
31 - 11.02.04 - 20:00
(30) Давай, вернёмся ...
Чё там в (25) не поместилось?
   Валентина
 
32 - 11.02.04 - 20:05
ДАльше на работе, то что дома выглядело так:
       Если ""+СокрЛП(ДБФ.NAME)<>"" Тогда
           пТов=Спр.ТекущийЭлемент();
       Спр.Наименование=""+СокрЛП(ДБФ.NAME);
       Спр.ПолнНаименование=""+СокрЛП(ДБФ.NAME);
           Иначе
               //не найден
           КонецЕсли;
       КонецЕсли;

Если все это правильно, тогда как згрузить все остальное
   skunk
 
33 - 11.02.04 - 20:11
надо

если спр.найтипонаименованию(СокрЛП(ДБФ.NAME)) = 0 тогда
не найден
иначе
найден
конецелси
 
  Рекламное место пустует
   Валентина
 
34 - 11.02.04 - 20:13
Спасибо, а как тут же подгузить расчетные счета и банки?
   skunk
 
35 - 11.02.04 - 20:30
Функция ЗагрузкаЭлемента(Кладр,Таб)
   КодСКА = Таб.CODE;
   КодРегиона = Лев(КодСКА,2);
   КодРайона  = Сред(КодСКА,3,3);
   КодГорода  = Сред(КодСКА,6,3);
   КодНП      = Сред(КодСКА,9,3);
   Если КодНП<>"000" Тогда
       Название = СокрЛП(Таб.NAME)+" "+СокрЛП(Таб.SOCR)+" #"+КодРегиона+КодРайона+КодГорода;
   ИначеЕсли КодГорода<>"000" Тогда
       Название = СокрЛП(Таб.NAME)+" "+СокрЛП(Таб.SOCR)+" #"+КодРегиона+КодРайона;
   ИначеЕсли КодРайона<>"000" Тогда
       Название = СокрЛП(Таб.NAME)+" "+СокрЛП(Таб.SOCR)+" #"+КодРегиона;
   Иначе
       Название = СокрЛП(Таб.NAME)+" "+СокрЛП(Таб.SOCR);
   КонецЕсли;
   Если Кладр.НайтиПоНаименованию(Название)=0 Тогда
       Кладр.Новый();
       Кладр.Код = КодСКА;
       Если (КодНП<>"000") Тогда
           Кладр.Регион = "4"+КодРегиона;
           Кладр.Район = "4"+КодРегиона+КодРайона;
           Кладр.Город = "4"+КодРегиона+КодРайона+КодГорода;
           Кладр.Уровень=4;
       ИначеЕсли (КодГорода<>"000") Тогда
           Кладр.Регион = "3"+КодРегиона;
           Кладр.Район  = "3"+КодРегиона+КодРайона;
           Кладр.Уровень=3;
       ИначеЕсли (КодРайона<>"000") Тогда
           Кладр.Регион = "2"+КодРегиона;
           Кладр.Уровень=2;
       ИначеЕсли (КодРегиона<>"00") Тогда
           Кладр.Уровень=1;
       КонецЕсли;
       Кладр.Наименование = Название;
       Кладр.Индекс = Таб.INDEX;
       Кладр.Записать();
       Возврат 1;
   КонецЕсли;
   Возврат 0;
КонецФункции // ЗагрузкаЭлемента()


самому лень писать, да и незнаю толком чего надо
попробуй может это поможет

(с) 1С:Налогоплательщик
   Валентина
 
36 - 11.02.04 - 20:54
Спасибо, попробую
   Валентина
 
37 - 12.02.04 - 08:09
даже близко не похоже, может кто более конкретно знает, как решить проблему?
   Рупор абсурда
 
38 - 12.02.04 - 11:33
(37) Все знают ..., только суть проблемы твоей уловить никто не может ...
Потому тебя и на буксир брать не хотят ...

Учись задавать вопросы!
   Валентина
 
39 - 12.02.04 - 16:11
Уважаемый Рупор, скажите как правильно задать вопрос и что вам из моего не понятно. Рябята, я правда погибаю!!!!!
   Рупор абсурда
 
40 - 12.02.04 - 16:39
   Валентина
 
41 - 12.02.04 - 18:45
А ты крутой мужик, Рупор.

Рисуй карту
   Рупор абсурда
 
42 - 12.02.04 - 18:48
(41) Чего я должен делать?
   Кое-кто@где-то.там
43 - 12.02.04 - 19:00
(0) Давай попорядку - что именно не получается на данном этапе?
   Рупор абсурда
 
44 - 12.02.04 - 19:02
(43) Диал-ап кончится ... :))
   Валентина
 
45 - 12.02.04 - 19:59
(42)Я пытаюсь загрузить контрагентов, но в этой же таблице нужно и расчетные счета и банки взять.

Т.е для контрагента такого-то нужно залить его расчетный счет и проверить есть ли такой банк и если нет, то загрузить или просто выбрать из списка. ((
   Рупор абсурда
 
46 - 12.02.04 - 20:23
(45) От тебя, в первую очередь, требуется описать тут структуру DBF, описать структуру нужных справочников или, если конфигурашка типовая, сказать какая ...



Список тем форума
 
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует