Вход | Регистрация

1С:Предприятие ::

Метки:

У меня опять с Владельцами проблемы. Помогите.

Я
   Таня
 
09.02.04 - 21:35
Спр =СоздатьОбъект("Справочник.Товары");
    ТовПрайса = СоздатьОбъект("Справочник.ТоварыВПрайсе");
    ТовПрайса.ИспользоватьВладельца(Прайс.ТекущийЭлемент());
    Пока rs.EOF() = 0 Цикл  
        Если (Спр.НайтиПоРеквизиту("сАртикул",rs.Fields("Артикул").Value,1) = 1) Тогда
            Сообщить(Спр.ТекущийЭлемент()); 
        Иначе
            Спр.Новый();
            Спр.Наименование = rs.Fields("Товар").Value;
            Спр.сПолнНаименование =  rs.Fields("Товар").Value;
            Если rs.Fields("Единица").Value = "" Тогда
                Спр.апТип=Перечисление.ТипТовара.Услуга ;
            ИначеЕсли rs.Fields("Единица").Value = "г"Тогда
                Спр.апТип=Перечисление.ТипТовара.Весовой;
            ИначеЕсли rs.Fields("Единица").Value = "шт." Тогда
                Спр.апТип=Перечисление.ТипТовара.Штучный;
            КонецЕсли;
            Спр.сАртикул =  rs.Fields("Артикул").Value;
            Спр.Записать();
            Сообщить("Создан новый "+Спр.ТекущийЭлемент());
        КонецЕсли;
        ТовПрайса.Новый();
        ТовПрайса.ИспользоватьВладельца(Прайс.ТекущийЭлемент());
        ТовПрайса.асТовар = Спр.ТекущийЭлемент();
        ТовПрайса.чЦена = rs.Fields("Цена").Value;
        ТовПрайса.асВалюта = rs.Fields("Val").Value;  
        ТовПрайса.Записать();
        rs.MoveNext();
КонецЦикла;

Сообщает об ошибке:
ТовПрайса.Записать();
Не выбран элемент справочника-хозяина! Элемент не может быть записан!
 
  Рекламное место пустует
   skunk
 
1 - 09.02.04 - 21:50
ТовПрайса.Новый(); 
ТовПрайса.ИспользоватьВладельца(Прайс.ТекущийЭлемент()); 
ТовПрайса.асТовар = Спр.ТекущийЭлемент(); 

ТовПрайса.Новый(); 
ТовПрайса.ИспользоватьВладельца(Спр.ТекущийЭлемент()); 

либо
ТовПрайса.Новый(); 
ТовПрайса.Владельц = Спр.ТекущийЭлемент(); 

и вверху
ТовПрайса.ИспользоватьВладельца(Прайс.ТекущийЭлемент());  - на фих
   Таня
 
2 - 09.02.04 - 21:50
Вопрос снят, оно испугалось чего-то и заработало само :)
   Таня
 
3 - 09.02.04 - 21:54
Не, ТоварыВПрайсе подчинен не Товару а Прайсу,
просто тот кто писал конфу, почему-то решил что должно быть два справочника товаров. в ТоварыВПрайсе они попадают методом подбора из Товаров, то есть потом существуют отдельно. Но набор товаров должен быть идентичным.
   skunk
 
4 - 09.02.04 - 22:08
ну немжко телепат не догнал, ведь у тебя там два создать объекта типа справочник, про прайс не фих не говорилось, извини.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует