Вход | Регистрация

1С:Предприятие ::

Метки:

DBF - срочно!!!

Я
   Kadr
09.02.04 - 12:00
Тут такой вопрос: при попытке записи в DBF выдает "Перед выполнением операции установите объект на запись". Как это сделать?
 
  Рекламное место пустует
   egor
 
1 - 09.02.04 - 12:12
Покажи модуль где записываешь
   kadr
2 - 09.02.04 - 12:15
Чего = СоздатьОбъект("XBase");//база по сотрудникам

    Куда = СоздатьОбъект("XBase");

    Сотр = СоздатьОбъект("Справочник.Сотрудники");   
    
    Чего.ОткрытьФайл("c:\job\adress.dbf");
    Куда.ОткрытьФайл("c:\job\import_a.dbf");
    Куда.Автосохранение(1);
    Куда.Очистить();
    Куда.Записать();
    Чего.Первая();
    Куда.Первая();
    Сотр.ВыбратьЭлементы();
    
    
    Пока Чего.ВКонце()=0 Цикл
        Если Сотр.НайтиПоНаименованию(Чего.name,0,1) = 1 Тогда
           //Куда.R_Country  = Сотр.Страна.Наименование;

       //    Куда.УстановитьЗначениеПоля(R_country,Сотр.Страна.Наименование);

            Стр = Сотр.АдресПрописка;
            Если Сред(Стр,1,1)="," Тогда
                Стр = Прав(Стр,СтрДлина(Стр)-1);
            КонецЕсли;
            Разделитель = ",";
            СЗ = СоздатьОбъект("СписокЗначений");
            ДлинаРазделителя = СтрДлина(Разделитель);
            Пока 1=1 Цикл
                Поз = Найти(Стр,Разделитель);
                Если Поз=0 Тогда
                    СЗ.ДобавитьЗначение(Стр);
                    Перейти ~м1;
                КонецЕсли;
                СЗ.ДобавитьЗначение(Лев(Стр,Поз-1));
                Стр = Сред(Стр,Поз+ДлинаРазделителя);
            КонецЦикла;
~м1:        Если СЗ.РазмерСписка()<>9 Тогда
                Сообщить (Сотр.Наименование);
            Иначе
                Куда.Записать();
                СЗ.ПолучитьЗначение(1,Куда.R_Index);
                СЗ.ПолучитьЗначение(2,Куда.R_District);
                СЗ.ПолучитьЗначение(3,Куда.R_Region); 
                СЗ.ПолучитьЗначение(4,Куда.R_City);
                СЗ.ПолучитьЗначение(5,Куда.R_Punkt);
                СЗ.ПолучитьЗначение(6,Куда.R_Street);
                СЗ.ПолучитьЗначение(7,Куда.R_House2);
                СЗ.ПолучитьЗначение(8,Куда.R_Korp);
                СЗ.ПолучитьЗначение(9,Куда.R_Flat);
            КонецЕсли;
        КонецЕсли;
        Куда.Следующая();
        Чего.Следующая();
    КонецЦикла;
   MaxMaster
 
3 - 09.02.04 - 12:30
Ребята, у меня есть поля:

    ДБФ=СоздатьОбъект("XBase");
    ДБФ.ДобавитьПоле("ROWID",1,11,0);     //не заполнятеся

    ДБФ.ДобавитьПоле("PAY_NUM",2,10,0);   //номер платежного поручения

    ДБФ.ДобавитьПоле("PAY_DATE",2,10,0);  //дата платжки

    ДБФ.ДобавитьПоле("PAY_SUMMA",1,20,4); //сумма платежки

    ДБФ.ДобавитьПоле("PAY_CMT",2,254,0);  //назначение платежа

    ДБФ.ДобавитьПоле("PAY_ORDER",2,1,0);  //порядок проведения платежа

    ДБФ.ДобавитьПоле("PAYER",2,75,0);     //название организации платежа

    ДБФ.ДобавитьПоле("PAYER_TID",2,12,0); //ИНН плательщика

    ДБФ.ДобавитьПоле("PAYER_BNK",2,75,0); //Название банка плательщика

    ДБФ.ДобавитьПоле("PAYER_MFO",2,9,0);  //БИК банка плательщика

    ДБФ.ДобавитьПоле("PAYER_KOR",2,25,0); //корсчет банка плательщика

    ДБФ.ДобавитьПоле("PAYER_CH",2,75,0);  //директор организации плательщика

    ДБФ.ДобавитьПоле("PAYER_GB",2,75,0);  //главный бухгалтер организации плательщика 

    ДБФ.ДобавитьПоле("PAYER_ACC",2,25,0); //счет плательщика

    ДБФ.ДобавитьПоле("REMITTEER",2,75,0); //Название организации получателя

    ДБФ.ДобавитьПоле("REMIT_TID",2,12,0); //ИНН получателя

    ДБФ.ДобавитьПоле("REMIT_BNK",2,75,0); //название банка получателя

    ДБФ.ДобавитьПоле("REMIT_KOR",2,25,0); //корсчет банка получателя

    ДБФ.ДобавитьПоле("REMIT_MFO",2,9,0);  //БИК банка получателя

    ДБФ.ДобавитьПоле("REMIT_ACC",2,25,0); //счет получателя

    ДБФ.ДобавитьПоле("RAY_PET",2,1,0);    //способ отправки

    ДБФ.ДобавитьПоле("RAY_DAY",2,10,0);   //срок платежа

    ДБФ.ДобавитьПоле("RAY_TYPE",2,2,0);   //всегда 1

    ДБФ.ДобавитьПоле("PAKAGE_DTE",2,19,0);//незаполняется

    ДБФ.ДобавитьПоле("BANK_DTE",2,19,0);  //незаполняется

    ДБФ.ДобавитьПоле("BANKKOP_DTE",2,19,0)//незаполняется 

    ДБФ.ДобавитьПоле("DOC_STATE",1,0,0);  //незаполняется

    ДБФ.ДобавитьПоле("PAYER_TID1",2,12,0);//КПП плательщика

    ДБФ.ДобавитьПоле("REMIT_TID1",2,12,0);//КПП получателя

    ДБФ.ДобавитьПоле("PAY_CLE_FI",2,100,0)//не заполняется
   egor
 
4 - 09.02.04 - 12:33
Дя начала Куда.Очистить()по моему нужно заменить Куда.ОчиститьФайл()
и Куда.Записать() установи после присвоения из списка значений

               СЗ.ПолучитьЗначение(1,Куда.R_Index); 
               СЗ.ПолучитьЗначение(2,Куда.R_District); 
               СЗ.ПолучитьЗначение(3,Куда.R_Region); 
               СЗ.ПолучитьЗначение(4,Куда.R_City); 
               СЗ.ПолучитьЗначение(5,Куда.R_Punkt); 
               СЗ.ПолучитьЗначение(6,Куда.R_Street); 
               СЗ.ПолучитьЗначение(7,Куда.R_House2); 
               СЗ.ПолучитьЗначение(8,Куда.R_Korp); 
               СЗ.ПолучитьЗначение(9,Куда.R_Flat);
               Куда.Записать();
   kadr
5 - 09.02.04 - 16:34
Надо было:
Куда.ДобавитьЗначение();
Куда.R_Index=СЗ.ПолучитьЗначение(1)
и т.д.
   Рупор абсурда
 
6 - 09.02.04 - 18:20
Ой, как тут весело было ...
Жаль я опоздал ... :((


Список тем форума
Рекламное место пустует  
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует