Вход | Регистрация

Информационные технологии ::

Метки:

работа метода "ВыбратьОперацииСПроводками с фильтром"

Я
   ViCon
 
03.02.04 - 11:44
кто знает как работает этот метод, замучался уже с ним
мне надо что бы делал выборку по счету к примеру 50 по дебету, и все счета по кредиту, для этого я пишу так
Опер.ВыбратьОперацииСПроводками(НачПериод, КонПериод, "211,*");
в результате у меня делается выборка по счету 50 и в дебете и в кредите... что неправильно я делаю, помогите.
 
  Рекламное место пустует
   ViCon
 
1 - 03.02.04 - 11:52
извините ошибся с указанием счета, но вопрос все равно в силе :)
пишу так
Опер.ВыбратьОперацииСПроводками(НачПериод, КонПериод, "50,*");
   345
2 - 03.02.04 - 12:26
ЖКК


А лучше бух запросом ....
   ViCon
 
3 - 03.02.04 - 12:33
345 я не спорю, может и лучше, но меня интересует как использовать этот метод.
   Дмитрий
4 - 03.02.04 - 14:29
Вроде правильно все. Может потому что 50 счет активный ?
   ViCon
 
5 - 03.02.04 - 15:06
Дмитрий только что попробовал, поставил в выборку пассивный счет, нет, все равно выбирает не только тот счет что я задал :(
   Дмитрий
6 - 03.02.04 - 16:52
Без понятия. Сам книгу поукпок так 100 раз делал, выбирал дебет 18 (в России вроде 19). Все работало.
   Дмитрий
7 - 03.02.04 - 16:53
Приведи текст от определения операции до цикла по проводкам
   ViCon
 
8 - 09.02.04 - 14:41
Дмитрий извини за задержку с ответом.

Опер=СоздатьОбъект("Операция");    
Если Материал.Выбран()=1 Тогда        
 Опер.ИспользоватьСубконто(ВидыСубконто.Материалы,     Материал);
КонецЕсли;
Если Склад.Выбран()=1 Тогда        
 Опер.ИспользоватьСубконто(ВидыСубконто.МестаХранения, Склад);
КонецЕсли;

Если Опер.ВыбратьОперацииСПроводками(НачПериод, КонПериод, "211,*")=0 Тогда        
  Предупреждение("Запрос не выполнен! Проводок нет.");
  Возврат;
КонецЕсли;

у нас другой план счетов, 211 это материалы.
   Дмитрий
 
9 - 09.02.04 - 15:25
(8) Мда... Единственное, что приходит в голову:
Метод ИспользоватьСубконто для операции возможно работает только если используется метод ВыбратьОперацииСПроводками с указание счета и корсчета (в твоем случае вариант с использованием фильтра)
Попробуй не отбирать по складу и материалу и посмотри, правильно ли перебирает. Может грабли в этом, а может и нет )
   ViCon
 
10 - 10.02.04 - 09:30
Пробовал, отключал отбор по складу и материалу.... результат все тот же, ладно, я уже обработал как тут посоветовали запросом :)
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует