Вход | Регистрация

1С:Предприятие ::

Метки:

Вопрос по ЗиК

Я
   Kadr
02.02.04 - 13:10
Че-то я туплю к концу смены...
Подскажите, как в отчете выбрать дату приема сотрудника?
 
 
   ally
 
1 - 02.02.04 - 14:09
Поэкспериментируй с реквизитом спр. сортудники "СостояниеФизлица"
   Kadr
2 - 03.02.04 - 10:55
Во я замочил! Правда еще сам толком не понял как работает, но работает...

    Если Список.РазмерСписка()>0 Тогда
        Если Вопрос("Перед заполнением список сотрудников будет очищен."
                    "Продолжить?","Да+Нет")="Нет" Тогда
            Возврат
        КонецЕсли;
    КонецЕсли;
    Список.УдалитьВсе();
    Сотрудники = СоздатьОбъект("Справочник.Сотрудники");
    Периодический = СоздатьОбъект("Периодический");
    ДатаПриема = Дата(0);
    ДатаУвольнения = Дата(0);
    ДатаАктуальности = ТекущаяДата();
    Сотрудники.ВыбратьЭлементы();
    Пока Сотрудники.ПолучитьЭлемент() = 1 Цикл
        Если Сотрудники.ЭтоГруппа()=0 Тогда
            Периодический.ИспользоватьОбъект("СостояниеФизлица",Сотрудники.ТекущийЭлемент());
            СостояниеФЗ = Периодический.ЗначениеНаДату(ДатаАктуальности);
            Если ПустоеЗначение(СостояниеФЗ)=0 Тогда
                Если Периодический.НайтиЗначение(ДатаАктуальности,-1)=1 Тогда
                    ДатаПриема = Периодический.ДатаЗнач
                КонецЕсли;
                Если Периодический.НайтиЗначение(ДатаАктуальности+1,1)=1 Тогда
                    ДатаУвольнения = Периодический.ДатаЗнач-1
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        Если (СостояниеФЗ<>Перечисление.СостояниеФизлица.ВременноНеРаботает) Тогда
            Если (ДатаПриема>=НачальнаяДата) И (ДатаПриема<=КонечнаяДата) Тогда
                Список.ДобавитьЗначение(Сотрудники.ТекущийЭлемент(),""+Сотрудники.ТекущийЭлемент().Наименование);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует