Вход | Регистрация

1С:Предприятие ::

Метки:

Как выбрать Цех

Я
   Platon
 
02.02.04 - 11:42
Может кто свежим взглядом глянет я уже не знаю что делать Как сделать так чтобы выбирался цех, такой вариант как у меня не работает где ошибка?
У меня N-е количество строк заполняет нулями а потом две строки находит и заполняет действительными данными а при выборе другого цеха всё точно также с темиже данными но только номер цеха другой.
     ТЗ=СоздатьОбъект("ТаблицаЗначений");    
    ТЗ.НоваяКолонка("Цех","Строка");                                //1

    ТЗ.НоваяКолонка("НомУч","Число");                              //2

    ТЗ.НоваяКолонка("Дт","Счет");                                 //3

    ТЗ.НоваяКолонка("СтРасх","Число");                             //4

    ТЗ.НоваяКолонка("Кт","Счет");                                 //5

    ТЗ.НоваяКолонка("Сум","Число");                                //6

    ТЗ.НоваяКолонка("СумОткл","Число");     
    ТЗ.УдалитьСтроки();
        
    Опер=СоздатьОбъект("Операция");
    Опер.ВыбратьОперацииСПроводками(ВыбНачПериода, ВыбКонПериода,"20.01.02,*;20.01.03,*;25.01.01,*;25.01.02,*;23.07.00,*;23.01.03,*;23.03.00,*;23.02.00,*;23.01.03,*;23.01.04,*;26.02.00,*;29.03.02,*;29.02.01,*;29.01.01,*;29.01.03,*;29.01.06,*;29.02.05,*");
    Если (Опер.Документ.Вид()="ТребованиеНакладная") Тогда 
   Пока Опер.ПолучитьОперацию()=1 Цикл
Состояние("Обрабатывается документ "+Опер.Документ); 
          Если ВыбЦех.Выбран()=1 Тогда
    ТЗ.НоваяСтрока();
            Номер=0;
            Номер=Номер+1; 
            
            Если ПустоеЗначение(Опер.Дебет.Субконто(2).Код)=1 Тогда
                ТЗ.УстановитьЗначение(Номер,1,Опер.Дебет.Субконто(2).Родитель);
            Иначе
                ТЗ.УстановитьЗначение(Номер,1,Опер.Дебет.Субконто(2).Код);
            КонецЕсли;
            ТЗ.УстановитьЗначение(Номер,3,Опер.Дебет.Счет);
            ТЗ.УстановитьЗначение(Номер,4,Опер.Дебет.Субконто(1).Код);
            ТЗ.УстановитьЗначение(Номер,5,Опер.Кредит.Счет);
            ТЗ.УстановитьЗначение(Номер,6,Опер.СуммаОперации);
 Если Опер.ПолучитьПроводкуПоНомеру(2)=0 Тогда
     Продолжить;
            ИначеЕсли Опер.Кредит.Счет=СчетПоКоду("16.09") Тогда
                ТЗ.УстановитьЗначение(Номер,7,Опер.Сумма);
            КонецЕсли;
    ТЗ.УстановитьЗначение(Номер,2,Сред(СокрЛП(Опер.Дебет.Субконто(1).Код),2,1));
    
          Иначе
    Продолжить;
КонецЕсли;
    КонецЦикла;
 КонецЕсли;
 
 


Список тем форума
 
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует