Вход | Регистрация

1С:Предприятие ::

Метки:

Как получить остатки по регистру остатков за выбранный месяц

Я
   Таня
 
01.02.04 - 20:29
Если я пишу РасчитатьРегистрыНа(ДатаКонца)
то оно суммирует остатки с предыдущим месяцем
Вобщем мне надо получить значения из регистра только с начала месяца до конца месяца. Помогите.
 
 
   Волшебник
 
1 - 01.02.04 - 20:35
ОСТАТКИ - это информация на МОМЕНТ.
Не бывает остатков за ПЕРИОД.
   sn
 
2 - 01.02.04 - 21:08
попробуй сделать это с помощью запроса по регистру
   Таня
 
3 - 01.02.04 - 21:26
Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с ДатаНачала по ДатаКонца;
    |Товар = Регистр.ПродажиТоваров.Товар;
    |Отдел = Регистр.ПродажиТоваров.Отдел;
    |Количество = Регистр.ПродажиТоваров.Количество;
    |СтоимостьПродажи = Регистр.ПродажиТоваров.Сумма;
    |Функция ИтогоКоличество = Сумма(Количество);
    |Функция ИтогоСумма = Сумма(СтоимостьПродажи); 
    |Группировка Отдел;
    |Группировка Товар;";
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
        Рег = СоздатьОбъект("Регистр.ТоварныйЗапас");
        РассчитатьРегистрыПо(ДатаКонца);
    
    Пока Запрос.Группировка(1) = 1 Цикл
        ПрибыльПоОтделу = Рег.СводныйОстаток(,Запрос.Отдел,"Стоимость");
        ИтогоСебестоимость = Запрос.ИтогоСумма-ПрибыльПоОтделу;
        Таб.ВывестиСекцию("Отдел");
        Пока Запрос.Группировка(2) = 1 Цикл 
            ПрибыльПоТовару = Рег.Остаток(Запрос.Товар,Запрос.Отдел,"Стоимость");
            СебестоимостьТовара = Запрос.СтоимостьПродажи - ПрибыльПоТовару;
            Таб.ВывестиСекцию("Товар");
        КонецЦикла;
    КонецЦикла;


Так вот, мне надо получить не остаток по регистру ТоварныйЗапас, а значение Стоимость по выбранному Товару.
и значение Всего по выбранному Отделу.
   sn
 
4 - 01.02.04 - 23:45
Я может немного торможу... (не понимаю вас)
но я имею ввиду следущее:
для того, чтобы получить так сказать движения по регистру за выбранный период (с определенной группировкой), можно в запросе использовать функцию Приход(Сумма) - это все движения "плюсом" или расход(Сумма) - соответственно минусом.
Если не устраивает запрос... то устанавлвайте фильтра на регистр и перебирайте движения... но это дольше...
или подождите...
может кто еще что-нибудь более умное посоветует
   T-34
5 - 02.02.04 - 08:59
Единственно здравая мысль здесь, так это в первом топике.
   Таня
 
6 - 02.02.04 - 09:33
Я прекрасно понимаю, что такое остатки, ну неправильно выразилась.
Я пробовала получить информацию из обоих регистров в одном запросе:
Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса = "
   |Период с ДатаНачала по ДатаКонца;
   |Товар = Регистр.ПродажиТоваров.Товар, Регистр.ТоварныйЗапас.Товар;
   |Отдел = Регистр.ПродажиТоваров.Отдел, Регистр.ТоварныйЗапас.Отдел;
   |Количество = Регистр.ПродажиТоваров.Количество;
   |СтоимостьПродажи = Регистр.ПродажиТоваров.Сумма;
   |себестоимость = Регистр.ТоварныйЗапас.Стоимость; 
   |Функция ИтогоКоличество = Сумма(Количество);
   |Функция ИтогоСумма = Сумма(СтоимостьПродажи);
|Функция ИтогоСебестоимость = Сумма(Себестоимость);
   |Группировка Отдел;
   |Группировка Товар;"; 

В результате получила 0 по значению Себестоимость.
   skunk
 
7 - 02.02.04 - 09:52
Тань ты просто скажи что ты хочешь получить. то бишь цель всего отчета в целом. так сказать простое ТЗ.
   Таня
 
8 - 02.02.04 - 19:34
Я хочу по тому же самому долбанному второму заданию по ТиС (извиняюсь, что грубо, просто меня от него уже тошнит), получить отчет, в котором бы отражалось следующее:
Количество проданного товара с разбивкой по отделам, Себестоимость (то есть закупочная цена) товара и всего по отделу, Стоимость продажи товара (выручка) и всего по отделу, Прибыль (всего по отделу и по каждому товару в отдельности)
У меня есть два регистра:
Товарный запас (остатков) и ПродажиТоваров (оборотов)
По ТоварныйЗапас отражается Товар, Отдел, Количество, Стоимость - все касаемо прихода от поставщика и соответственно продажа по себестоимость (по закупочным ценам)
По ПродажиТоваров отражается Товар, Отдел, Поставщик, Количество, Стоимость - все касаемо продажи по стоимости которую устанавливает магазин (можно считать что это себестоимость + комиссионный процент поставщика).

Я этот отчет сделала, только заранее знаю что использовала не то, что может потребоваться на экзамене. То есть информацию по ПродажиТоваров я получила через Запрос, а из ТоварныйЗапас не могу получить, поэтому я получила остаток по ТоварныйЗапас, который получается равен комиссионному вознаграждению поставщика, и эта же цифра как я думаю является прибылью. Так вот, я от Стоимости магазанной (то есть от выручки) отняла эту прибыль и получила себестоимость товара.
Один факт меня смущает: когда в следующем месяце я ввожу Товарный чек (документ которым отражается продажа товара), и в этом ТовЧеке я продаю товар из другого отдела, не из того, из которого продавала в прошлом месяце, то он все считает не правильно, то есть прибавляет остаток по регистру к прибыли.
   skunk
 
9 - 02.02.04 - 19:41
Сдается мне тут не отчет смотреть надо. Кинь на мыло md свой.  skunk_ собака mail.ru
   Таня
 
10 - 02.02.04 - 20:24
Отправила
 
  Рекламное место пустует
   skunk
 
11 - 02.02.04 - 20:44
Тань у меня внизу прочерк в мыле "skunk_"

а то у мене ящик пуст, проверь плиз.
   Таня
 
12 - 02.02.04 - 21:23
Снова отправила :)
   skunk
 
13 - 02.02.04 - 21:29
(12)Все получил, ответ мылом кину
   skunk
 
14 - 03.02.04 - 05:30
(12)посмотри ящик, .... ну вобщем все там


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует