Вход | Регистрация

1С:Предприятие ::

Метки:

Проблема с выборкой документов

Я
   Arhitektor
 
26.01.04 - 14:21
Пишу следующим образом:
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы(выбНачДата, выбКонДата);
    
Пока Док.ПолучитьДокумент() = 1 Цикл 
ТекДок = Док.ТекущийДокумент();
Если ТекДок.Вид() = "ЗаявкаПокупателя" Тогда
Если (выбСклад = ТекДок.Склад) и (выбФирма = ТекДок.Фирма) Тогда
Если ТекДок.ВыбратьПодчиненныеДокументы(,,ТекДок) = 0 Тогда
    Таб.ВывестиСекцию("Док");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

В базе туева хуча документов, но цикл не работает!!! Смотрел в отладчике - условие Док.ПолучитьДокумент()=0, хотя Док указывает на первый документ!!!
В чем может быть проблема?
 
 
   Львенок
 
1 - 26.01.04 - 14:29
Попробуй для начала Док.ВыбратьДокументы() вот так в чистом виде без параметров.
___
Исекренне Ваш, Львенок.
   Arhitektor
 
2 - 26.01.04 - 14:32
Все равно не работает - уже пробовал
   skunk
 
3 - 26.01.04 - 14:36
ну знаешь едиственное что приходит на ум так это плюх с датой, скорее всего выбНачДата > выбКонДата
   Arhitektor
 
4 - 26.01.04 - 14:38
Самое ужасное, что дату ставлю сам!
выбНачДата='01.01.2004'
выбКонДата='26.01.2004'

??????????????????????????????????
   Arhitektor
 
5 - 26.01.04 - 14:49
Вроде все получилось, но почему, так и не понял...
   may
6 - 26.01.04 - 17:11
Создай еще один объект документ общего вида и попробуй вот так:
Если ДокЕщеОдин.ВыбратьПодчиненныеДокументы(,,ТекДок) = 0 Тогда 
   Таб.ВывестиСекцию("Док"); 
КонецЕсли;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует