Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки:

как получить следующий день от даты?

Ø
Я
   oooaaa
04.07.05 - 17:10
сорри что туплю!
10
13
13
13
17
 
 
   Div0
1 - 04.07.05 - 17:12
Дата(Число(ТвояДата)+1), чтобы наверняка
   Денис2
2 - 04.07.05 - 17:13
мояДата+1...
   Fram
3 - 04.07.05 - 17:13
ВыбДата+1 )))
   Poplavok
4 - 04.07.05 - 17:13
+1
   qwertyadmin
5 - 04.07.05 - 17:13
+1
   Чучундер
6 - 04.07.05 - 17:14
По определению - следующий день от даты это есть +1.
Что тебе нужно:
- след.дата?
- след порядковый номер дня года?
- след номер дня недели?
- след наименование дня недели?
...
?????
Действительно - и вопрос тупой и сам тупишь ;-)
Пожалей техх, кто будет пытаться понять что ты имел ввиду - ато будут иметь ввиду тебя с твоими вопросами...
   Ненавижу 1С
7 - 04.07.05 - 17:14
1 решение. Результат = ТвояДата+1
2 решение.
Флаг=0;
Для инд=НачМесяца(ТвояДата) По КонМесяца(ТвояДата) Цикл
 Если Флаг=1 Тогда Прервать; КонецЕсли;
 Если инд=ТвояДата Тогда Флаг=1; КонецЕсли;
КонецЦикла;
Результат = инд;
   aqua80
8 - 04.07.05 - 17:14
4 и 5, Присоединяюсь :-)
   oooaaa
9 - 04.07.05 - 17:16
спасибо всем, но мне больше нравится решение +1 )))))
   КонецЦикла
10 - 04.07.05 - 17:18
2(0) А вдруг рабочий день? Что-то об этом никто не подумал :)
Тогда юзай календарь - ПолучитьДату()
 
 
   Ненавижу 1С
11 - 04.07.05 - 17:18
+7 второе решение не работает, когда дата=конец месяца, будем думать. основная идея, неиспользовать явные операции с датой +и -.
15
   Poplavok
12 - 04.07.05 - 17:18
самая прикольная ветка за сегодня :))))))))))))
   qwertyadmin
13 - 04.07.05 - 17:30
СдвигДаты=1; // Обязательно положительное
сДата=Формат(дДата,"ДДДММГГГГ"); // ДД.ММ.ГГГГ
сДень=Сред(сДата,1,2);
сМесяц=Сред(сДата,4,2);
сГод=Сред(сДата,7,4);
чДень=Число(сДень);
чМесяц=Число(сМесяц);
чГод=Число(сГод);
Для й=1 По СдвигДаты Цикл
  чДень=чДень+1;
  Если чМесяц=1 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=2 Тогда
    чДеньМакс=28;
  ИначеЕсли чМесяц=3 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=4 Тогда
    чДеньМакс=30;
  ИначеЕсли чМесяц=5 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=6 Тогда
    чДеньМакс=30;
  ИначеЕсли чМесяц=7 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=8 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=9 Тогда
    чДеньМакс=30;
  ИначеЕсли чМесяц=10 Тогда
    чДеньМакс=31;
  ИначеЕсли чМесяц=11 Тогда
    чДеньМакс=30;
  ИначеЕсли чМесяц=12 Тогда
    чДеньМакс=31;
  КонецЕсли;
  чМесяцМакс=12;
  Если чДень>чДеньМакс Тогда
    чДень=1;
    чМесяц=чМесяц+1;
    Если чМесяц>чМесяцМакс Тогда
      чМесяц=1;
      чГод=чГод+1;
    КонецЕсли;
  КонецЕсли;
КонецЦикла;
сДата=Формат(чДень,"Ч(0)2.0")+"."+Формат(чМесяц,"Ч(0)2.0")+"."+Формат(чГод,"Ч(0)4.0");
дДата=Дата(сДата);
18
   Чучундер
14 - 04.07.05 - 17:33
Бездатый вопрос!
Кандидат, однако!
   Денис2
15 - 04.07.05 - 17:35
(11)
дт = '30.04.2005';
сообщить(""+дт+"   "+(дт+1));
проверь.
16
   Ненавижу 1С
16 - 04.07.05 - 17:38
(15) Это ты к чему?
   cathode
17 - 04.07.05 - 17:39
А может, (0) - по V8 вопрос? :)
   Макс 1С
18 - 04.07.05 - 17:43
клёво....
в (13) вообще супер!!!!
тут рядом про крассивый код рассуждают.... это туда


 
Список тем форума

Форум Территория 1С


 
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.