Вход | Регистрация


1С:Предприятие ::

Метки:

Пишем новую конфигурацию склад - Начинающий

Я
   Владислав
22.01.04 - 09:33
Здравствуйте. Я начинающий. Хочу реализовать розничную торговлю. Есть справочник номенклатура.
С одним кодом много товаров, но у них разные размеры.
Реализовать надо печать ценников, учет остатков и проданых товаров именно по размерам.
Просьба не ругать, хочу написать от начала и до конца сам, для себя. С Уважением.
 
 
   Львенок
 
1 - 22.01.04 - 09:38
Тогда стоит начать с того, что почитать как это устроено с наружи (с точки зрения пользователя) в типовой ТиС, а потом поглядеть как оно устроено внутри там же. Для этого нужно иметь ТиС и книжки (необязательно ЖКК). Из книжек по ТиС с точки зрения пользователя мне понравилась книжка Н. Рязанцево и Д. Рязанцева 1С:Предприятие. Торговля и склад. Секреты работы.
Такой подход позволит избежать многих ошибок и позволит сообразить, с чего же начать.
___
Искренне Ваш, Львенок.
   Владислав
2 - 22.01.04 - 11:05
Спасибо. Пойду искать книгу.
   Владислав
3 - 22.01.04 - 18:33
справочник товары и подчиненный спр.размеры.
как сделать печать ценников если у товара1 - размеры 1,2,3,4 у товара2 - 1,2,3,4,5. Если размеров 5 значит количество товара =5шт. Если поймете вопрос - прошу помочь. Спасибо.
   skunk
 
4 - 22.01.04 - 18:40
Оригинально, это в книге так написано или просто ее не нашел. Владислав а может как нить по русский получиться. Тип у меня есть ложка и поворежка, если я сейчас возьму ложку - то пойду и стукну жену по лбу, если поворежку то сосдку по пятой точке.
   Владислав
5 - 22.01.04 - 18:47
Да книгу не нашел это правда. Сам запутался напрочь.
Попробую еще раз. Надо распечатать ценники или прайс в которых вместо количества (шт) должно быть количество взятое из справочника размеры. Если размеров 10 то и товаров 10. Может так понятней. С Уважением.
   skunk
 
6 - 22.01.04 - 18:55
а как у тебя товар связан с размером
   Владислав
7 - 22.01.04 - 18:56
Справочник товар. Подчиненный справочник размер.
   skunk
 
8 - 22.01.04 - 19:03
Тогда типа того
СпрРазмер = СоздатьОбъект("Справочник.Размер");
СпрРазмер.ИспользоватьВладельца(Товар);
СпрРазмер.ВыбратьЭлементы();
Пока СпрРазмер.ПолучитьЭлемент() > 0 Цикл
  если СпрРазмер.РеквизитРазмера > Размер.РеквизитРазмера тогда
     Размер = СпрРазмер.ТекущийЭлемент();
КонецЦикла

Печать
Товар - Размер;
   WhiteCat
 
9 - 22.01.04 - 19:05
А что, цены на товары разного размера разные?
   Владислав
10 - 22.01.04 - 19:05
Спасибо пробую.
 
  Рекламное место пустует
   Владислав
11 - 22.01.04 - 19:07
WhiteCat -
Нет цены одинаковые но нужно на каждый товар свой ценик состряпать. Ну и позже учет вести какой размер ушел а какой остался.
   WhiteCat
 
12 - 22.01.04 - 19:12
Ну, это несложно, измерение только добавить нужно в регистр остатков
   skunk
 
13 - 22.01.04 - 19:18
(12)Измерения так просто добавлять не есть гуд, могут быть каки
   WhiteCat
 
14 - 22.01.04 - 19:26
(13) Верно, но я же не говорю, что нужно тупо добавить - и все. Я про то, что если бы еще и с ценами парится пришлось - то ваще попец полный был бы. А так - только с размерами
   Владислав
15 - 22.01.04 - 19:28
skunk - WhiteCat
А Вы не хотите продолжить развивать мысль?
   WhiteCat
 
16 - 22.01.04 - 19:33
А ты подкинь дровишек - вопросик какой-нить
   Владислав
17 - 22.01.04 - 19:38
Да я еще с печатью пока не разобрался.
А с измерением это неплохо. Думаю надо будет попробовать.
Но это позже. Я потом с Вашего позволения спрошу.
   skunk
 
18 - 22.01.04 - 19:38
Насколько я понимаю идет дороботка стандартной конфы, а там кучу всего править придеться, если в регистр, что ткунть.
   Владислав
19 - 22.01.04 - 19:40
Не не идет разработка новой конфигурации. Для себя под себя  что бы лишнего ничего и что бы удобно. Учусь и Вас достаю.
   skunk
 
20 - 22.01.04 - 19:43
Удачи! ;)

Как пар еще не валит. Звони, если, что. Одну конфу писать, подвиг достойны уважения. Конечно если конфа не предназначена для цветочного ларька.
   Владислав
21 - 22.01.04 - 19:48
Спасибо. Позвоню. Не для ларька
   WhiteCat
 
22 - 22.01.04 - 19:51
(20) Смотря какая конфа. Если только учет остатков - дня за 2-3 можно сделать. А djn если с прибабахами - то и несколько недель сидеть можно
   skunk
 
23 - 22.01.04 - 19:56
Ну ребетишки по нескольку лет трудяться и не потееют.
Хотя человек с одной стороны прав, нет более не благодарнее работы, чем убирать чужие каки.
   Владислав
24 - 22.01.04 - 19:56
Для начала приход,учет оформление ценников и т.п а дальше и еще что нибудь прицепить можно. Я не так давно с 1С знаком, но процес оказался интересным. Тем более приятно когда что-то сам пытаешься сделать.Да и поиск программ такого рода ничем хорошим никогда не заканчивался. То сильно круто то сильно тупо.
   Владислав
25 - 22.01.04 - 19:59
Вы главное не забывайте про меня. Подкидывайте свои советы. Любые. Очень интересно будет посмотреть.Я же всетаки новичок в этом.
С Уважением.
   WhiteCat
 
26 - 22.01.04 - 20:08
(23) Знакомо, сам обнажды попал на фирму, с которой все отказывались работать, настолько много там было дерьма в конфе ихней (там до сих пор существует такое понятие как "говнокод"). Разгребал все 9 месяцев, пока не уволился. На мое место троих взяли, только недавно что-то реально заработало
(25) Для этого форум и существует
   Владислав
27 - 24.01.04 - 18:24
Привет всем. Вы были правы пар повалил конкретно. из за
этих размеров. Запутался напрочь снес все. Есть какие либо предложения по поводу реализации одежды с учетом размеров. кто нибудь может в курсе. Я уже и не знаю как вопрос поставить. Просто нужно реализовать учет товаров на складе с учетом разных размеров одежды. продано размер 1, остался на складе товар с размером2,3 и т.п.
   skunk
 
28 - 24.01.04 - 18:33
В твоем случае, читай (12).

В доках прихода/расхода добавляешь колонку размер. в модуле проведения там где движение регистров пишешь остаток.размер = количество;

вроде увсе.
   WhiteCat
 
29 - 24.01.04 - 21:21
(28) Я в качестве измерения из (12) сделал не число, а справочник "Подвиды", подчиненный ТМЦ. В этом случае можно учитывать как по размерам, так и по цветам или еще каким-нить классам
   Alexandr
 
30 - 24.01.04 - 22:57
Для начала скачай на сайте пример небольшой торговой единицы. Ссылка http://www.mista.ru/tutor_1c/example_konkurent.htm
Пользоваться не сможешь- защищено хэшкодом, но поколупаться стоит. Есть хорошие идеи.
   skunk
 
31 - 25.01.04 - 01:56
в (28) есть небольшой опечатка "остаток.размер = количество" следует заменить "остаток.размер = размер"

(29)Полностью согласен.
   skunk
 
32 - 25.01.04 - 09:36
(30)Да. Недумал даже, что такой мощной защитой как слово стрХэшКод можно облать кого-то.
   Владислав
33 - 25.01.04 - 19:32
"Движения регистра не могут выпаолняться у данного объекта" ?????????????????????????????????
Это что за объект. Все перепроверил. Обыкновенный приход
товара на склад и такой косяк, где искать может встречалось?
 
  Рекламное место пустует
   skunk
 
34 - 25.01.04 - 19:39
В документе галочку надо поставить "Оперативный учет"
   Владислав
35 - 25.01.04 - 19:43
skunk Спасибо огромное.
Как не заметил.
   skunk
 
36 - 25.01.04 - 20:24
наше вам, самое главное не стань специалистом.
   vladK
37 - 03.02.04 - 15:45
Здравствуйте. Почти закончил с учетом и уперся как баран. Выручайте. Все о том-же кто в курсе:

Где ошибка не печатает ценники с несколькими размерами.
Выдает один ценник и список размеров.(Все в одном)


Процедура ПечатьЦенника()
        Перем Таб;
    Перем ЧислоСтрок;
    Перем Столбик;
    Перем Ряд;
    Таб=СоздатьОбъект(\\\"Таблица\\\");
    Таб.ИсходнаяТаблица(\\\"Ценник\\\");
     ЧислоСтрок=0;
     Столбик=1;
     Ряд=0;
      СпрРазмер =СоздатьОбъект (\\\"Справочник.Размер\\\"); 
СпрРазмер.ИспользоватьВладельца(Товар); 
СпрРазмер.ВыбратьЭлементы(); 
Пока СпрРазмер.ПолучитьЭлемент() > 0 Цикл 
 если СпрРазмер.РеквизитРазмера > Размеры.РеквизитРазмера тогда 
    Размер = СпрРазмер.ТекущийЭлемент(); 
КонецЦикла; 
         
             Столбик=?(Столбик=0,1,0);
             Ряд=?(Столбик=0,Ряд+1,Ряд);
            Если Ряд>5 Тогда
                Таб.НоваяСтраница();
                Ряд=1;
            
            КонецЕсли;
             Если Столбик=0 Тогда
                Таб.ВывестиСекцию(\\\"Товар|Ценник\\\");
            Иначе
                Таб.ПрисоединитьСекцию(\\\"Товар|Ценник\\\");
            КонецЕсли;
                        КонецЦикла;
        Таб.ТолькоПросмотр(1);
        Таб.Показать(\\\"\\\");
    КонецПроцедуры
   skunk
 
38 - 03.02.04 - 17:02
вывод ценника надо внутрь цикла затолкнуть, а не после

то есть чего в этом роде

Процедура ПечатьЦенников(ТекДок, Стр, Кол, Тип = 1);
    СпрЦена = СоздатьОбъект("Справочник.Цены");
    Отчет = СоздатьОбъект("Таблица");
    Отчет.ИсходнаяТаблица("Ценник");
    ТекДок.ВыбратьСтроки();
    Фирма = ТекДок.Фирма;
    Секция = Стр + "|" + Кол;
    Пока ТекДок.ПолучитьСтроку() > 0 Цикл
        Что = ТекДок.Номенклатура;
        ПечКод = Строка(Что.Код);
        Товар = Что.ПолнНаименование;
        ЕдИзм = Что.ОсновнаяЕдиница.ОКЕИ.ПолнНаименование;
        СпрЦена.ИспользоватьВладельца(Что);
        СпрЦена.ИспользоватьДату(РабочаяДата());
        СпрЦена.НайтиПоКоду(2);
        ПечЦена = Строка(Цел(СпрЦена.Цена)) + " руб. " + Строка((СпрЦена.Цена - Цел(СпрЦена.Цена)) * 100) + " коп.";
        СтИзг = Строка(Что.СтранаПроисхождения);
        Номер = ТекДок.НомерСтроки;
        Если (Номер / 2) = Цел(Номер / 2) Тогда
            Отчет.ПрисоединитьСекцию(Секция);
        Иначе
            Отчет.ВывестиСекцию(Секция);
        КонецЕсли;
        Если Тип = 1 Тогда
            Если (Номер / 8) = Цел(Номер / 8) Тогда
                Отчет.НоваяСтраница();
            КонецЕсли;
        КонецЕсли;
        Если Тип = 2 Тогда
            Если (Номер / 12) = Цел(Номер / 12) Тогда
                Отчет.НоваяСтраница();
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    Отчет.Опции(0, 0, 0, 0, "", "Ценник", 0, 1);
    Отчет.Показать("Ценник", "");
КонецПроцедуры



Список тем форума
Рекламное место пустует  
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует