Вход | Регистрация

1С:Предприятие ::

Метки:

ТаблицаЗначений.Свернуть

Я
   NataVVV
20.01.04 - 14:09
Проблема такая. ТаблицаЗначений переменным количеством колонок.n-число колонок -\"строка\",n-число колонок число. ТаблицаЗначений надо свернуть по строковым колонкам с суммированием по числовым. Кто пробовал свертывать через переменные.
 
  Рекламное место пустует
   gr13
 
1 - 20.01.04 - 14:13
ТаблицаРеализации.Свернуть("ВидНоменклатуры, СтавкаНДС, СтавкаНП, СтавкаНР","Всего, НП, НР");

Подробнее объясни как понять через переменные?
   klon
 
2 - 20.01.04 - 14:26
СворачиваемыеСтроки = "ОбДт, ОбКт";
Для НомерКварт = 1 По КолКварт Цикл
    СворачиваемыеСтроки = СворачиваемыеСтроки+", ПоступлЗаКвартал"+Строка(НомерКварт);
    СворачиваемыеСтроки = СворачиваемыеСтроки+", КомиссЗаКвартал"+Строка(НомерКварт);
КонецЦикла;
ТЗ.Свернуть("Контрагент, Договор, Валюта",СворачиваемыеСтроки);
   NataVVV
3 - 21.01.04 - 12:55
ТабЗн.НоваяКолонка("","Строка",100,,"Материал",30);
ТабЗн.НоваяКолонка("","Строка",10,,"ЕдИзм",10);
Для Ном=1 по Конец Цикл
ТабЗн.НоваяКолонка("","Число",10,,"Тип",10);
ТабЗн.НоваяКолонка("","Число",10,,"СвТип",10);
КонецЦикла;
ТабЗн.Свернуть("1,2","а как тут быть");
// Это поянение к проблеме
   Львенок
 
4 - 21.01.04 - 14:56
Если я правильно понял условие (1) с учетом дополнения (3), то впринципе заранее известно и число колонок для групиировки k (причем они идут в начале) и число колонок для суммирования n. В конкретном примере k=2, n=Конец. Предположим немного более общий случай - k (число колонок группировки) известно и все эти колонки идут в начале, все колонки после них подлежат свертыванию. Тогда

k=...; //Известно заранее
СтрГрупп=""; СтрСумм="";
Колонок=ТЗ.КоличествоКолонок();
Для i=1 По Колонок Цикл
   Если i>k Тогда//Пошли колонки для суммирования

      СтрСумм=СтрСумм+i+",";
   Иначе//Колонки для группировки

      СтрГрупп=СтрГрупп+i+",";
   КонецЕсли;
КонецЦикла;
СтрСумм=Лев(СтрСумм,СтрДлина(СтрСумм)-1);//Обрезаем лишьнюю запятую

СтрГрупп=Лев(СтрГрупп,СтрДлина(СтрГрупп)-1);//Обрезаем лишьнюю запятую

ТЗ.Свернуть(СтрГрупп,СтрСумм);

P.S.: Пример писал прямо здесь в окошке браузера и не проверял в конфигураторе.
___
Искренне Ваш, Львенок.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует