Вход | Регистрация

1С:Предприятие ::

Метки:

1C И OLE

Я
   Вадим
 
19.01.04 - 15:00
гОСПОДА! КАК ОТКРЫТЬ ФАЙЛ EXCEL(РАСШИРЕНИЕ .XLT) ИЗ
1 C
EXCEL=СОЗДАТЬОБЪЕКТ("EXCEL.APPLICATION") А ДАЛЬШЕ?
 
  Рекламное место пустует
   ezh
 
1 - 19.01.04 - 15:02
в Яндексе поищи. Вот что я сразу нашел:

Ексель=СоздатьОбъект("Excel.Application");

Ряд=0;
ЗапущенExcel = 1;

Если ЗапущенExcel=1 Тогда

  Попытка
   // открываем файл

    Ексель.Application.Workbooks.Open("a:\Отчет");
    ВходнойФайлОткрыт = 1;
  Исключение
    Ексель.Quit();
    Сообщить(ОписаниеОшибки(),"!");
  КонецПопытки;

КонецЕсли;

Ексель.Visible=1;
СпрКонт = СоздатьОбъект("Справочник.Контрагенты");
СпрЮрЛиц = СоздатьОбъект("Справочник.СвоиЮрЛица");
СпрКонт.ВыбратьЭлементы();

Пока СпрКонт.ПолучитьЭлемент(1) = 1 Цикл
  Ряд=Ряд+1;
  Столбец=1;
  Ячейка= Ексель.Cells(Ряд,Столбец);
  Ячейка.Value=СпрКонт.СвойКод;
  Столбец=2;
  Ячейка= Ексель.Cells(Ряд,Столбец);
  Ячейка.Value=СпрКонт.Hаименование;
  Имя=СпрКонт.ЮрФизЛицо;
  Сообщить(Имя);
  
  Если СпрЮрЛиц.HайтиПоРеквизиту("ПолнHаименование",Имя,1) = 1 Тогда
    Сообщить ("1");
  КонецЕсли
  
КонецЦикла;
   ezh
 
2 - 19.01.04 - 15:04
кстати, не XLT, а XLS.


Список тем форума
 
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует