Вход | Регистрация

1С:Предприятие ::

Метки:Типовые конфигурации, Типовые конфигурации

Комплексная, проблема выгрузки в Фин.Планирование

Я
   Gisborn
16.05.05 - 19:27
457 комлексная (Пример на ДемоБазе)
после синхронизации аналитики и настройки соответствия валют, создаем элемент справочника ФП_ВыгрузкаДанных (Настройка выгрузки данных для планирования):

Наименование: ИнноТрейд
Статья оборотов: Денежные средства -> Поступление денежных средств -> Оплата от покупателя -> ИнноТрейд

Отбор итогов:
Параметр: Счет дебета , Операнд: равно, Значение: 51
Параметр: Счет кредита, Операнд: равно, Значение: 62.2
Параметр: Субконто кредита - Контрагенты, Операнд: равно, Значение: Покупатели -> ИнноТрейд

Запускаем выгрузку в txt формате за 22.12.01 - 22.12.01
Вариант бюджета: План на месяц по дням (факт)
Не работает! Говорит:
0001: ИнноТрейд - в отборе по бухгалтерским данным нет ни одного значения.
Если отборе итогов поменять контрагента ИнноТрейд на группу ПОКУПАТЕЛИ, то работает! При этом в файле выгрузки будет сумма двух документов, один из которых по ИнноТрейду (все это видно по ОСВ по 51 счету). Что делаю не так? Нужно ли копаться в конфигураторе? Хочется разобраться с этим, xml не предлагать.

заранее спасибо
 
 
   Gisborn
1 - 17.05.05 - 05:49
Ладно, поставим вопрос по другому:

В выгрузке в ФП используется бух.запрос с ИспользоватьКорСубконто() с параметром значения корсубконто - СписокЗначений. Если подставить вместо списка значений - конкретный элемент справочника, то работает.

Кусок кода (со строки 3709 в 457 комплексной):
ТаблицаСубконто.ВыбратьСтроки();
Пока ТаблицаСубконто.ПолучитьСтроку()=1 цикл
    ИтБУ.ИспользоватьСубконто(ВидыСубконто.ЗначениеПоИдентификатору(ТаблицаСубконто.ВидСубконто),ТаблицаСубконто.ЗначенияСубконто);
КонецЦикла;
ТаблицаКорСубконто.ВыбратьСтроки();
Пока ТаблицаКорСубконто.ПолучитьСтроку()=1 цикл            
    ИтБУ.ИспользоватьКорСубконто(ВидыСубконто.ЗначениеПоИдентификатору(ТаблицаКорСубконто.ВидСубконто),ТаблицаКорСубконто.ЗначенияКорСубконто); 
КонецЦикла; 
Если СписокСчетов.РазмерСписка()>0 тогда
    ИтБУ.ВыполнитьЗапрос(НачИнтервала,КонИнтервала,СписокСчетов,СписокКорСчетов,ВалютаВыгрузки,2,ВариантБюджета.Периодичность,); 
Иначе
    ИтБУ.ВыполнитьЗапрос(НачИнтервала,КонИнтервала,СписокКорСчетов,,ВалютаВыгрузки,1,ВариантБюджета.Периодичность,);
КонецЕсли;

Если вместо ТаблицаКорСубконто.ЗначенияКорСубконто в

ИтБУ.ИспользоватьКорСубконто(ВидыСубконто.ЗначениеПоИдентификатору(ТаблицаКорСубконто.ВидСубконто),ТаблицаКорСубконто.ЗначенияКорСубконто);

поставить ТаблицаКорСубконто.ЗначенияКорСубконто.ПолучитьЗначение(1) то работает. Штука в том, что хотелось бы отбирать не по одному субконто а по их набору. Если же в Списке ТаблицаКорСубконто.ЗначенияКорСубконто присутствует группа справочника (содержащая необходимые элементы, как впрочем и те которые не нужны) то также работает на отлично.
Пихать необходимые элементы в новые группы, производить выгрузку, а потом возвращать их обратно несколько гемморойно.

Я так понимаю, что ошибка или в запросе или в обходе результатов запроса, но с обходом результатов не все ясно. Обход начинается циклом:

ИтБУ.ВыбратьПериоды();// строка 3795

Пока ИтБУ.ПолучитьПериод()=1 цикл
...
КонецЦикла;

ИтБУ.ПолучитьПериод() сразу равно 0 и выгрузка не происходит (в случае списка элдементов справочника). Или я туплю (что не исключено), или ИспользоватьКорСубконто не верно отрабатывается. 25 релиз, 457 компл. конфа.
   Rovan
 
2 - 17.05.05 - 05:58
(1) ИспользоватьКорСубконто(<ВидСубконто>,<Субконто>,<ТипФильтра>,<ПоГруппам>)
4 аргумента, какое у тебя значение ТипФильтра ?
   Gisborn
3 - 17.05.05 - 06:09
(2) Тип фильтра по умолчанию 1. Ставил 1 и 2  - не помогает
   Gisborn
 
4 - 17.05.05 - 07:50
На Т1С подсказали:

"Это глюк 1С.
Убери с свойствах субконто Контрагенты галку "Отбор" и все будет ОК"

И действительно заработало, еще бы знать где это аукнется.


Список тем форума
  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует