Вход | Регистрация

1С:Предприятие ::

Метки:

как разбить партии по складам в торговле

Я
   Кро
 
16.05.05 - 16:40
Сделать запрос по регистру ПартииНаличие с разбиением на склады, МОЛы не катят, у нескольких складов может быть одно МОЛ
 
 
   Ёпрст
 
1 - 16.05.05 - 18:02
(0)Никак ... Единственное, если только знать какие документы двигают регистр.
Но это слишком тупо :

|Склад = Регистр.ПартииНаличие.ТекущийДокумент.Реализация.Склад,
         Регистр.ПартииНаличие.ТекущийДокумент.ПроходТМЦ.Склад;

|Группировка Склад;
   Ёпрст
 
2 - 16.05.05 - 19:04
+1  Или сделай так :
врТекст="";
Для сч=1 По Метаданные.Документ() Цикл 
  Если Метаданные.Документ(сч).РеквизитШапки("Склад").Выбран()=1 Тогда
     рТекст=врТекст+"Регистр.ПартииНаличие.ТекущийДокумент."+
            Метаданные.Документ(сч).Идентификатор+".Склад,"+РазделительСтрок;
  КонецЕсли;
КонецЦикла;
Если ПустоеЗначение(врТекст)=0 Тогда
  //заменяем последнюю зпт на ";" 

   врТекст=СокрП(врТекст);
   врТекст=Лев(врТекст,СтрДлина(врТекст)-1)+";";
   ТекстЗапроса=ТекстЗапроса+"Склад = "+врТекст;
КонецЕсли;
   427
 
3 - 16.05.05 - 19:07
Партионный учет ведется в целом по предприятию...
   Ёпрст
 
4 - 16.05.05 - 19:12
(3)А причем тут это ?? У меня к примеру 7 складов. Нужно к примеру знать сколько реализованно с каждого склада ...
   Ёпрст
 
5 - 16.05.05 - 19:12
+4 А в регистре изначально тока МОЛ заложен.
   427
 
6 - 16.05.05 - 20:17
Мдя...
   Guk
 
7 - 16.05.05 - 20:41
(6) Что Мдя. Не видишь человек учет настраивает. С одного склада продали валенки по 40 руб, с другоого по 20 руб. Вывод: с первого склада прибыль больше. Второй склад надо нах закрывать. Учись...
   Убитая С Тазом
 
8 - 16.05.05 - 20:48
(7)Вань, ты чо??? там же "РеквизитШапки"... при чем тут "Валенки"?
   Guk
 
9 - 16.05.05 - 20:51
(8) Тем более. Просто я не знал как оценить РеквизитШапки для примера. Я в магазине просто РеквизитШапки ни разу не видел. С валенками более менее всё понятно...
   Убитая С Тазом
 
10 - 16.05.05 - 20:53
Понятная хня... Валенок вместо шапки... и по улицам... Гатична!!!
ПС. "Здеь метро, здесь гулять" нервно откуривают
 
 
   Guk
 
11 - 16.05.05 - 20:54
(10) Зато тепло ;)...
   Убитая С Тазом
 
12 - 16.05.05 - 20:56
И не говори , кума :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует