Вход | Регистрация

1С:Предприятие ::

Метки:

Обработка подбора

Я
   idv
 
16.05.05 - 15:41
Процедура ПриНачалеВыбораЗначения(ЭлементДиалога,Флаг);
  Если ЭлементДиалога = "Материал" Тогда
     Флаг = 0;
     ОткрытьПодбор("Справочник.Материалы",,,0,)
  КонецЕсли
КонецПроцедуры

Процедура ОбработкаПодбора()
   ****************
   *****************
   ********
   *********************
КонецПроцедуры

Почему-то после выполнения ОткрытьПодбор программа не попадает
в процедуру ОбработкаПодбора()??
 
 
   miki
 
1 - 16.05.05 - 15:43
Она должна туда попадать после выбора.
   miki
 
2 - 16.05.05 - 15:45
Ну и параметры-то передай...
   idv
 
3 - 16.05.05 - 15:45
Так после выбора и не попадает, а сразу записывает в документ.
   idv
 
4 - 16.05.05 - 15:46
А можно узнать какие параметры-то ???
   NDV
 
5 - 16.05.05 - 15:46
(4) ОбработкаПодбора(<Элемент>,<КонтФормы>)
   idv
 
6 - 16.05.05 - 15:50
Пишу так....и не заход в эту процедуру вообще.

Процедура ОбработкаПодбора(ВыбрМатериал) 
  
  НоваяСnрока();
  Материал = ВыбрМатериал; 

КонецПроцедуры
   YF
 
7 - 16.05.05 - 15:52
Я бы, для начала, написал
Если ВреГ(ЭлементДиалога)="МАТЕРИАЛ"
   idv
 
8 - 16.05.05 - 15:53
Причем здесь Если ВреГ(ЭлементДиалога)="МАТЕРИАЛ" ,
если в эту процедуру вообще нет захода.
   GrayT
 
9 - 16.05.05 - 16:02
Лови в обработкаВыбораЗначения
   idv
 
10 - 16.05.05 - 16:09
Ну спасибо GrayT, шарящий ты чувак (Очень помог!!!!).
 
  Рекламное место пустует
   miki
 
11 - 16.05.05 - 16:11
Да,  GrayT прав. Как всегда rtfm.
ПриНачалеВыбораЗначения
Предопределенная процедура при начале выбора значения.
Замечание. В теле этой процедуры методы ОткрытьФорму и ОткрытьПодбор работают для выбора.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует