Вход | Регистрация

1С:Предприятие ::

Метки:

как сделать реквизит для ввода времени

Я
   Lady_x
 
16.05.05 - 15:30
хочу вводить время в виде 17:00
 
 
   miki
 
1 - 16.05.05 - 15:36
Что мешает?
   laeg
 
2 - 16.05.05 - 15:36
Строка, длина 5
маска: 99:99
   Бодун
 
3 - 16.05.05 - 15:43
1. Поле ввода (фВремяЧасСек) типа "Строка" длины 5. На закладке свойств "Дополнительно":
1.1. Формула: ПроверитьВводВремениПоМаске(фВремяЧасСек)
1.2. Маска: 99:99
2. В модуле формы:
Процедура ПроверитьВводВремениПоМаске(парСтр)
    Перем тЧас,тМин;
    тЧас=СокрЛП(парСтр); тМин="00";
    Если Найти(тЧас,":")>0 Тогда
        тМин=СокрЛП(Сред(тЧас,Найти(тЧас,":")+1));
        тЧас=СокрЛП(Лев(тЧас,Найти(тЧас,":")+1));
    КонецЕсли;
    тЧас=Число(тЧас); тМин=Число(тМин);
    Если тМин>59 Тогда тМин=тМин-60; тЧас=тЧас+1; КонецЕсли;
    тЧас=тЧас-Цел(тЧас/24)*24;
    парСтр=Формат(тЧас,"Ч(0)2")+":"+Формат(тМин,"Ч(0)2");
КонецПроцедуры//ПроверитьВводВремениПоМаске

// Да здравствует самый информативный форум по 1С имени Стасика, страдающего манией величия!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует