Вход | Регистрация


О жизни... ::

Метки:

OFF: Сколько известно миру совершенных чисел?

Я
   Дудка Ахинеи
 
16.05.05 - 13:03
СОВЕРШЕННОЕ ЧИСЛО - это натуральное число, равное сумме всех своих правильных (т. е. меньших этого числа) делителей. Напр., 6=1+2+3 и 28=1+2+4+7+14 суть совершенные числа.

Ни кто не пробовал писать программульку по поиску?
 
 
   Кофеин
 
1 - 16.05.05 - 13:04
ща слабаем
   Grant
 
2 - 16.05.05 - 13:05
Вот как 1С совершенной станет, так сразу...
   Дудка Ахинеи
 
3 - 16.05.05 - 13:07
(1)Ненадо кода, друг мой. Особенно 1С-ного. Это на 1С писать - изврат. Да и один фиг, на любом коде - встретятся проблемы.
   Крутейший 1с-ник
4 - 16.05.05 - 13:07
(1) на 1с-е ес-но!
И найдет она след совершенное число!

Всякие там пишут на асме для Супер-пупер ЭВМ,
а мы 1с-ке!
   гость11
5 - 16.05.05 - 13:10
Насколько я помню, самое большое число то ли 50, то ли 150 знаков. Короче очень большое, и программа работала не один месяц.
   SnarkHunter
 
6 - 16.05.05 - 13:13
А чего их искать... Есть формула Евклида, которая описывает все совершенные четные числа...

Про существование (а равно и про отсутствие) нечетных совершенных чисел науке пока ничего низвестно...
   Rovan
 
7 - 16.05.05 - 13:16
(0) А зачем ? В чем польза народному хощзяйству ?
   Дудка Ахинеи
 
8 - 16.05.05 - 13:17
(6)Это я знаю. Вопрос и стоит какое кол-во этих чисел уже известно.
ЗЫ: Ребенок заставляет писать программу :)
   Дудка Ахинеи
 
9 - 16.05.05 - 13:17
(7) Любопытство.
   lamerULLIE
10 - 16.05.05 - 13:22
Совершенное число - это уйма вычислений в каждой следующей итерации, поэтому я даже и не пытался вешать свой комп на 1000...000 лет для подобных вычислений.

Самое большое число на сегодняшний день пока неопределено.
А Самое большое на сегодняшний день - смотри (5)
 
  Рекламное место пустует
   Дудка Ахинеи
 
11 - 16.05.05 - 13:26
LOL: "Самое большое число на сегодняшний день пока неопределено.
А Самое большое на сегодняшний день - смотри (5)"
   SnarkHunter
 
12 - 16.05.05 - 13:26
   Дудка Ахинеи
 
13 - 16.05.05 - 13:38
хмм
   Cerrg
 
14 - 16.05.05 - 13:39
Процедура ПоискЧисел
   КоличествоЧисел = 0;
   ИскомоеЧисло = 2;
   Пока ИскомоеЧисло < 10000000000000000000000000000 Цикл    
       СуммаЧастных = 0;
       ДелительЧисла = 1;
       СовершенноеЧисло = "";
       Пока ДелительЧисла <= ИскомоеЧисло/2 Цикл
           ЧастноеЧисла = ИскомоеЧисло/ ДелительЧисла;
           Если ЧастноеЧисла = ЦелоеЧисло(ЧастноеЧисла) Тогда
               СуммаЧастных = СуммаЧастных + ЧастноеЧисла;
           КонецЕсли;
           ДелительЧисла = ДелительЧисла +1;
       КонецЦикла;
       Если СуммаЧастных = ИскомоеЧисло Тогда
           СовершенноеЧисло = СовершенноеЧисло + Текст(ИскомоеЧисло) + "; ";
           КоличествоЧисел = КоличествоЧисел + 1;
       КонецЕсли;
       ИскомоеЧисло = ИскомоеЧисло + 1;
   КонецЦикла;    
   Сообщить(СовершенноеЧисло);
   Сообщить(КоличествоЧисел);
КонецПроцедуры



Функция ЦелоеЧисло(ПроверяемоеЧисло) Экспорт
   ЦелаяЧастьЧисла = Сред(ПроверяемоеЧисло, 1, Найти(Текст(ПроверяемоеЧисло), "."));
   Возврат ЦелаяЧастьЧисла;
КонецФункции



Вроде так....
   Кофеин
 
15 - 16.05.05 - 14:07
496 :)
   Кофеин
 
16 - 16.05.05 - 14:08
у меня 13 строчек получилось
   Tabo
 
17 - 16.05.05 - 14:10
а может еще и числа мерсена поискать
   Кофеин
 
18 - 16.05.05 - 14:30
8128
я думаю хватит пока
   Дудка Ахинеи
 
19 - 16.05.05 - 14:36
(18) :)
У меня еще дите про числа Фибоначи (Открыл Леонардо Пиззанский Фибоначи) мне заливает... Но я уже и не помню что за числа.  Мне тоже отец сказки такие перед сном рассказывал, теперь вот моей дочке заливает... А она потом на мне отрывается...
   Кофеин
 
20 - 16.05.05 - 14:46
(19) Уточни и запомни :)
   kolys_new
 
21 - 16.05.05 - 14:54
а ты не в курсе, уважаемый гений, что за тебя этот вопрос давно решили? Еще до рождения христова?
У греков было понятие (практически "гештальт") - "золотое сечение"

-------------------
ЗЫ  Если что, 1,2,3,5,8,13,21, ...
архимедова пентаграмма целиком и полностью построена на этом "сечении". Это твоя октябрятская звезда, если помнишь.
   Кофеин
 
22 - 16.05.05 - 14:56
(21) Эт Вы кому, уважаемый? :)
   Кофеин
 
23 - 16.05.05 - 14:58
кстати, для справки :
6, 28, 496, 8128, 33550336, 8589869056, 137438691328, 2305843008139952128
   kolys_new
 
24 - 16.05.05 - 14:58
(22) дудке. как зачинателю изначально абсурдной ветки
   Cerrg
 
25 - 16.05.05 - 14:58
Правильно так:



Функция ЦелоеЧисло(ПроверяемоеЧисло) Экспорт
   ЦелаяЧастьЧисла = Сред(ПроверяемоеЧисло, 1, Найти(Строка(ПроверяемоеЧисло), ".") - 1);
   Возврат ЦелаяЧастьЧисла;
КонецФункции

Процедура ПоискЧисел()

   КоличествоЧисел = 0;
   ИскомоеЧисло = 6;
   СовершенноеЧисло = "";

   Пока ИскомоеЧисло < ПределПоиска Цикл    
       СуммаДелителей = 0;
       ДелительЧисла = 1;

       Пока ДелительЧисла <= ИскомоеЧисло/2 Цикл
           ЧастноеЧисла = ИскомоеЧисло/ ДелительЧисла;

           Если Строка(ЧастноеЧисла) = ЦелоеЧисло(ЧастноеЧисла) Тогда
               СуммаДелителей = СуммаДелителей + ДелительЧисла;
           КонецЕсли;
           ДелительЧисла = ДелительЧисла +1;

       КонецЦикла;

       Если СуммаДелителей = ИскомоеЧисло Тогда
           СовершенноеЧисло = СовершенноеЧисло + Строка(ИскомоеЧисло) + "; ";
           КоличествоЧисел = КоличествоЧисел + 1;
       КонецЕсли;

       ИскомоеЧисло = ИскомоеЧисло + 1;
   КонецЦикла;    

   Сообщить("Совершенные числа: " + СовершенноеЧисло);
   Сообщить("КоличествоЧисел: " + КоличествоЧисел);
КонецПроцедуры




ЗЫ ПределПоиска - реквизит формы....
   Кофеин
 
26 - 16.05.05 - 14:59
такое чуйство, шо совершенные числа встречаются все реже и реже.....
   Дудка Ахинеи
 
27 - 16.05.05 - 15:00
(24)пшел нах из моей ветки
   kolys_new
 
28 - 16.05.05 - 15:01
(27) обоснуй
   Cerrg
 
29 - 16.05.05 - 15:05
(23) Это по какому принципу считал?
   Кофеин
 
30 - 16.05.05 - 15:09
(29) По принципу поиска, основываясь на уже найденных :)
   Кофеин
 
31 - 16.05.05 - 15:10
(27)
Cуть последовательности Фибоначчи в том,что начиная с 1,1следующее число получается сложением двух пpедыдущих.

последовательность 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, ... называются " числами Фибоначчи",
   Дудка Ахинеи
 
32 - 16.05.05 - 15:13
(31) Да владею я поиском, чудный ты мой :) Давно уже не актуально.
   kolys_new
 
33 - 16.05.05 - 15:17
(31) Фибоначчи был далеко не первым
 
 
   Cerrg
 
34 - 16.05.05 - 15:18
(30) Это как?
   Кофеин
 
35 - 16.05.05 - 15:18
(32) Нет ты посмотри на нее, надрываешься, надрываешься тут ради нее, ветку поддерживаешь......
а она..... тьфу на вас
   Кофеин
 
36 - 16.05.05 - 15:20
(34) А ты поиском не владеешь?
   Дудка Ахинеи
 
37 - 16.05.05 - 15:32
(35) :) Ну ладно, тебе... Не обижайся. Я хорошая, гдето глубоко глубоко внутри :)
   Cerrg
 
38 - 16.05.05 - 15:34
(36) Да как сказать, владеть-то, наверное, владею, только у меня доступ есть только сюда, в 1С и еще пару мест....
   Кофеин
 
39 - 16.05.05 - 15:37
(37) Внутри или в душе? А то как -то эротикой повеяло..... :)
(38) На яндекс доступ есть?
   kolys_new
 
40 - 16.05.05 - 15:38
(37) глубоко внутри все вы замечательные. Через одну
   Cerrg
 
41 - 16.05.05 - 15:59
(39) Угу, только на титульную страницу - курс смотреть.... =(((((
   Кофеин
 
42 - 16.05.05 - 16:01
(41) Кто эт тебя так жестоко обрезал?
   Cerrg
 
43 - 16.05.05 - 16:17
(42) Корпоративная политика - у нас работает несколько сотчеловек, вот и обрезали всем, а доступ к апределенному ресурсу получить очtym тяжело...
   Кофеин
 
44 - 16.05.05 - 16:18
(43) Чо за контора, если не секрет? (для статистики)
   Cerrg
 
45 - 16.05.05 - 16:39
(44) Гарантовская компания
   Кока
46 - 16.05.05 - 17:51
(45) Меняй контору - жлобьё..... не знал, что уже до этого дошли
   Cerrg
 
47 - 16.05.05 - 18:18
Да фиг с ними, пока з/п и коллектив устраивают буду работать
   Бивень
 
48 - 16.05.05 - 18:20
(47) Ты нашёл уже следующее совершенное число?
   ado
 
49 - 16.05.05 - 18:33
А мне друг рассказывал, он учился на физфаке МГУ, так вот когда он был на 1-м курсе у них была игра, называлась -- "письками меряться". Кто точнее число пи посчитает. Ну народ на своих домашних писюках 500 000, 1 000 000 знаков выдавали, пока один парниша, имевший доступ к вычислительному кластеру ЦУПа не принес число пи на 4-х болванках. После этого перестали меряться.
 
 



Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует