Вход | Регистрация

1С:Предприятие ::

Метки:

Лоха надо ткнуть носом.. Как по значению в СпискеЗначений найти элемент..

Я
   aka AMIGO
 
16.05.05 - 10:43
РегистраСведений?
Код у меня такой:
    Рег =  РегистрыСведений.РаботникиОрганизаций;
    ВыбСотр = Рег.Выбрать(,);
    СписокСотров = Новый СписокЗначений;

    Пока ВыбСотр.Следующий() Цикл
         СписокСотров.Добавить(ВыбСотр.ФизЛицо);
    КонецЦикла;

    СписокСотров.СортироватьПоЗначению();

    Кол = СписокСотров.Количество();
    Для х=1 По Кол Цикл
              ...1) Надо_получить_значение_из_спискаЗначений;
              ...2) Надо_найти_запись_в_Рег_по_СЗ..

        КонецЦикла;

ЗЫ. оччень трудно перестроиться от 7.7, которой занимался 6-7 лет.. пока в голове мешанина с преобладанием 7-рочных решений... это второй день мой в 8-ке..
надеюсь, по голове получу не очень больно :))
 
  Рекламное место пустует
   Rovan
 
1 - 16.05.05 - 10:52
(0) У тебя РаботникиОрганизаций - периодический регистр ?
   aka AMIGO
 
2 - 16.05.05 - 10:54
для первого вопроса нашел решение:
СотрИзСЗ = СписокСотров.Получить(х);

для второго: .. пока нет.. что-то типа Рег.Найти(..)
ЗЫ весь 7-рочный язык у меня в голове, а вот 8-чный - в книжке.. когдааа-то перекачаю в мОзги :))
   aka AMIGO
 
3 - 16.05.05 - 10:55
1. да,  "В пределах дня"
"Подчинение регистратору"
   aka AMIGO
 
4 - 16.05.05 - 10:59
на сей момент мне нужна только сортировка выборки по алфавиту. Может существовать решение выбрать сразу из регистра с упорядочением..
   aka AMIGO
 
5 - 16.05.05 - 11:16
+3 может у меня насчет периодичности прокол?..
я просмотрел все регистры сведений, у всех установлена эта Периодичность.. :(
Может быть у регистровСведений где-нть в конфигураторе устанавливается другой признак Периодичности?
   aka AMIGO
 
6 - 16.05.05 - 13:54
а вот - решение:

ЗапросС = Новый Запрос;

 ТекстЗапросаПоСотрам =
 "ВЫБРАТЬ
 |Работники.ФизЛицо КАК ФизЛицо
 |ИЗ
 |РегистрСведений.Работники КАК Работники

 |УПОРЯДОЧИТЬ ПО
 |ФизЛицо.Наименование ВОЗР";
 ЗапросС.Текст = ТекстЗапросаПоСотрам;

 Сотры = ЗапросС.Выполнить().Выбрать();

 Пока  Сотры.Следующий() Цикл

  ФизЛицо = Сотры.ФизЛицо;
... ...
КонецЦикла;

век живи, век учись.. в сабже код, думается, тупиковый..
час потратил на первый запрос.. простецкий, конечно, только надо ведь что-то знать, чтобы хоть такой составить..


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует